How to fix my S6 that sometimes is "Not registered on network"

magenta1911537

    I have a Galaxy S6.  I bought it a few months ago, never used.  It came to me set up for T-Mobile.  WIFI calling works fine.  In many locations the phone also works well with the T-Mobile cellular network.  But it just happens that it will NOT work in my local area where I need it most.  When I try to make phone calls, or access the internet, I get the message, "Not registered on network".  This is so even if the full 4 bars of signal strength are indicated.  I m getting CRAZY please HELP!!!!!!

      All replies

      • artart

        Hi magenta1911537

        Welcome to the T-Mobile Community Support Forum

         

        Usually the remedy for your problem would be to check the network settings in the phone and or verify that there are no problems with the SIM Card  or its connection.

         

        I suspect that the solution to your problem might lie elsewhere.

        Could you please answer a few questions?

         

        Is your phone a new T-Mobile branded phone? Did you buy it used and just delay using it for a few months? A non T-Mobile phone from another carrier will not make use of all of the available frequency bands that T-Mobile uses. I have a Verizon branded S7  "set up"  for T-Mobil that works fine, but has different reception capabilities and download speeds depending upon proximity to various cell towers. Different T-Mobile cell towers may make use of different frequency bands.  My  S6 purchased from T-Mobile, can receive all of the frequency bands that the T-Mobile network uses. My S7, since it only receives the frequency ranges within the bands used by Verizon,  does not receive all of the T-Mobile bands available in my area. It just receives those bands which T-Mobile uses that are in the same range of those used by Verizon.

         

        I suspect that you might have a phone that receives some working T-Mobile bands in some areas, but might not have the capability of receiving the specific bands that T-Mo uses in  your local area. If the phone can do Wi-Fi calling, it is obviously not a Verizon phone setup for T-Mobile. Is your phone possibly an AT&T branded phone? If your phone is actually a T-Mobile phone sold by T-Mobile , and not a phone sold by another carrier which was configured (or set up) to work on the T-Mo network, the solution to your problem should be fairly easy. 

         

        Have you updated your S6 to Nougat yet?

         

        Until you are able to provide some of the additional info I requested,

        I will for now, suggest some simple traditional solutions that may fix your problem.

         

        1. The first and simplest step to take is to disable

        all of the phone's wireless connectivity by turning on Airplane Mode.

        After a few minutes turn Airplane mode off. Is the problem solved?

         

        2. Power the phone off and reboot.

        Some time that simple step fixes the problem.

         

        3. Verify the following setting:

        Go to "Settings > Connections > Mobile networks > Network mode > . . . select  >  LTE/3G/2G (auto connect)

         

        4. If none of those simple steps work,

        wipe the cash partition.

         

        1. Power off the phone by pressing and holding the "Power" button then select "Power Off"

        2. Simultaniously press and hold the "Volume Up" button, the "Power" button and the "Home" button until the splash screen or the android guy appears then let go of all buttons.

        3. If the system updates, just wait until it finishes updating and you see a menu that says "Android recovery at the top."

        4. Use the volume down button to highlight "Wipe cache partition". Be sure you select only "Wipe CACHE PARTITION".

        5.Press the power button to select that option.

        6.When asked to confirm "Wipe Cache? use volume down button to highlight "yes"

        7. Use power button to select "yes".

        8. You will then see reboot system now highlighted.

        9. Use power button again to select the Reboot system option.

         

        If the above steps do not solve the problem, the next step is to verify that the SIM card is not the culprit. I have included those steps in a separate reply.

         

        Art

          • magenta1911537

            Hi Artart,

             

            Thank you for your reply regarding my case but i did follow all the steps in your reply unfortunately none of them works for me. I did remove the SIM card for a while and put it back again to the phone, it works just for 1 phone call after trying another call I got the same message " Not registered on network".

             

            Any other suggestion pls?

             

            P.S: my phone is  a T-Mobile phone sold by T-Mobile , and not a phone sold by another carrier.

             

            Thank you!

              • artart

                Hi magenta1911537

                Rather than try to provide too many options at once,

                I would like to address the Nougat update. What is the Operating System on your S6?  Did you update it to Nougat yet ? My S6 updated to Nougat and works fine. Any step by step instructions in settings might be slightly different between Marshmallow and Nougat.

                 

                There is also another troubleshooting procedure that I always try no matter what the problem is. It is what is called a simulated battery pull. On the S6 press and hold the volume button down key plus press and hold the power button key simultaneously for 8-10 seconds. When the phone turns off you can release the buttons and the phone will reboot automatically.

                 

                What has worked for me in the past was to call 611 customer support on the phone,

                and ask to speak to tech support. The technical support experts really know their stuff. They can run tests on your phone remotely and also can determine if there is any network trouble in your "area" ?

                 

                Also, do you know anybody else with T-Mobile service, who might be able  to check to see if they have the identical problem in your area? How far away from your house (out of your area) do you have to get before you no longer have the issue? Answers to those questions would give me some idea of what could possibly be causing an area or location problem. Are you using a new SIM card? Did the SIM card come with the phone? Did the phone ever work properly at home?

                 

                If your phone hasn't updated to Nougat yet, I would consider wiping the cache again and then updating to Nougat . That might solve the issue. There are still some other things that could be tried, but see how any of these additional suggestions work first.

                 

                Art

            • artart

              Hi again magenta1911537

              The following are some additional basic trouble shooting steps

              which may or may not remedy your problem. Since your phone works in some locations and not others it suggests a coverage or reception issue based upon location, not a phone or SIM card malfunctioning issue.

               

              The phone not reading the SIM card,

              is frequently the reason that a phone receives

              the "Not Registered on Network" message.

              Some of the reasons that the SIM card might malfunction are:

              • The SIM card may may not be making proper contact.
              • The SIM card may need to be cleaned.
              • The SIM card may be faulty.

               

              Remove SIM card and inspect contacts for damage or foreign matter. Buff the

              contacts with a clean dry lint free cloth. Carefully reinsert SIM card  insuring

              a proper fit. Verify that the card fits snugly. See if that solves the problem.

               

              At this point, I would try using another SIM card which is known to be

              operational. If another SIM card is not available to verify the current SIM

              card is not at fault, I would proceed to take the next trouble shooting steps.

               

              Reset Phone Dialer:

              To reset the dialer app,  go to "Settings> Application Manager > All Apps".

              Scroll down to and select "Phone App". Next select "Wipe Cache".

               

              Please let us know how you are making out so far.

               

              Art

              • magenta1911537

                Hello Art

                Below the infos below of my S6

                 

                Android version : 5.0.2

                Model: SM-G920T

                 

                I did not update it and I don't really know the step to do it.

                  • artart

                    magenta1911537 wrote:

                     

                    Android version : 5.0.2

                    Model: SM-G920T

                     

                    I did not update it and I don't really know the step to do it.

                    Hi magenta1911537

                    The most recent version of Android (7.0) that is available

                    from T-Mobile for the S6, can be found at the top of this page.

                     

                    The Version is G920TUVU5FQE1.

                     

                    Updating your operating system to Android 7.0 is definitely your next step.

                    The instructions for how to update to "Baseband Version G920TUVU5FQE1"

                    are at the bottom of the above linked page.

                     

                    After the update is complete, I would recommend performing the wipe cache procedure again.

                     

                    Let me know if you have any questions about updating your phone.

                     

                    I am hoping that updating the operating system, will fix your "Not Registered" issue.

                     

                    Art