magenta1484059

    I gave my friend my ATT Samsung S7 Edge. I first had it unlocked.  We then took it to the store, and they activated it with a SIM.  She can make phone calls, text, and use her home Wi-Fi, but she soon discovered she cannot connect to the internet outside her home. We took it to the store again, and they put the SIM in another phone, and it worked.  Store employees called tech support and could not get it to work. I called tech support, and they had me manually put in Access Point Names (erc.tmoble.com and fast.t-mobile.com).  Neither APN worked--although we did get a 4G symbol.  I will add the phone has the latest ATT version of Nougat.  It has been over 2 weeks, and she still cannot use mobile data, and no one seems to know why!!! I suggested she leave T-Mobile for ATT as it is an ATT phone, but she likes T-Mobile.  Anyone have any suggestions. The only thing I can think of is going back to her Note 3, or possible doing a factory reset.

      All replies

      • alfer64

        We too are having issues with our unlocked  AT&T S7. We just switched to T-Mobile last week.

         

        Tech support had us change the APN info, but that didn't work. We are now waiting on "Engineering" to figure this issue out.

         

        One interesting note about this that I discovered.  If I turn the Airplane Mode on, then off, like magic I have full data coverage, as long as you don't reboot the phone. If you reboot, you lose data and you have to do the Airplane Mode trick again.

         

        I hope they can figure this out soon. All of our other phones work fine (iphones and my Axon 7). Hard to believe the supposed flagship phone is having this kind of issue.

        • magenta1556610

          I had a similar situation with a recently unlocked AT&T Samsung S7 (Model: SM-G930AZDAATT) on Android 7.0. When I initially inserted the nano SIM card the mobile network worked just fine (I was even able to use the phone as a mobile hotspot for my laptop), but suddenly the mobile data didn't work. Long story short here is what I did.

           

          I went to Settings --> Connections --> Mobile networks --> Access Point Names, pressed the three dots on the top right, and selected "Reset to default." The phone did its thing and then a bunch of APNs showed up (I had originally deleted all APNs except the T-mobile APN). One of those APNs was called "T-Mobile GPRS" and it had "fast.t-mobile.com" underneath it. I selected it and in the "Edit Access Point" screen I changed the "Name" from "T-Mobile GPRS" to "T-Mobile." Then, under "MMSC" I typed "http://mms.msg.eng.t-mobile.com/mms/wapenc". Next, under "APN type" I changed the text from "default,supl" to "default,supl,mms". Finally, I pressed the three dots on the top right, selected "Save", and restarted the phone.  When the phone rebooted the mobile data worked.  I realize that most of what I wrote is already documented elsewhere ( Generic T-Mobile data settings under "Android APN settings"), but I think the difference for me was resetting the default APNs which I described at the beginning of this paragraph and then following the procedure in T-Mobile's Generic data settings support page.

           

          I also noticed that after the phone rebooted an APN called "T-Mobile MMS" showed up in the list. This is likely to be because of what I typed under MMSC and/or APN type. Anyway... In summary, here is my APN configuration (which at the time of this writing I have mobile data working):

           

          Name: T-Mobile

          APN: fast.t-mobile.com

          Proxy: Not set

          Port: Not set

          Username: Not set

          Password: Not set

          Server: Not set

          MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

          Multimedia message proxy: Not set

          Multimedia message port: Not set

          MCC: 310

          MNC: 260

          Authentication type: Not set

          APN type: default,supl,mms

          APN protocol: IPv6

          APN roaming protocol: IPv4

          Turn APN on/off: APN turned on (this is grayed out)

          Bearer: Unspecified

          Mobile virtual network operator type: None

          Mobile virtual network operator value: Not set (this is grayed out)

            • alfer64

              Perfect, thanks! Wil give it a shot tonight. I fear T-Mobile support engineers will never follow up on my ticket they claim the created.

               

               

              • alfer64

                Tried your trick with no luck.  The minute you reboot the phone, the data (4G/LTE) stops working.

                 

                Help T-Mobile!!

                  • stevetjr

                    Re: ATT Samsung S7 Edge mobile data not working

                    Rather than editing an existing APN have you tried just manually creating one then select that one as the active APN?

                      • alfer64

                        Re: ATT Samsung S7 Edge mobile data not working

                        I don't believe I've tried this.

                         

                        I talked to tech support yet again and of course they had no record of a ticket being given to the "engineers" so I had to start all over again and this time the tech guy created a new ticket of which I got the ticket # for to keep track of. The main tech guy couldn't solve things, but did suggest I get new SIM card which I did but no luck, Same issues. ugh

                          • alfer64

                            Re: ATT Samsung S7 Edge mobile data not working

                            What I'd love is if I could just do an even trade in of this  mint condition AT&T S7 for a T-Mobile version and call it good, my wife of course is regretting this switch.  So as they say, Happy wife, happy life. 

                              • tmo_mike_c

                                Re: ATT Samsung S7 Edge mobile data not working

                                Oh alfer64  we really want you to have a happy life and when you're wife is regretting the switch, we know that'll make things tough. If you're still interested you can Trade in your device and get a T-Mobile branded phone. Might be a better option if the data is still giving you fits on your Non-T-Mobile phone. When your bring your device from another carrier, it should be as easy as entering the settings, and the data should would. But hey, sometimes it's not that what happens even with the correct settings. Please keep us posted on if you're keeping this phone or if you're gonna trade it in. We'd just like to make sure you're able to use the service, and you're wife is happy with the switch.

                                  • alfer64

                                    Re: ATT Samsung S7 Edge mobile data not working

                                    I'd love to swap this phone but not willing to add an extra $20-30 per month to my bill to get it.

                                      • tmo_mike_c

                                        Re: ATT Samsung S7 Edge mobile data not working

                                        Okay, I understand. Just wanted to let you know trading in that phone was an option if you really wanted to. Currently, I'm not seeing any phone offers right now that might peak your interest, but you can always keep in eye on dedicated offers page just in case something pops up. As I mentioned before, the settings can be kinda hit or miss on Non-T-Mobile devices. If all the settings are correct, testing the data in a T-Mobile branded phone would be the next step. If it works, it's definitely gonna be something strange going on with that device. If data doesn't work in our branded phone, we'd need to revisit a network Trouble Ticket and get engineers to take another look at your data connection.

                              • magenta1556610

                                In hindsight, I unwisely rebooted my phone because after the reboot the mobile data stopped working. I tried many times what I wrote previous post and didn't work. I even tried the APN settings from my wife's [I can truly related to "happy wife, happy life"] phone (an unlocked Moto G4 Plus I got her from Best Buy) and my unlocked Nexus 5 APN settings, and every time I changed the APN settings I rebooted the phone as instructed (suggested?) in T-Mobile's Generic data settings support page with no success.

                                 

                                Here is what I did. I set the APN settings for the S7 to be equal to those of my Nexus 5 (which turned out to be the same as those I posted on May 23), did not reboot the S7, removed the SIM card from the S7, and inserted the SIM card into the Nexus 5 (the Nexus 5 was already powered on). The mobile data worked just fine on the Nexus 5 which ruled out that something was wrong with the SIM card. I removed the SIM card from the Nexus 5 and inserted the SIM card into the S7, but did not restart the S7, and the mobile data worked! I did this on Monday (5/29) and the mobile data in the S7 has been working since then.

                                 

                                If you don't have another phone to test the SIM card like I have, maybe removing the SIM card from the S7 while the phone is powered on and then reinserting it and not rebooting the phone might do the trick... Hope this helps.

                                 

                                All I know is that I'm not rebooting that S7 for as long as I can to avoid going through this again.  =)

                                 

                                As an aside, I briefly considered the trade-in, but quickly rejected it when I found out that I would get an estimated $131 for the phone.

                                Thanks for the suggestion and thanks to tmo_mike_c for providing the link.

                                  • gunn317

                                    So I just switched from AT&T to T-Mobile and noticed with my AT&T Samsung Galaxy S7 phone I am unable to use mobile cellular data. This thread fit my situation perfectly. I just wanted to know @magenta1556610 as a follow-up if your phone has been working fine since your recommended fix? Do you still have issues after a reboot, or is it all good now?

                                    Thanks,

                                      • magenta1556610

                                        gunn317 the mobile data in the S7 has been working since I recommended the fix, but I still have the issue after the reboot as detailed below. This gave me the chance to test the fix I recommended.

                                         

                                        On June 4, I rebooted the S7 (because I wasn't receiving text messages) and, as expected, the mobile data didn't work. I waited until the "4G LTE" symbol appeared on the status bar, removed the SIM card, and inserted it back without rebooting the phone. It took a couple of attempts, but it got the mobile data working again and has been working since then (I haven't rebooted the phone since June 4).

                                          • gunn317

                                            Thanks for the reply! So I followed your instructions that are marked as the answer, with the modification you posted on May 31, 2017 6:29 PM about not rebooting the phone. My only difference was that once I applied the settings and took out the sim card, I just waited for a few seconds and then inserted the sim card back in. I didn't place it in another T-Mobile phone.

                                             

                                            As soon as I placed it back in and it recognized it, the internet started working over cellular! It's been fine since, though I have not yet rebooted it (afraid to!).

                                             

                                            Note that I never had an issue with text messages, or texts with pictures...just internet over mobile/cellular.

                                             

                                            Thanks for being so clear with your instructions, I didn't have to guess at anything, you had them very well laid out.