accessing this support site by tapping "Help" in DIGITS app has problems

^_^

    iPad.  WiFi.  iOS 9.

     

    If I tap "Help" in DIGITS, it displays the support site embedded in a window.  I tried accessing this community through there to post, but it was quite unresponsive.  That window didn't always respond when I tried to scroll or tap a link/UI element, and often highlighted text on the page instead, or just did nothing.

     

    This was observed while the app was trying to activate the line for a few minutes.  I don't know if that's related.  I finally made the embedded browser window go away by navigating elsewhere in DIGITS, and just accessed this site via Safari, which worked fine (though forum navigation is rather unintuitive here).

     

    Thanks!

      All replies

      • tmo_mike_c

        Hey there and thanks a bunch for helping out in the beta.

         

        Just to be clear, is support site only acting weird when you go through the "Help" option with the DIGITS app? I'm just curious if it works if you go through the normal browsers. If it does, can you try uninstalling and reinstalling the DIGITS app? Give it another shot and let us know how things are going. Thanks!

        1 of 1 people found this helpful
          • ^_^

            Hi there.  Sure thing.  I appreciate the positive attitude and helpful replies I'm getting here, so thanks to everyone for that.

             

            Yes, support site is only acting weird if I use the Help option in DIGITS (on an iPad).  I normally (like right now) use it from Safari on the same iPad, where it works fine.  I just verified that it still has the same issues via the DIGITS app.  DIGITS is now on version 1.0.30.  The longer I tried to use the site through DIGITS' Help today, the less responsive it seemed to get, and it took awhile to get off the Help screen in the end, as whatever was going on seemed to make all of DIGITS become less responsive (unless it was making he whole iPad less responsive -- I'm not sure).

             

            The issue occurs even when the line is in "active" state, I can clarify, based on today's test.

             

            I hesitate to rush to reinstalling, as I just did that three days before reporting this issue, to resolve another issue: Re: The latest update doesn't work on my iPad, but I can do so in the coming days if you still would like me to try that.

             

            Thanks Chris for following up, too.

              • tmo_chris

                Thanks for clarifying! I don't have an iPad to test with but I am using an iPhone 7+. I just tested it on 1.0.29 and 1.0.30 and it seemed pretty responsive. Are you logged into the support community when viewing it through DIGITS? Also, go ahead and update your DIGITS app and test it through the new version.

                 

                Lastly, this one is silly I know, but try and do a quick reboot on the tablet after installing the update before attempting to navigate the support site through DIGITS.

            • tmo_chris

              Just wanted to check in here and see how things are going. Are you still having issues with the site through the DIGITS app?

              • tmo_chris

                Just wanted to check in here to see how things were going. Is the support community still acting weird when accessing it through DIGITS?

                  • ^_^

                    Apologies for the delay.

                    Well, I started a reply a couple/few hours ago to say the issue continues, but then I remembered your request to try restarting the iPad before testing...

                     

                    I initially checked before restarting with DIGITS 1.0.31, which is the version my iPad automatically updated to last night.  After restarting, I didn't test it right away.  When I returned, the iPad had updated to 1.0.32, and I tried again (without restarting the iPad a second time), and ... The issue seems resolved, at least from a fairly fresh iPad start.

                     

                    I succeeded in signing in and am writing this from within the embedded browser.

                    There are some problems with using the site, but not the one described here.  The site has rendering problems at the resolution of the window  the embedded Help browser, even in landscape mode, on this device.  The issues go beyond having to scroll around a lot to use the site; there are overlapping elements in the page header when it is in fixed position (after scrolling down the page) in Communities, and the login link did not work with the header like that (scrolling to the top of the page and then right allowed me to access the login link, when the header was rendered without error).

                     

                    Also, editing this post has been tedious, as ordinary interaction with the editor is not fully working.  I can not position the cursor by tapping, and I cannot correct a mistyped word by tapping on it.

                     

                    And although I'm not noticing the site being especially slow right now, the editor response is.  Typing on the keyboard, I get well ahead of the input, which seems  displaying what I typed (and highlighting the characters on the keyboard) at something like a 110 baud modem's speed.  Dated reference, but maybe 10 characters per second.  I'm only experiencing this in DIGITS.

                     

                    My iPad is a 3rd Gen. Model MD329LL/A, in case that's effecting my app update schedule or otherwise of interest.

                     

                    I'll try the Help browser more in the future and let you know if the issue re-presents itself in the way I originally described it.

                     

                    I may be slow to respond, but I will definitely reply to inquires.

                     

                    Thanks!

                      • tmo_chris

                        Thanks so much for testing this! We recently redesigned the support website for desktop and added mobile support. Part of me thinks that you may be seeing a problem that we did not catch in testing. Are you able to reproduce these same behaviors when logging into the support site using your Safari browser or is this only happening when accessing support through the help section of the DIGITS app?

                          • ^_^

                            None of the issues I described before or in my last post have presented themselves in Safari — only in DIGITS. 

                             

                            I just noticed that in Safari, the site automatically zooms/scales; evident when I switch between landscape and portrait.  In DIGITS, it looks like it's always displayed at the same zoom; perhaps the same as what I see in portrait mode (the larger zoom) in Safari (the community/forum name seems like it might be a little bolder in DIGITS too).  If it scaled some — gosh — that would help reduce all that horizontal scrolling I have to do in DIGITS to use the site, too.

                              • tmo_chris

                                Thank you so much for clarifying! We are going to look into this one and see what options are available. I am thinking that with our recent redesign of the support site (happened after DIGITS beta started) where we started supporting mobile browsing, the DIGITS integrated browser is still trying to render the support site in the old desktop view instead of the new and improved mobile experience.