iOS app usually frozen when I go to use it (iOS 9, iPad)

^_^

    The iOS app on my iPad is usually frozen when I switch to it.  I leave it on the dialer screen and leave it open in the background after using it, and when I switch back to it (usually after some days), it is unresponsive.

     

    If I close the app and restart it, it is responsive but the line is inactive.  I can fix that by closing and reopening the app again, at which point it becomes active immediately, however, today I noticed that it became active after several minutes when I just waited. Either way, it seems like something is not going smoothly.  While it is inactive at startup, the toggle to activate/deactivate the line is just a spinning wheel and cannot be toggled.

     

    This iPad is always on WiFi or not online, as it doesn't have cellular data support.  iOS 9.

     

    If there is a solution on my end, I welcome it, otherwise, I hope this can be fixed in the future.

      All replies

      • ^_^

        P.S.  I just switched back to the app, to make a a test call, and my line was inactive with the toggle spinning/trying to activate.  Restarting twice didn't immediately reactivate the line as it often does, but the line did activate within a couple minutes after I tried that.

          • ^_^

            P.P.S.  I still couldn't make a call, even after it showed the line as active.  It indicated "Calling" for a very long time time, then finally, "Call failed".  A second try also stayed on "Calling" interminably, and while it still indicated "Calling", I tried calling my DIGITS line from another phone.  I got an incoming call notification on my iPad, and selected the option to "End and Accept" (I think that's how it was worded; I understood it to mean disconnect my outgoing call attempt and answer the incoming call).  Well, nothing happened.  My call from the other phone kept ringing for a while, then I hung up that line.  Then the iPad displayed a notification for a missed call.  Tapping that didn't seem to do anything, but the DIGITS app was already open.  I noticed it still was showing the dialpad and the word "Calling", presumably from the outgoing call attempt started before the incoming call, even though I'd chosen the option to end that call to accept an incoming call.  I then hit the hang up key, and the text changed to "call ending", but nothing further happened.  It has stayed like that for some time now, and it is frozen.  The "back" navigation at the top left for exiting the call screen does not respond, and it still says "call ending".  I'll be closing and restarting the app.

             

            I was hoping to see how call quality is in the current version, but doesn't seem like I'll get to do that for now.  Previously on the occasions calling did work, call quality was disappointing both in terms of fidelity and delay.  My Samsung Galaxy phone can make a T-Mobile WiFi call on this same WiFi network with excellent fidelity that seems as good as a very good cellular call (Using the WiFi calling feature -- not related to DIGITS).

              • ^_^

                P.P.P.S. I later managed to take a call on the iPad.  I hadn't switched to the app again until today, 2.5 days later, and DIGITS is completely frozen.  On the screen is the dial pad (where I left it) and an indication for a missed call (Probably from about 11 hours after I last used the app).  Nothing responds at all.  This is different from the freeze I described when attempting to place and receive a call.  I didn't mention at that time, but the buttons on the dial pad acknowledged my keypresses, even though the back navigation didn't work and the call state was stuck.  Right now, none of the dial buttons or any other controls acknowledge touches.  The iPad has been continuously on WiFi during this time.

                 

                So, just a bit ago, leaving DIGITS running and frozen like that, I tried calling it again.  I got a call notification, and was able to accept the call.  Afterward, the app was responsive again...  I wondered if it goes into a bad state when there is a missed call, so I called again with DIGITS running in the background, but this time did not answer.  Without responding to the missed call notification, I switched back to the app.  This time, the app was responsive.  So, there goes that theory, unless I needed to wait longer or something.

                 

                It's nice to know that I may be able to receive calls even when the app interface has frozen up, though.

                 

                I'll try an outgoing call from DIGITS again.  No go, still.  Still says "calling" for some time, then "call failed".

                Also the dial pad is hard to use, since the numbers I touch/dial do not appear on screen and can't be deleted/edited.  If I misdial, I seem to have to call the number and hang up to clear the number, then start over.  Switching screens in the app, then switching back to the dial pad does not clear the number (though since the number is not displayed, there's no indication of this until you place your next call).  Also, system screen gestures dial numbers (like 4/5 fingers upwards for recent apps), compounding the problem.

                 

                despite these issues, make no mistake, I'm very pleased with the concepts of the various DIGITS scenarios.  The Samsung integration seems very nice and smooth (though I'll try to share my experiences with that before long too.)  Thank you!

                  • tmo_chris

                    Thanks for taking the time to post to our community! I apologize for the delay in responding to you I must say, it sounds like you are having quite a bit of issues with the iOS DIGITS app! Out of curiosity, what version of the DIGITS app do you currently have installed on your iPad? Also, which network setting do you have selected in the DIGITS settings? Is it set to use minutes and data or use data only?

                      • ^_^

                        Hi Chris,

                        My pleasure.  Thanks for the great support.   I understand if you and the others can't always immediately respond.

                         

                        DIGITS is currently at version 1.0.30, though it would have been one of the last couple versions a week ago.  The iPad automatically updates daily to the latest version in the App Store for me.

                         

                        I don't have that network setting, probably because my iPad is a WiFi-only model.  It must be using (WiFi) data, as that's the only possibility.

                         

                        Testing this latest update a bit today, I was able to make some outgoing calls as well as incoming calls (it failed to connect an outgoing call just once, and that still took a long time to fail).  I didn't analyze call quality today.  I ran into other problems, though.  Everything I last said about interacting with the dial pad to place a call were issues.  Additionally my third-party voicemail service didn't recognize touchstones well enough to be accessed and used.  And I tried call transferring and conferencing, which had significant issues in my tests.  First of all, I discovered that you can't dial a number for those features, but have to select one from your contact list (even though the dial pad are displayed during those operations).  Then I found that call transferring would not work, and indicated it was tying to connect the callers for a long time, then eventually I think indicated success and just dropped the incoming call I was trying to transfer.  That caller never heard ringing or anything.  I was able to create a conference call and use the merge option successfully a couple times.  One attempt at a conference call failed to work, but DIGITS kept indicating it was trying to connect it, and that the incoming call was on hold.  It actually dropped the incoming call eventually, though it still had an on-screen indicator for the call time on it incrementing, and continued to indicate it was trying to create the conference.  The Hangup button did not cancel this.  In fact, nothing I tried did.  I even deactivated the line (which took awhile) to no avail.  Closing and restarting the app did get out of that failed conference call, and I was able to reactivate the line (which took 2-3 minutes).

                         

                        So, the app still seems pretty unreliable for me, although I was able to place and receive calls as described today.