I use Iphone6 and i can't access my home security camera

magenta1368883

    Hi everyone. Im just wondering if any of you guys are experiencing the same issue. I use iphone6 to access my home camera through my YOOSSEE app.. but it is not working at all.. i tried switching simcard (with a friend's verizon sim) ans it worked fine.. i can only access it when im connected to my home WIFI but gives me a network error when using my carrier data,

     

    please help

      All replies

      • tmo_lauren

        You may want to bet in touch with the app developers to see if they are able to assist! We don't know of anything on our end that would cause the issue, and we are very limited in the troubleshooting support we can offer for a third party device.

         

        If you haven't already, I would suggest uninstalling and reinstalling the app, and possibly change the signal on your device down to a lower coverage level to see if being off of 4G/LTE helps.

         

        -Lauren

        • snn_555

          You may have to use a VPN. I use TunnelBear and BetterNet. I also use Alfred on my iPhone 7+ as a viewer and 2 androids as cameras. On wifi it's fine. But over LTE I have to use a VPN or else I get a connection but no audio or video.

          • tmo_marissa

            Hey there! I just wanted to touch base and see if you'd had any luck with the suggestions above, or if the app developer had any insight to offer. If you were able to solve this, we'd love to know how it worked out in case another user stumbles upon the thread with a similar question! Thank you so much for posting.

             

            - Marissa

            • rprudencio

              This issue is affecting me as well. It is not a problem with the developer, nor is it a problem with your home camera. What is happening is that T-Mobile (inline with Apple's vision) has disabled IPv4 addressing in support of IPv6. This is actually a good thing in the long run, but unfortunately I don't think the world is quite ready for this change yet. All of the other carriers run what is called a Dual Stack, meaning that they either issue both IPv4 and IPv6 addresses, or they will translate the public IPv4 addresses into usable IPv6 addresses your phone can understand. Unfortunately T-Mobile is ahead of the curve here and normally that wouldn't be a problem, BUT in Apple's last update (late April) they set iOS to only use IPv6 when available. So, since a.)T-mobile isn't running a dual stack, and b.) Apple updated iOS to PREFER and ONLY use IPv6, ALL of your traffic is routing via IPv6 and can NOT route to an IPv4 only address. (Try to run a ping to 8.8.8.8 and it will fail when using an up-to-date iPhone on T-Mobile LTE).

               

              Essentially what is happening is that your iPhone, when connecting to LTE, will request an address from T-Mobile's DHCP server. The address issued will be in IPv6 format, and weather they offer you an IPv4 address or not, your iPhone will not use it. T-mobile could fix it by issuing an IPv4 address instead of an IPv6 address (not feasible) or providing NAT through an IPv4 endpoint, and Apple could fix it by rolling back the IPv4 limitation from their last update. I'm doubting either of them will correct this anytime soon.

               

              Your particular issue could potentially be fixed on your end by getting another modem/router from your ISP (one that supports IPv6), but that is an unreasonable request and it isn't fair to ask that of you. You also may be able to correct it by using DNS to provide a Hostname pointing to your IP address. For this I might recommend Cloudflare. They offer free public DNS if you have your own domain name. If you do this, then T-Mobile will perform a DNS lookup to the domain name you have setup, and since it's an IPv4 only address they WILL translate it to an IPv6 address, BUT it will depend on the app you are using to access the camera if it will accept that address. My camera app uses my camera's Serial Number instead of a hostname to find it's way back, which apparently doesn't work.

               

              I have heard that Apple has provided T-Mobile support with a configuration profile that can be installed to your iPhone which will enable the IPv4 addressing and fix the problem (temporarily), but when calling I was just blindly transferred here and there to no avail. Even when talking to Apple support, they could not help me.

               

              I wish they would work with Apple and resolve this issue. So far it is affecting my L2TP VPN (using the native client), Cisco Jabber app (voice services only), My cameras, and any other end point that doesn't support IPV6 pass-through. I NEED my Cisco Jabber app to function as it's essential for my job. I love T-mobile and intend to stay, but again I NEED to be able to use Cisco Jabber for work. So if this isn't fixed in a reasonable time frame, I may switch to another carrier for now.

               

              Can we get anyone on the inside to look in to this for us?

              • snn_555

                Regarding my internet security cameras: 

                 

                Over wifi I'm good. On LTE I have to use a VPN. My ISP is WOW or Way Out West. It is IPv4 only.   No issues on TWC with IPv6.