takenusername

    I've been traveling to Europe for two weeks. I've used international roaming with my T-Mobile One account. My device is an iPhone 7, which I've occasionally tethered to a MacBook Pro laptop. I noticed the following:

     

    • The network name displayed was "T-Mobile LTE" in Amsterdam and "TELEKOM.RO" (followed by one of "E", "3G", or "LTE" in Romania depending on location). On rare occasions, the provider in Romania switched to "orange 3G".
    • With signal, everything on the phone works as expected: http (insecure) and https (secure) browsing, gmail (SSL/TLS connection over port 993), apps.
    • On the laptop using tethering however, https does not work - it always times out. And it's not sometimes and it's not because of some slow connectivity; I could verify speed of connection readily on the phone itself. It always times out, and on all https sites (google, apple, yahoo, wikipedia, ibm... you name it; most sites in broad usage today are only usable with https). Also, gmail (same SSL/TLS port 993) also does not work. Somewhat surprisingly, ssh on port 22 works swimmingly.

     

    Back in the USA, I tried the same setup and everything (including https tethering) works fine.

     

    I called and first spoke to a CSR who forwarded me to a tech expert. The latter said it's the first time he hears about it, but that it's technically not difficult for a given provider (or partner/subsidiary) to specifically restrict https tethering. He hypothesized that that might be a way for roaming partners to reduce roaming usage.

     

    This was quite the bummer seeing I've changed providers specifically because of being able to work while traveling.

     

    Has anyone experienced this problem in these countries or others? Is there a palatable workaround? Thanks!

      All replies

      • tmo_marissa

        Hey takenusername - I can totally see why this is a bummer to encounter, as I imagine this functionality is paramount to getting work done while you're travelling. 
        I haven't heard of this before, although we do have some regular users on the forum who travel frequently.  To be clear; this happened on your MacBook in every location, regardless of which roaming partner you were connected to, correct?  How are you connecting your phone to the MacBook (are you using any third party apps for tethering or Wi-Fi sharing)? 

        Lastly, did you happen to use your iPhone to provide internet to any other device while you were there to test whether these sites were accessible or similarly timed out?  I understand this might not have been an easy feat if you were travelling solo, but your post was so thorough I thought I'd ask just in case you'd had the opportunity.

         

        - Marissa

          • takenusername

            Hi Marissa, thanks for looking into this.


            Yes, it happened on one MacBook every time. It's the same that works well in the USA. I tried all standard tethering mechanisms: USB, Bloetooth, WiFi - same result. I haven't tried other devices, but that's a good idea to keep in mind for the future.

              • tmo_marissa

                That's definitely odd.  I do know that while roaming in other countries, a user would be subject to any rules regarding site access that country might have, but that doesn't seem like the case here since you were able to access all of these sites on your phone.  I asked a few colleagues who have a Tech background if they'd ever heard of a situation like this and came up empty-handed.  Since this works fine using the same connection methods with the same equipment in the US, it does seem like something we'd want to investigate further - but we'd need you to contact us if you encounter it again so that we could have a ticket filed.  I feel like if the issue were more widespread we'd have heard of it before - not just here in the Support Community, but overall.  I'd definitely be interested to know if it happens with other equipment, too - are you planning any trips soon?

                 

                - Marissa

            • wtm326

               

              Hi Takenusername,

               

              I had the same issue. I was traveling in Shanghai and Taipei in the late March and early April.   All your descriptions are true.  I just wanted to add a few things:

               

              • The two iPhone 6/6s with me that had T-Mobile One Plus International Plan were the ones having HTTPS tethering issues.  What I found out was that during the tethering, the phone and the PC have different IPs (both 172.56.x.x that belong to T-Mobile) with different locales (Garland, TX and Chicago areas).  This was the case in both cities I traveled.
              • I also tried to open up a VPN on the tethered machine but failed, clearly the VPN ports were blocked
              • Ironically, the iPad (3rd generation) with me that has only T-Mobile One Plus plan was able to provide unblock tethering.  What I found out was that both PC and iPad had the same IP
              • I also monitored some TCP/IP sessions on the tethered PC.  It seemed my browser could establish sessions with certain hosts (amazonaws) via HTTPS but not the content websites (Wikipedia for instance which I believe uses Akamai which seemed to be blocked).

                

              I have contacted with T-Mobile tech support during and after my Asia trip, they even opened a ticked. I have told the tech support that it had clearly nothing to do with the connection speed/quality since the phones had no issue to connect the sites, nor the Great Firewall of China.  IMO, the issue could likely relate to the network/firewall provision at the T-Mobile WAN side.

               

              In the meantime, I am asking a refund for the International Plan.

               

              • dragon1562

                Tethering is prohibited when roaming. I also do alot of travel and it was something i made sure to verify. It says so on the t-mobile terms. Standard speeds approx. 128 Kbps. No tethering. Not for extended international use; you must reside in the U.S. and primary usage must occur on our U.S. network.

                • takenusername

                  OK, so I proceeded on T-Mobile's Facebook site to create an issue, and things proceeded real smooth. Got quickly in touch via Facebook Chat with "MarvaBiggar", who did some pretty solid detective work and discovered the following:

                   

                  * According to https://support.t-mobile.com/docs/DOC-31900, the T-Mobile One includes a service called "Simple Global".

                   

                  * In turn, Simple Global, described at International roaming services, offers coverage abroad, BUT no international hotspot. Quoting from there: "Even though the included data roaming service that comes with Simple Choice allows you to use data for your phone, it doesn't allow the ability to share with other devices by tethering through Smartphone Mobile Hotspot."

                   

                  The cure to this is to buy an international data pass, which come in 1-, 7-, and 14-day varieties.

                   

                  I'm less than thrilled by this response because it was impossible for me to detect this limitation by perusing the marketing documentation available about T-Mobile One. Knowing this in advance might have affected my decision to switch carriers, though I confess T-Mobile still is the best choice for my usage pattern.

                    • tmo_marissa

                      Yeesh.  So I assumed (foolishly - and I apologize) that this whole time we were discussing the T-Mobile ONE Plus International plan.  It's a permanent add-on, it does come with a monthly fee, but it includes tethering.  One of the other users on this thread had mentioned that he actually had this add-on, and that he was still experiencing the same issues with HTTPS tethering, though!  So I'm not sure that this, or the passes, are the solution.  Let me see if I can reach out to someone with more insight into these plans - they may not have the engineering expertise to advise, but it's worth a shot.  I'll keep you posted on whether I gain any insight!

                       

                      - Marissa