siy-usilaner

    Hi! I am at my wit's end..... I have a Samsung Galaxy S7 purchased from Target under AT&T. I recently switched to T-Mobile (phone is paid off and unlocked). Everything was working well until my husband downloaded the Nougat Update. Since then, the Internet has not been working. I can text and make calls but only get Internet through WIFI.

    I did extensive diagostic work with T-Mobile, all the way to doing a master factory reset. In the end, they said the phone itself is the problem. I went to Samsung and they determined it must be a frequency issue b/w AT&T and T-Mobile because it worked fine when an AT&T SIM card was popped in. 

    The Best Buy guy reflashed/redownloaded Nougat and then amen, Internet started working. It worked great for a day but now it's back again to not working. The only thing I did was to add apps and insert an EVO SD card.

    It's not a SIM card issue because I popped in another T-Mobile SIM card and it's not working either.

    I really don't know what to do ............. HELP!!!!!!!!!!!!!!!!!!

      All replies

      • knopper

        1) Make sure APN settings are set correctly.
        2) Maybe it needs to be unlocked again from ATT?

         

        What do you mean internet doesn't work? Are you not getting an LTE signal (bars) at all? Or are you getting an LTE signal but web pages aren't loading, etc.?

          • siy-usilaner

            Thanks very much for your questions .

             

            The APN settings are 100% correct. The phone definitely shows bars and sometimes, even the 4G LTE wording yet there is no Internet connection. Last night, a friend was able to find a workaround by Turning Airplane mode and off  - which refreshed the signal - but I have to do it every time I restart the phone. It's not a big thing to do but it's disturbing that my phone is behaving this way. Do you think this is because I have an AT&T phone or because of the Nougat download?

          • tmo_marissa

            Ouch, siy-usilaner.  I'm so sorry to read this.  Were you able to get this worked out?  Did you return to Best Buy or did Samsung offer you any additional support, or are you still using the Airplane toggle after restarts to get the phone working? 
            We're in a tough spot here because we're limited in our ability to offer support for software on non-TMO devices (or really even the devices themselves).  We can provide the settings and definitely take a look at our network side, but other than that one of the reasons I love this community is because working with other users instead of just TMO folks like us, you've got a good shot at reaching someone else using the same type of non-TMO device as you who might have input.  I'd definitely like to know how it's going for you - if you were able to figure out a fix, or if the Airplane toggle is the fix for now, it would help to be able to have that answer in case someone else runs into the same problem!

             

            - Marissa

            • tmo_marissa

              Gotcha - that is such a bummer to hear.  I'm glad you've got a workaround that makes the phone possible to use, but it's definitely not ideal.  I do hope someone else will have some input to provide - I'm sure you are not the only user in the forum with an unlocked AT&T S7!  Thanks for updating us here.

               

              - Marissa