Cannot find the Preview option for the Messages app

ovin08

    I know the option used to be there but i have looked for days but i cannot find a way to turn on the message previews on the lock screen and in the notifications window.

    i turned it off while i was using 6.0 but now that i've updated to 7.0 i cannot find the option to turn it back on. now all of my messages show as

    "Messages, New message" in the notification and lock screen. settings->lock screen and security is set to Show Content. and the notifications for the app are all turned on.

      All replies

      • tmo_amanda

        Hi, ovin08!

         

        This handy feature is still available! It may take up to 72 hours after the update for everything to be in good shape. You'll want to go to settings > lock screen and security > lock screen notifications. You'll also want to make sure you're using the native messaging app.

         

        Please keep me updated if the steps I provided worked for you.

        1 of 1 people found this helpful
        • tmo_marissa

          Hey hey! Just wanted to check in with you now that we're a few days post-update - were you able to locate the settings using the steps above?  How is everything going?

           

          - Marissa

            • ovin08

              There are 3 options for the Content on Lock Screen option. Show Content, Hide Content, and Do not show notifications. Mine is currently set to Show Content like it should be AND the "Messages" app is turned on in the list of apps below. And i'm using the native Messages app. So no, this does not help me at all. I have a strong feeling that this is a bug that T-mobile introduced when modifying android 7.0

              The option was set to Hide Content when i was on 6.0 and upgraded to 7.0. Maybe something got screwed up during the update.

                • tmo_marissa

                  Yikes - although I suppose something could have been snarled during the update, I hope that's not the case.  The best way to test is going to be by completing a Master Reset, which a lot of our pillars and super users recommend as best practice after an update.  Maybe that can be avoided, though - there's one last thing I'd ask you to check first.  We had a few users reporting issues with their LED notifications after the update, and so we'd reached out to our contact who works with Samsung equipment.  She let us know that aside from just the LED indicator, Nougat does come with general changes to the notification system, and that now specific notification behaviors are set app by app.  Can you try following this flow to see if you can access your Messaging app:

                  Navigate to Settings > Notifications > All Apps > Messaging app

                  If the Messaging app is an option you see, then once you select it, you should see a main switch to turn the app's notifications on, and then "Advanced" options at the top which would let you select specific behaviors.  If you tap "Advanced" at the top, do you see any options there to set Message previews back up?

                  All this is kind of guesswork, I don't know that you can access your Messaging app through that initial menu flow; but it seems worth a shot!  Can you let me know if that gets you anywhere?

                   

                  - Marissa

                  1 of 1 people found this helpful
              • tmo_marissa

                Happy Monday!  I just wanted to stop by and see if you'd had any luck isolating some advanced notification settings for the Messaging app.  Were you able to get your previews back?  If that suggested menu flow didn't yield results, the next step would be a Master Reset - did you wind up going that route?  Please let us know how you're doing!

                 

                - Marissa

                  • ovin08

                    I was waiting as long as i could before having to reset my device again but i finally did it today. i started off by backing up settings and everything else. then i did a restore. then i did a test text message send from my email to my phone. which brought up the notification as expected. BUT, after i restored my device settings, it went back to showing the message in the preview as Message, New Message, without showing the content.

                    So after that i did a reset to the factory settings (Without doing a full phone reset) which fixed the notifications.

                     

                    BUT now i cannot find a way to disable the horrific heads up popups. i really hate the annoying window that pops down from the top telling me i have a notification since it takes up about 1/4 or my screen and interrupts anything that i'm doing. I have done a lot of searching and it seems that the option just isn't there.