Galaxy S6 No Longer Recognized by PC

branman6901

    Well, the question says it all. My Windows 7 box no longer sees my GS6.  It's been a bit since i've tried to pull photos and whatnot off of it, and I've had 2 device updates from T-Mobile in that time. 

     

    The first update was really wonky and the phone just shut down afterwards.  After several restarts things calmed down and it was fine.  The last update was a week ago i think.  No issues there.  Here's a few things I've tried:

     

    Uninstalling reinstalling Samsung USB drivers - FAIL

    Installed Smart Switch and tried updating drivers from there - FAIL

    Turned on Developer options + USB Debugging and set USB mode to MTP (it was already, but i set it to something else and then back) - FAIL

    Tried OEM USB cable - FAIL

    Tried other USB cables - FAIL

    Plugged in my work GS4 to the same computer and cables - Success

    Tried the above on a different PC - same results

     

    So the cables/PC/drivers aren't the problem as other Samsung devices are seen without a problem.  I'm not certain which direction to go in except a factory reset and I definitely don't want to go there without exhausting all other possibilities.  Could one of the updates have screwed things up?

      All replies