Galaxy S7 Edge Nougat Update

sethneds

    Ever since I updated my phone to Android 7.0 just a few days ago, it has been really lagging and even freezing multiple times a day. Has anyone else had this problem? I have tried clearing cache on apps and that didn't help. When I restart my phone, it runs normally for a few minutes and then starts to lag again. Any suggestions would be much appreciated!!

      All replies

      • theartiszan

        Re: Galaxy S7 Edge Nougat Update

        Sounds like there is a application that is sucking up resources. Have you tried starting in safe mode?

        https://support.t-mobile.com/docs/DOC-28008

         

        Might need to see if that helps and maybe uninstall one's you don't use.

         

        Worst case,  you might need to master reset the phone.

        1 of 1 people found this helpful
        • tmo_marissa

          Re: Galaxy S7 Edge Nougat Update

          Hey sethneds!  Just wanted to check back in here and see how things were going.  Did safe mode allow you to isolate an app causing this lagginess and freezing, or did you wind up moving forward with a Master Reset?  How's your phone acting these days?

           

          - Marissa

          • sergecur99

            Re: Galaxy S7 Edge Nougat Update

            I'm having the same issue since the Nougat update.  Can't pin it down to a specific app though

            • realitycheck

              Re: Galaxy S7 Edge Nougat Update

              The 'Correct Answer' was not correct for me. Just a canned response.

              I was having terrible battery drain and lagging on my Samsung Galaxy S7 phone (TMobile) after the pushed update to Android Nougat on 2/27/17. The battery monitor showed no app causing the drain. After much fiddling, I found three things that, done together, have solved my battery drain and lagging.

              1. I turned off WiFi unless I needed it. Nougat drained the battery with wifi on even if I wasn't connected to a network. I left Bluetooth on since I use a headset for phone calls. I always leave Location off unless using Maps.
              2. I turned off Power Saver. I paid for a fast phone, so why slow it down?
              3. I changed the default settings on the new Performance Mode Optimized settings so that my phone is not 'optimized'. My Optimize settings are now WQHD and Video Enhancer on. (I left game launcher and tools off.)

              My battery and I are happy again - and no lag! For the past three days, I've come home with 70% battery like the Marshmallow days. I can use my Gear VR without recharging! I guess the GS7 hardware just performs best when it isn't being obstructed by third party monitors.