ASUS TM-AC1900 wifi broken, how can I get service?

mnagali

    BACKGROUND:

    I purchased the ASUS TM-AC1900 device from the T-mobile.com website as a standalone device only, not-attached to any T-mobile account. It has been a great router, until recently has been giving me problems.

    Order #3163151330, Placed 11/23/2016, Delivered 12/02/2016

     

    PROBLEM 1: the wifi (both 2.4 GHz and 5.0 GHz) on my device (ASUS TM-AC1900) has stopped functioning.

    If my laptop or phone device is directly touching the router I have weak signal, and if I take it beyond 1 foot away from the device the signal is dropped. There is no problem for devices connected directly via cables. I have spoken both with T-mobile and ASUS technical support specialists who have taken me through the steps of rebooting/restoring my device to factory default a couple of times. We have tried other software adjustments as well, including changing channels and altering some of the advanced settings without any improvement. They have recommended that I have my device replaced under warranty.

     

    PROBLEM 2: the device is no longer available in stock for replacement.

    I spoke with online sales support for possible replacement but they said it was not possible because the device is no longer available in stock. The only option they offered me was refund, but I am not interested in that, so they directed me to technical support again for possible warranty service since the device is only a few months old.

     

    PROBLEM 3: my order was not attached to a T-Mobile account so technical support unwilling/unable to do warranty service.

    Because the device was purchased outright without an account, there is no attached T-Mobile account which apparently is a prerequisite for processing any sort of warranty service. Because they were unable to help me, they direct me to the device hardware manufacturer (ASUS) for warranty service.

     

    PROBLEM 4: ASUS states this specific router can ONLY be serviced by T-Mobile.

    After extended conversation with ASUS over the phone with multiple reps (ASUS case #N170213759) they ultimately told me: "Upon researching your case, we find that your router, manufactured to T-Mobiles specifications. The TM-AC1900, can only be serviced by T-Mobile."

     

    I have spent hours between T-mobile and ASUS phone support and I only seem to get redirected to someone else, so hopefully someone here will be able to help me. Is there no way for me to get warranty service on this device? No one seems to be wanting to help me out here.

      All replies

      • It's interesting that you bought a T-Mobile branded Asus RT-AC68U instead of a non-branded, considering the firmware is set up to give priority to T-Mobile wifi calling specifications and you are not a customer.  (Maybe the price was just awesome?)  However, there is apparently back stock available considering T-Mobile customers are still using the TM-AC1900 and replacing defective units.  That being said, it might only be available for T-Mobile customers.  In this case, I would surely take the refund and go buy a new router.

          • mnagali

            yes it was an awesome price at 60% off retail, so if I just take the refund I'd have to pay much much more. This is why I'm looking at a warranty replacement or repair. I was specifically being told though that there are no units available  to give me for replacement.

              • I searched and searched my manual and box for warranty info, but all I could find was that it is the property of T-Mobile.  That leads me to believe that any current customer would have support for any issue.  But, with you not being a customer, I wonder if your box/packaging has anything different printed on it.  Did you have any documentation with your order disclosing warranty info?  Mine just came in a brown box via FedEx I believe and was pretty straight forward setup with no other documentation of warranty.

              • kanehi

                I have the same router and sometimes it just resets itself to original specs.  If for some reason you attempt to connect to the router and can't find your customized access name and instead see CellSpot the router probably resetted itself.  I don't understand why this keeps happening but it only happens infrequently.

              • mnagali

                I am still awaiting an answer. I have tried reaching out to T-mobile via social media but have been largely ignored so far.

                • mnagali

                  Update: still not getting any help AND the refund option is not even being offered to me either!

                  • mnagali

                    just a quick update: still awaiting to hear back from T-mobile (via snail mail). I never did a response back btw from social media.

                     

                    so the tentative answer to my question: I can NOT get any service.

                    • mnagali

                      I am still awaiting a resolution at this time.

                        • sflesch

                          Did you get anywhere? I purchased one of these and I discovered their last firmware update broke upnp. I'll be posting my own inquiry, but just wondering how you made out.mnagali

                            • mnagali

                              Nope, another agent from here requested additional information from me via direct message about my order & product, but then no further update in the past 2 weeks.

                                • sflesch

                                  Thanks. I have no idea where to go for support other than posting a question here. I haven't found a webpage where you can check for or download firmware. Do you have an idea? I'm trying to revert to an older version that actually supports upnp as they broke it with the "most recent" one. Since I bought mine outright at least I have a few more options than you, but I'm crossing my fingers for you.

                                    • artart

                                      Hi sflesch & mnagali

                                      Maybe you might want to check out the ten used TM-AC1900 s that are being sold on Ebay.

                                       

                                      14 day return

                                       

                                      ASUS T-Mobile TM-AC1900 Dual Band Wireless Router Personal WiFi Calling Cellspot

                                      $52.99

                                      + $2.99 Shipping
                                      Quantity More than 10 available / 95 sold
                                      Condition Used

                                       

                                      Sold by jtpap1 (10408)

                                      100.0% Positive Feedback

                                       

                                      Delivery Est. Jun 15 - Jun 22From Lakeville, Minnesota
                                      Returns  14 days money back

                                      Buyer pays return shipping

                                        • artart

                                          ebay.com/i/182557884075?chn=ps&dispItem=1

                                          • sflesch

                                            Why would we want to buy another router when ours are having issues. Why do I get the feeling you are the seller on this?

                                              • artart

                                                sflesch wrote:

                                                 

                                                Why would we want to buy another router when ours are having issues. Why do I get the feeling you are the seller on this?

                                                 

                                                 

                                                 

                                                Hi sflesch

                                                Please accept my apology.

                                                Let me explain why I replied to you as I did. I should have handled my response in a different way. I will in the future try to remember you and my not so well thought out reply.

                                                 

                                                @mnaaproblem began back in early February with a two month old router which was then and still is under warranty. I have been following this thread ever since mnagali  first posted. There was nothing I could personally offer as a solution to the problem that wasn't already being addressed by our very experienced T-Mobile Customer Service team.

                                                 

                                                You sflesch, on the other hand have an entirely different problem. Your malfunction was caused by a software malfunction, not a hardware malfunction. The responsibility for, and remedy to the two different issues might lie with two separate parties.

                                                 

                                                I should have replied directly to mangali's original post and conversation with snn_555 about a refund not covering the cost of replacement.  Four months mnagali had said,  "the device is no longer available in stock for replacement".

                                                 

                                                Mnagali had replied to snn_555 who had suggested to take the offered refund and buy a new router; "yes it was an awesome price at 60% off retail, so if I just take the refund I'd have to pay much much more. This is why I'm looking at a warranty replacement or repair. I was specifically being told though that there are no units available  to give me for replacement."

                                                 

                                                Your recent inquiry bumped the thread to the top of the queue, which  reminded me that the OP's problem has not been resolved yet. I believe that you did the OP a great service by reminding all of us that the problem has not yet been resolved .. I began searching the internet again to see if there were any solutions to the OP's problem. * Please note mnagali has subsequently updated us with good news while I was in the process of replying to you.

                                                 

                                                I found the availability of the used TM-AC1900 for less than what T-Mobile is probably willing to still offer as a refund. The fact is T-Mobile has a history of offering "a little more" to compensate customers who have had problems which dragged on as long as the OP's.  Although the OP is not a customer who is currently paying T-Mobile for carrier service, any purchase from T-Mobile does make that consumer a customer.

                                                 

                                                The T-Mobile managers of this thread will not stop trying to assist the OP. I was just trying to help by offering a possible solution that would satisfy all parties involved. You made me realize that my solution would not satisfy you.

                                                 

                                                Let me try to help point you in the right direction which might actually help you a little better. Please see my reply to your  Jun 7 / 1:18 PM  reply to mnagali "Thanks. I have no idea where to go for support other than posting a question here".

                                                 

                                                Art  

                                              • mnagali

                                                Re: ASUS TM-AC1900 wifi broken, how can I get service?

                                                I personally already have a replacement (not as capable) router that I bought myself.  I am still seeking a response to get service on my TM-AC1900 router which I very well still intend on using if fixed/replaced.

                                                 

                                                //edit: looks like they are trying to see if they can approve a replacement for me. will update if things are rectified.

                                              • artart

                                                sflesch wrote:

                                                 

                                                I have no idea where to go for support other than posting a question here.

                                                 

                                                I haven't found a webpage where you can check for or download firmware.

                                                 

                                                I'm trying to revert to an older version that actually supports upnp as they broke it with the "most recent" one.

                                                Hi again sflesch

                                                By posting your problem in this thread you are limiting your opportunity to be helped by the fairly large group of forum members who might provide some useful advice. I believe that posting here was a good idea, however you are limiting the exposure of your particular issue which is not the same as the OP's issue.

                                                 

                                                This is just a suggestion I would make knowing how this forum operates. Since your issue is a device malfunction, You might get more responses, if you post a separate question in the "Device Discussion Forum" .  If you ask a question,  you will get more responses than if you make a statement.

                                                 

                                                I would suggest something like the following.

                                                 

                                                " Firmware Update broke ASUS TM-AC1900 ! !  Can anybody help me? "

                                                The statement below which you have already made should get some results if you can get enough eyeballs on it.

                                                 

                                                >>  I have no idea where to go for support other than posting a question here. I haven't found a webpage where you can check for or download firmware. Do you have an idea? I'm trying to revert to an older version that actually supports upnp as they broke it with the "most recent" one. <<

                                                 

                                                I hope the above suggestion might be of some help to you.

                                                 

                                                Welcome to the forum.

                                                I hope you come back often even after your problem no longer exists. I am new here. There are a great bunch of people here who have been sharing information and helping others for years.

                                                 

                                                Art

                                                  • artart

                                                    Re: ASUS TM-AC1900 wifi broken, how can I get service?

                                                    Please don't take offense by me providing detailed instructions, in case I was stating the obvious to you. I'm doing it primarily to make the process easier for you, as a new member who might not find it easy to navigate an unfamiliar website.. Furthermore, others may read this thread and don't  have your expertise  in forums and might benefit by the step by step approach.

                                                     

                                                    Art

                                          • mnagali

                                            At this point I am still awaiting approval of my device replacement (or repair).

                                              • artart

                                                Hi mnagali

                                                At this point I am still wondering why nobody seems to be able to help you. I wish there was something I could do to help. To bad that the companies that could take care of you immediately won't. Even tmo_amanda tried to help, and nothing seems to have happened. Unresolved issues like yours do a lot of harm to T-Mobile's & Asus's brand reputation. I have absolutely no idea why somebody doesn't just fix your problem as a matter of just doing the right thing from a public relations point of view. For my part, I will not be buying any Asus products in the future.

                                                 

                                                Whenever I am inclined to reassure a T-Mobile customer that T-Mobile will eventually fix an issue in the future, I might just refrain from doing so. Up until know, I have always felt that T-Mobile,  has always taken care of customers who had "fallen through the cracks". I no longer believe that. It is still my prayer that your issue is resolved. I really am very sad that you did not get what you paid for when buying a product in good faith.

                                                 

                                                I stopped using all Dell & Westinghouse products over 10 years ago because of their  failure to fix their faulty products. Faulty products sold to consumers are bad enough. A complete refusal on the part of companies to remedy the problems is totally inexcusable. My first three computers were Dells. My last dozen or so devices were definitely not. I will never buy another Westinghouse product either.  Every time you come back to this thread and remind me that nobody fixed your problem yet, I will continue to avoid buying Asus's products.

                                                 

                                                I actually have the same router that you have. T-Mobile provided me the router to overcome temporary bad reception in my area. I almost never use any T-Mobile data since the TM-AC1900 does a fantastic job for me. I am not sure what T-Mobile will do if my router suddenly ceased to work. The company didn't charge me for the router, so there definitely would be no obligation to replace it if it did fail.

                                                 

                                                I do know this. If I ever have to replace the router, at my own expense, I will not be buying another made by Asus.

                                                 

                                                You have my hart felt empathy

                                                 

                                                Art

                                                  • tmo_amanda

                                                    Thanks for your concern, Art! Perhaps I should've jumped on the thread earlier to provide an update for anyone that views this thread. I'm already working with our internal teams to get the OP and another user's routers replaced. Yes, it has taken quite a bit of time but this is not a normal exchange process.

                                                      • tws155

                                                        Hi Amanda,

                                                         

                                                        I just found this thread and I'm glad to hear things are still moving forward. I'm in the same boat as the OP. I purchased the TM-AC1900 router from T-Mobile's website last November but do not have a T-Mobile account. My router recently stopped working and I've had multiple conversations with both T-Mobile and ASUS support and each claim that the other side is responsible for providing service. Are you able to offer any help? I'm happy to provide proof of purchase and any other necessary information.

                                                         

                                                        Many thanks,

                                                        Travis

                                                          • tmo_amanda

                                                            Hey, Travis!

                                                             

                                                            I'm glad you stumbled upon this thread. I'm happy to take a look to see what we can do. I'm going to send you a private message within the next couple of minutes. You can check your inbox here.

                                                              • brizzo3

                                                                Hello Amanda,

                                                                 

                                                                My issue is exactly the same as the OP and Travis above.  I do not have a T-Mobile phone number but purchased the TM-AC1900 last November from the T-Mobile website.  I only started using the router last month, but after less than 2 weeks of actual use I am having the same problem with the wifi signal failing and only being able to connect if I am 1-2 feet away from the router.  Of course I tried resetting to factory defaults and restoring the firmware, but none of that worked.  I have called T-Mobile customer service twice and was told I needed to speak to the specialized technical department.  After speaking to them and explaining the issue (even referencing this thread and that ASUS will not offer service for the product since it is a T-Mobile branded item), they still transferred me to ASUS technical support (who surprise surprise told me there was nothing they could do).  I would appreciate it if there is anything you can do to help and can provide my order number/info.

                                                                 

                                                                Thanks,

                                                                 

                                                                Brian

                                                                • magenta2270596

                                                                  Hi Amanda, please let me know if you can help me as well.  I've been having the identical problem and have been trying to get the problem resolved for the last two months.  As a final attempt, I actually just filed a complaint with the Better Business Bureau today.

                                                              • yorkchen2001@yahoo.com

                                                                Hello @amanda (tmo_amanda),

                                                                 

                                                                Glad I found out this page by searching internet. I got the same router around last Thanksgiving without TMobile account.

                                                                I only started using the router last month, but after less than 2-3 weeks of actual use ,  the router's wireless signalling suddenly because almost non-exiting  over night.   I almost need to touch the router to detect  the wifi signalling , for both 2.4G and 5G.   I have tried factory reset, hard reset. restore firmware, leave the router powered off for 24 hours before power on.. Just the same.

                                                                 

                                                                I contact T-mobile customer service initially, and then was redirect between Tmobile and  Asus for warranty. I have called both Tmobile adn Auss twice , and both of them unwilling/unable to do the warranty work, after hours discussion on the phone.

                                                                 

                                                                I would appreciate it if there is anything you can do to help and can provide my order number/info.

                                                                 

                                                                Thanks.

                                                                 

                                                                /york

                                                                • aloha1010

                                                                  Hi Amanda, I am glad I have found this page and I guess it will be my last resource/hope for getting my replacement router.

                                                                  Please let me know if you can help me as well. I am having the same wifi issue like mnagali, plus I am a T-mobile customer.

                                                                  I've had multiple conversations today with both T-Mobile and ASUS customer service and tech support and each claim that the other side is responsible for providing warranty. (I should contact Asus because T-mobile is no longer selling the router....Asus can only provide technical support and I should reach out to T-mobile regarding warranty and replacement.....)

                                                                  Looking forward to hearing back from you with good news

                                                                   

                                                                  Phil

                                                            • mnagali

                                                              I am thankful to say that I finally received my replacement router!  Thank you tmo_amanda for helping move my case along.  As I am reading in this thread, this may not be an isolated scenario, but hopefully these guys will be able to get help faster than the nearly 5 months it took me!

                                                                • artart

                                                                  Great news mnagali

                                                                  I am glad that T-Mo finally came through for you.

                                                                  You deserve some kind of special award for tenacity and patience.

                                                                   

                                                                  Happy 4th.

                                                                  Art

                                                                  • sflesch

                                                                    Glad you got some resolve. I'm less hopeful that I will get a fixed firmware. I may have to download it from elsewhere on the web. I'm tempted at that point to jailbreak it and put the ASUS firmware, or maybe even DD-WRT firmware, on it for all the trouble it's been worth.

                                                                      • sflesch

                                                                        Well, I was asked if I had a T-Mobile account, then asked if I was interested in getting one. I explained that I get my service from a third party provider through T-Mobile and was happy with the service.

                                                                        It wasn't long after that the conversation turned cold. They had previously promised to get in touch with an engineer, but now all of a sudden, they don't do that and I am stuck with ASUS even though ASUS specifically said the T-Mobile provides the support for the router.

                                                                        Basically, since I am not a customer, they won't help me and apparently don't want me to ever be a customer in the future by the way they treated me afterward.

                                                                    • yorkchen2001@yahoo.com

                                                                      Hello @amanda (tmo_amanda),

                                                                       

                                                                      Glad I found out this page by searching internet. I got the same router around last Thanksgiving without TMobile account.

                                                                      I only started using the router last month, but after less than 2-3 weeks of actual use ,  the router's wireless signalling suddenly because almost non-exiting  over night.   I almost need to touch the router to detect  the wifi signalling , for both 2.4G and 5G.   I have tried factory reset, hard reset. restore firmware, leave the router powered off for 24 hours before power on.. Just the same.

                                                                       

                                                                      I contact T-mobile customer service initially, and then was redirect between Tmobile and  Asus for warranty. I have called both Tmobile adn Auss twice , and both of them unwilling/unable to do the warranty work, after hours discussion on the phone.

                                                                       

                                                                      I would appreciate it if there is anything you can do to help and can provide my order number/info.

                                                                       

                                                                      Thanks.

                                                                       

                                                                      /york

                                                                        • sflesch

                                                                          Not a T-Mobile customer? Oh no! I wish you luck! I got such a run-around on mine. Finally someone promised I'd be able to talk to an engineer (there's a bug in the firmware) and then I checked a few days later and got the old talk to ASUS, even though you can't put ASUS firmware on the router (without potentially bricking it).

                                                                          Lot's of broken promises (I'm trying to avoid saying lies), people who don't understand their own firmware and run around.

                                                                        • yorkchen2001@yahoo.com

                                                                          I bought the router from Tmoible onlien directly, but they would not do the warranty since I don;t have T-mobile account, Being kick around between Tmoible and Asus, but none of them unwilling to the do warranty. This is frustrating,  If Tmoible do not want to fulfilling the warranty to non-cusotmer, why they sell it to public at first beginning. 

                                                                           

                                                                          I am sure that the it is hardware problem.  There is no wireless telephone or microwave around,  It was working for a few weeks, and suddenly the wifi signal for both 2.4G and 5G HZ became almost non-exist over night, when nothing changed.

                                                                           

                                                                          Thanks