My Gear S3 and phone suddenly won't remotely connect

dshrum84

    I have a HTC One M9 and a Samsung Gear S3 Frontier LTE.  I'm using the Digits beta to have the watch mimic the phone's number.  I've been regularly using them with bluetooth off and they've been automatically remotely connecting within 30 seconds of losing bluetooth connection.  In the last 24 hours, that's just stopped.  I've turned the phone and watch off and on, gone to airplane mode and back, everything that's worked before short of doing a reboot on either.  Did something change recently in Digits that would explain this behaviour?

      All replies

      • azdreamscape

        I can't duplicate the issue.

        My watch connects remotely within a reasonable length of time when I go outside Bluetooth range.

          • dshrum84

            Mine just prompts me to connect by bluetooth then goes into Standalone mode.  I realize things are a work in progress but the primary reason I got an LTE watch was so I wouldn't have to use bluetooth all the time.  If that turns into rebooting the watch every 6 weeks the first Android Wear 2.0 watch with LTE could look more attractive than it would now.

              • tmo_evan

                dshrum84

                 

                Can you check to see if you have data on your watch?  Try loading flip board or anything that requires data connectivity when you are not paired with your phone via Bluetooth.

                 

                If for some reason you don't have data than something went wrong with the duplicate pairing and we'll need to look at that and it would exhibit the behavior you are describing.  If you have data than something went wrong with how Samsung does their relay and we can all them to look at that.

                 

                Thanks for helping out with making DIGITS better!

                  • dshrum84

                    I was still receiving Flipboard updates.  I've done a soft reset since and it's behaving normally.

                    • dan-wolfe

                      I have a similar issue.  The remote connection through cellular (T-Mobile, in my case) works great after a reset of the watch/Gear software on the phone.  But after a couple o' weeks-ish, it just stops.  It doesn't seem to try and the watch keeps displaying the "Connect via bluetooth?" dialogue which is useless if you're out of BT range. 


                       

                       

                       

                      My phone is a stock, not rooted Nexus 6.  I would think it's a compatibility issue only if it NEVER worked.  But it does -- it works great for a time, usually on the order of weeks, and then poof! It quits.  And the only thing that fixes it is a reset of the S3 and the Gear software on the phone.  I'm perplexed.


                       

                       

                       

                      I did have a chat dialogue with Samsung support a couple months ago but that was hopeless. 


                       

                       

                       

                      I thought it might be some kind of login token that is used to connect each of the two devices to the Samsung Network through which I understand this remote connection takes place.  But I have no means by which to test this.


                       

                       

                       

                      I love the product.  I get good battery life, the fitness features work acceptably, but damned if I can figure out why the remote connection doesn't connect. 

                • dshrum84

                  It happened again this week.  I had to do another soft reset to get it to remotely connect again.  This is not acceptable.  Resetting my device every 8 months or annually to get a fresh start is ok.  Having to reset them every 4-6 weeks because what should be a basic function just stops working is not ok.  Whether it's Digits or something else related to the T-Mo network, it needs to be fixed.

                  • tmo_marissa

                    DIGITSBETA.png

                     

                    This thread was the product of our fantastic collaborators during DIGITS Beta! As many terms have changed and bugs have been exterminated since the Beta launched, the information here may no longer be accurate. If you still have a question, please search our active threads or ask a new question in the DIGITS space!