Calls instantly go to voicemail (iPhone 7+)


    I'm having a big problem. Background:


    Primary device: iPhone 7+

    Secondary DIGITS device: HTC 10

    Tertiary DIGITS device: iPad Pro


    Situation: I started out on the DIGITS beta using the second SIM in my HTC 10. Everything worked fine. I ended up giving the HTC to a family member over the weekend and put my DIGITS SIM in my iPad Pro. Things were fine, then they weren't.


    The problem I'm having is all calls to my iPhone (the only active phone on my account) INSTANTLY go to voicemail. I don't even have a chance to answer. I did a few test calls to my iPhone from my work phone and my iPHone strangely says "User Busy."


    I found a thread here that had a similar issue and the fix seemed to be putting the DIGITS SIM back in the Android device, disabling and re-enabling the DIGITS beta within the Android app, and the calls then come through to the primary line (in my case my iPhone). That's all and well, but I don't have another phone at the moment because I don't have the HTC 10 anymore.


    I've tried activating/deactivating DIGITS from within the app on both my iPhone and iPad, and calls still instantly go to voicemail.


    I need this fixed like ASAP as my father passed away last week and I'm getting lots of calls for responsibilities.


    Aside from leaving the beta (which I don't want to do) and/or buying another Android phone to try to fix this (really don't want to do this either) how can I fix this? Please help, I can't deal with calling everyone back after they call me.


    Edit: to clarify before it's asked, "Do not disturb" isn't turned on at all and the numbers calling aren't on my block list at all.

      All replies

      • ericshmerick

        Judging from the amount of posts with 0 responses, I'm not very confident this will be resolved in a timely fashion.


        Guess I'll have to leave the beta. Nice, right? Maybe I'll call the DIGITS support number tomorrow. This needs to be resolved ASAP guys as my number is held hostage somehow.

          • tmo_chris

            Hey ericshmerick,


            My condolences for your loss I am truly sorry that your phone has stopped working as a result of DIGITS. I understand this puts you in a pretty difficult spot considering what you are having to go through with your father passing away. I want to make sure we get this taken care of for you as soon as possible! Out of curiosity, have you already called and spoken with our beta support team? I apologize that we were not able to respond to you last night. This is mainly a community driven forum and your post came in while we were not in the office.

              • ericshmerick

                Thank you. Update: I may have fixed it somehow. I removed the digits SIM from my iPad and put it on a Windows Phone that I had laying around. Data doesn't work on the Windows Phone (get the paywall for T-Mo to sign up for a data plan) but voice calls Windows Phone not supported?


                Anyway, after doing this dance, calls mysteriously work on my iPhone again. I am, however, afraid to remove the digits SIM from the Windows Phone or power it off since things are working.


                I know it's a beta, but so far I'm not impressed with the functionality. I'll keep an eye on it for now as things seem to be resolved somehow. Thank you.

                  • tmo_evan



                    Sorry that  you're having issues here.  I think the issue that you're running into is that you may have had "Calls on Other Devices" turned on in the iPhone settings which would allow you to get your calls on the iPad via Apple's Continuity which is also built on some of the same platform and can cause issues that sound exactly like what you described if you also have the DIGITS app installed and active.  Hopefully if you turn that off, you should not experience any additional problems with the calls going directly to voicemail.

                      • ericshmerick

                        I don't want to change the way my iOS devices are set up. The Digits beta shouldn't require disabling Apple specific features, so I haven't turned off "calls on other devices." I like being able to field a call on my Mac, iPad or iPhone and Digits isn't going to change that. The interoperability between Digits and Apple services is pretty janky.


                        Like I said, putting the Digits SIM in my Windows Phone magically fixed this and calls come in on my iPhone (and iOS devices/Mac). Good.


                        I just wish data worked on the Windows Phone...there is no app so all I get is a paywall for signing up for a data plan on the WP. Calls and basic SMS do work though. Oh well.

                • tmo_amanda


                  This thread was the product of our fantastic collaborators during DIGITS Beta! As many terms have changed and bugs have been exterminated since the Beta launched, the information here may no longer be accurate. If you still have a question, please search our active threads or ask a new question in the DIGITS space!