anthonyloprimo

    Since I started using T-Mobile with my Samsung Galaxy A5 phone, I've started using the T-Mobile Visual Voicemail app without a single issue.  It's been working flawless.  Two phones later and I'm using the Galaxy J7, and while it initially worked fine, recently the app causes com.android.phone to fail.  Multiple times.  This causes my phone to lose it's cellular network connection for anywhere from a few seconds to a minute EACH TIME the process fails.  It will stop throwing this error after a minute or two of just... not using the app, or other times only after I manage to force close the app from the recent apps list.

     

    It always stops when I remove the visual voicemail app, and seems to ONLY start after running the app or getting a voicemail where the app runs in the background to provide a notification.  I've tried clearing the cache for the phone app (all 3 listed in the Applications), the Visual Voicemail app (which has me re-setup the app like it was run for the first time on the device).  I saw another suggestion to clear the cache for the SIM Toolkit (2 listed in my app list in settings), however the button is greyed out and shows 0 bytes used anyway.

     

    I have a Call Recorder app and while it didn't give me the issue immediately after (and if I remember I am positive I had the issue BEFORE installing the app), I tried removing the call recorder app and did the above steps without it installed.  It STILL causes the same issues.

     

    It's absolutely frustrating that I can't manage my voicemail the same way.  I don't even want transcribing.  I just like the ability to very easily access and view my voicemail and I don't see how something like this doesn't just work, especially after it's been running fine. you have?

     

    Other than trying a system reset on the phone, are there any other suggestions?  I'm out of ideas and I don't see anything else about this issue online...

      All replies

      • tmo_chris

        Oh man, life without visual voice mail....... I totally know that feeling. You have definitely crossed your I's and dotted your T's when it comes to troubleshooting this issue. The last thing I could recommend before doing a full factory reset would be to try an entire system cache reset which should eliminate the issue being some sort of corrupted cache elsewhere in the phone rather than the specific apps.

          • anthonyloprimo

            Yeah, I know!  Honestly, after a while of using a visual voicemail app it's been a bit annoying to deal with "Press 1 to. *beep* Press 1 to *beep* Sorry, we didn't get the command.  Press one to" *Hangs up and throws phone*

             

            Silliness aside, I will give that a shot and see if the cache reset works.  If not... I'll either make do with regular voicemail (the pain!) until I get to do a system reset and pray that works, haha.

             

            That said, unless I was mis-informed, it's unfortunate that I don't only need to jump through hoops to change to another visual voicemail service (if I wanted to try that), but even moreso that pre-paid type service doesn't even allow for that.

             

            Granted that before it started to not work I actually -really- love using this app, but if I were in a situation I needed to change to another app, I don't understand why it should be so difficult. Moreso if I just want a better way of managing messages and could care less about transcribing them.

            • anthonyloprimo

              Okay so update:

               

              Just followed the steps to do the cache reset.....and it did absolutely nothing.  Within seconds of installing and starting the app, once it seems to verify the number or whatever it does, it chooses to start crashing until I close/remove the app.

               

              Grr, it's really frustrating.  I was hoping to avoid considering a factory reset but at least there's just calling voicemail, I guess!