More Digits iMessage issues

rherteux

    So I determined today that not only do I need to have iMessage turned off on my iPhone with the duplicate sim, but anybody that I'm sending a message to with an iPhone ALSO has to have iMessage turned off.  If I send a message to a friend who has an iPhone with iMessage turned on from my duplicate sim iPhone my friend will get my message, showing the correct phone number (not the duplicate).  So far so good.  But if he replies to me his reply only shows up on my primary (non duplicate sim) phone, even if it's turned off.  This means that if I'm out and about with my duplicate sim iPhone I won't get any messages or replies to my messages from anybody who has an iPhone with iMessage turned on (which I would imagine is just about everybody).  This seems to be a HUGE problem.  (BTW, if my friend turns off iMessage his replies to me show up on both phones)

     

    Additionally, when I have iMessage turned off on my duplicate sim phone I can never send a text to my wife (who has an iPhone with iMessage turned on).  When I try to send her a message I get an error saying "iMessage needs to be enabled to send this message".  I'm not sure if that has something to do with the fact that her number is on my account?  At any rate, this is a big problem for me because she's the one I text the most.

      All replies

      • tmo_evan

        Re: More Digits iMessage issues

        Sorry that you're having an issue here.  Relative to turning off iMessage only you need to turn it off - though you need to make sure that it is off on all of your iOS devices including (iPads, Macs, etc) so that Apple doesn't try to deliver messages in that fashion.

         

        One of the most effective ways to do this and often results in it being deregistered a little faster is going to the following website:  Deregister and Turn Off iMessage - Apple Support

         

        Apple does indicate that it can take up to 24 hours for them to completely deregister you from iMessage so there is definitely a lag time from when you turn the service off before all of your contacts who have iPhones are updated so as to not send you messages via iMessage.

         

        If your still seeing this issue after completely deregistering and more than 24 hours has gone by, please let us know so that we can have a conversation with our friends at Apple as to why people aren't getting deregistered.

          • rherteux

            Re: More Digits iMessage issues

            I turned off iMessage on my main iPhone and things seemed to be better.  I was getting messages from other iPhone users.  That is, until I went to lunch and an iPhone friend I was meeting texted me and I never got his texts.  When I got back to work, there they were on my Macbook.  So, you are right...you have to turn of iMessage on all devices.  I hate to say but I don't think the duplicate sim phone is going to be a really great long term solution for me.  I can probably disable iMessage on my iPhones but I rely on my Macbook to send messages and I can't bear to part with that.

             

            Is this anything T-Mobile will be able to work around in the future?  I think this will negatively impact most people who are heavily invested in Apple products.

              • tmo_evan

                Re: More Digits iMessage issues

                We understand the frustration with iMessage as lots of people have invested time and effort in that particular platform.  We do have a Mac/PC client that you can use so that you'll be able to get all of your messages on your Mac in the same fashion as iMessage did previously. 

                 

                You're welcome to try out that solution with iMessage off completely on all devices, as many of us are using that combination and find it works well; it's just a bit different.

                  • rherteux

                    Re: More Digits iMessage issues

                    How can I get the app for my Mac and my PC to try it out?  And to be clear, I can send AND receive SMS messages from my Mac as well as my PC?

                      • tmo_evan

                        Re: More Digits iMessage issues

                        Just go to http://webDIGITS.t-mobile.com at the bottom of the page is a link to download the pc and mac client.

                         

                        And yes you can send and receive SMS, MMS and RCS messages.

                          • rherteux

                            Re: More Digits iMessage issues

                            I get to a page where I can register then I can send messages via a web page but there was no link to download a separate app.  At least on my PC running Windows 10 and Chrome.

                              • txntundra

                                Re: More Digits iMessage issues

                                Same here, I still just see the static page but no links to apps.

                                  • rherteux

                                    Re: More Digits iMessage issues

                                    Solution:  (Maybe)  Try a different browser or a different machine.  I was trying to download from Chrome on Windows (bootcamp), never got the links to download.  Went over to the Mac side and tried the same.  First tried in Safari, no go...didn't like the browser...then I tried and Chrome and Shazam!...the links were there.  So I downloaded both the Mac and Windows versions from there.  I'm not sure if it's maybe a Windows issue, or perhaps because I had logged in on that page in Windows before it was caching something that bypassed the page with the download links.

                                     

                                    CAUTION:  If you try to load the app in Mac OS you're going to get a warning that the app won't open because it wasn't downloaded from the App Store.  You need to go into System Preferences > Security and Privacy > General tab, and there you will see an option to open from "App Store and identified developers", you need to select that option.

                      • lemmyslender

                        Re: More Digits iMessage issues

                        It seems many of us have been having trouble receiving SMS starting some time yesterday with duplicate sims.  Could this be related?

                        • rherteux

                          Re: More Digits iMessage issues

                          Still having issues with iMessage.  Yesterday I tried turning off iMessage on all my Apple products including my 2 iPhones and my MacBook.  During that time I missed every message that was sent to me from another iPhone user.  This weekend I'll try again, leaving it off longer.  I'll also try the link that Evan posted above that I was originally reluctant to try because turning off iMessage on all your devices should do the same thing and I don't want to run into issues should I want to "re-register" iMessage.

                          • tmo_tim_b

                            Re: More Digits iMessage issues

                            Hello rherteux -

                             

                            I know you were reluctant to de-register iMessage, but have you tried that out yet? Are you still having issues?

                              • rherteux

                                Re: More Digits iMessage issues

                                I think I got it mostly working.  I discovered some old Apple products that I no longer owned in iCloud and removed them, then turned off iMessage on my remaining products and now it seems to be working properly for the most part.  The only exception is that my wife sees text coming from my duplicate line with the new phone number, not my main number.  She's the only iPhone user I'm having these issues with and I'm guessing it has something to do with the fact that all of our numbers are on the same account, giving each of them some different level of visibility.  Since it's only her I'm having issues with I'm not too worried.  Though she's the one I text the most so on the other hand it would be nice if it was working properly for her as well.