Does this fix your phone sporadically missing text messages?

rickyd5000

    I've been sporadically missing text messages and think I've finally tracked down how to fix it.  There are 2 main actions you need to take:

     

    1.  Configure your texting app to use MMS for "long" messages.  I use Textra as my texting app, and highly recommend it.  Its hard to narrow down the specific failure, but I believe when a text message is larger than 160 characters, it is broken up into multiple messages, and then needs to get reassembled on the receiver phone.  There seems to be a failure somewhere along this process.

     

    2.  Configure all your APN protocols to IPv4 only.  I've had problems with IPv6 and IPv4/IPv6 settings, especially connected over wifi to a router.  I believe IP6 introduces issues depending on client/server implementations.  On my Nexus 6, this is under Settings > More > Cellular networks > Access Point Names.  Select each APN listed and set "APN protocol" and "APN roaming protocol" to IPv4 only.

     

    Unfortunately, this requires changing configuration on both the sender and receiver of the text, which you may not have control over.  But fixing one side is hopefully better than fixing neither...

     

    These are the observations and notes I've noticed so far:

     

    1.  I only seem to be missing "long" messages, messages larger than 160 characters.  These long messages need to get broken up and reassembled, and thats where a failure seems to occur.

    2.  I have seen this issue reported mainly with Android phones.  I believe iPhone defaults to the settings above, but I don't have an iPhone to verify.

    3.  The APN protocol seems to be defaulted to IPv6 on many phones - including Nexus 6, Motorola X Pure, and Samsung Galaxy 6 I've seen so far.

    4.  I've seen a lot of threads where tech support says update your phone or update your SIM card.  This does not make sense to me.  This issue happens to many different phones, and ones that are relatively new.

    5.  I missed texts mostly from my wife, who is also on T-mobile.  So being both on T-mobile doesn't seem to help.

    6.  Textra is a great texting app and can help with these missing text messages.  I have mine configured to convert Long SMS to MMS when > 1 SMS (I assume thats the character length of 1 SMS, versus 2 or 3, etc).  Also, you can configure it to show text status - Sent and Delivered.  Although, when sending a MMS message (or a "long" SMS which is converted to MMS), I never seem to get a Delivered status; yet the message always gets delivered.  FYI.

     

    Please let us know if this works for you.  If not, please let us know your:

    * Did both the sender and receiver have the 2 settings above configured?

    * Phone, OS and version, and Carrier for both the sender and the receiver.  e.g. Nexus 6, Android 6.0.1, T-mobile

    * At the time the text was sent, for each the sender and receiver, was the person connected to wifi?  Did both the sender and receiver have a "good" cellular connection? 

    * Any other relevant information so we can narrow this down...

     

    Thanks!

      All replies

      • rickyd5000

        Oh, 1 more thing.  After making those 2 changes, reboot your phone to make sure the changes take effect.

        • flora1910

          Ricky, thanks so much for this info. I have a Galaxy S5 and for months I've been having issues with not receiving all texts, and nothing TMobile support suggested worked. I followed some of your advice and switched to Textra as well as configured the texting app to use MMS. Also turned off WiFI (per the suggestion of TMobile rep) and the combo of these things all worked for me. Over the past three days I've been receiving all texts. Fingers crossed this is a permanent fix. Thanks so much! And I love Textra--wish I had switched to it sooner.

            • rickyd5000

              Awesome!  Glad to hear!

               

              FYI - They told you to turn off wifi because of a known issue with texting and T-mobile Wifi calling enabled.  If you don't use Wifi calling, then you could turn off this feature and still use Wifi (for data and internet).  I'm not sure if this issue still exists - it seems it is easy to test and should happen 100% if it has not been fixed.  Also, Textra has a config option which will workaround this by flipping off wifi, sending or receiving the text, then flipping wifi back on.  Here are more details:  MMS not working on T-Mobile WiFi – Support

               

              Its interesting you noted this is happening with the Galaxy S5.  That seems to be happening very frequently, not just with T-Mobile.

              Here is a thread on T-mobile:  Galaxy S5 not Receiving All Texts

              Here is a thread on Verizon:  Not receiving some text messages on S5. Never o... | Verizon Community

               

              I wonder if Galaxy S5 got an update at some point which started this issue.  I would be interested to know other users hitting this issue, what phone and carrier they have, and when they started seeing the issue.  I have seen it on my Nexus 6 and my wife's Moto X Pure.  From what I can see from Googling around, this issue does not seem specific to a carrier.  It seems more specific to various Android phones, and not iPhones.

              • rickyd5000

                2 quick followups for flora1910:

                 

                1.  For #1 above "sending a message as MMS when >1", this fix is mostly on the sender side.  So I'm not sure if this really fixes the problem for you if you only changed you're phone (acting as the receiver).

                 

                2.  For the "not being able to send texts with wifi calling enabled or wifi on", the problem is with the APN protocol setting.  If you change it to IPv4 only as I mentioned in #2 above, it will solve this issue and you can leave wifi on and wifi calling enabled.  The thread I linked to at the end has more details.  They say to set your phone to IPv4/IPv6.  This dual stack mode may work, but I haven't tested it thoroughly, and frankly, the benefits of IPv6 are debatable - so I would rather avoid it altogether since it could cause issues (especially with IPv6 only).  But if others run fine with IPv4/IPv6 and send/receive text messages without issue, please drop a comment so we can gather as much data as possible.  Here is the thread:  Solution to Picture/Group MMS on WiFi

              • vickyandken

                I think it's crazy that you have to change your settings to make sure you get all of your texts.  My question is, why only you, especially when you have an expensive Samsung Galaxy? 

                 

                I bought a Moto G Play from Best Buy, and although it's not a high-end phone, I do expect it to work like how it should.  Prior to that I had a Lumia 640.  On both phones I've had the same issue of SOMETIMES not receiving texts, or others not being able to receive texts from me, and this is only with those I'm texting who also have TMobile!  Others I text who have AT&T, Verizon, etc., there is no issue.  I have not tried those two things you suggested, but the long text is not the reason for me, since I've sent short one-sentence texts, and those have gone missing as well.  I've tried everything - changed texting app, got a new SIM card, changed setting from LTE to 3G, and even replaced my phone because it was still under warranty and I figured it couldn't hurt to try.  I've been on the phone with TMobile countless times and they've run out of answers.  This does not happen to everyone, so there has to be a better answer.

                 

                Sorry, I'm venting but also wanted to post what was happening to me to share with others, since that's what I've been trying to do - search for others who have been encountering this issue.

                • vickyandken

                  Addendum:  I just checked, and my phone doesn't even have wifi calling capability(!), so there's nothing to turn off.  It is also already set to IPv4, so those suggestions don't work for me.

                   

                  I just got off the phone with a Tmobile tech support person who suggested another setting change on my phone.  I'll test it out for a few days.  If this fix works, I'll be sure to post.