Messages not sending from Primary Phone to other T-Mobile customers since this morning!

thewebmachine

    I'll preface by stating that I have over 18 years of IT and Telecommunications experience, including cellular network deployment.

     

    Setup Details:

    2 numbers on account - primary phone and Gear S2 Classic

    DIGITS registered for primary phone

    DIGITS app installed on one other device and linked to primary phone # for testing

     

    Description of Behavior:

    Starting this morning, when sending texts to other T-Mobile numbers (not on my account), the texts show as sent on primary phone and show up in the DIGITS app on the other device, but are NEVER received by the recipient. Texts sent from DIGITS app on other device are not being received, either. Texts to other carrier destined numbers are delivered without issue. All texts are being received in DIGITS and on primary phone, regardless of originating sender carrier. ALSO, sending a text from primary phone or DIGITS app to the primary phone number (a "loop-back" test, if you will) results in the message never being received on primary phone but IS received on the DIGITS app. In short, texts from my primary # via any method outbound to, specifically, another T-Mobile number are never received. All inbound texts and outbound to other carriers are working fine.

     

    Diagnostic Steps Taken:

    Sent test texts from...Google Voice to T-Mobile recipient (success), Google Voice to Primary # (success), Primary # to T-Mobile recipient (failed, sent but never received), Primary # to non-T-Mobile recipient (success), DIGITS app to T-Mobile recipient (failed, sent but never received), Primary # to Primary # "loop-back" (failed, messaging app says delivered, but never received on Primary phone, IS received in DIGITS app). Deactivated/removed DIGITS app from other device.

     

    I see mention in other posts that re-provisioning is being done across some accounts that were not previously setup properly. Since this problem started this morning, I'm curious to know if I was included in this re-provisioning. Texts to other T-Mobile numbers were working as recently as last evening around this time.

     

    Combining this with some seriously lacking features/design elements in the DIGITS app, I'm beginning to regret participating in this "beta" that, as another poster put it, is more like an "alpha" when it comes to stability. I'll give this no more than 12 hours to be worked out, then I will be requesting removal from the beta and restoration of my services as they were before opting in. This kind of major upset to basic services simply shouldn't be happening in a "beta" phase. If I put out "features" this buggy in my apps, I'd be out of business!

      All replies