"Message blocking is active" message on my wearable using DIGITS

spw303

    So I have an S7 edge as my primary phone. I also have the Gear S3 watch. I have been setup on DIGITS beta.

     

    Observations and problems:

     

    If the watch is is STANDALONE mode, meaning it is not connected to the phone via Bluetooth or WiFi and has full LTE signal and connection to t-Mobile LTE. I can make phone calls and my primary number shows correctly on the opposite end. Also my primary phone rings along with the watch. So everything appears to work fine with phone calls.

     

    It is Texting I am having problems with. When I try and send a text message from the watch, I immediately get a message on the watch from the "DUPLICATE" number (which is the new number from t-Mobile which allows DIGITS to function) telling me that "Unable to send message, Message Blocking is Active".

     

    I have also noticed that in the Gear App under "Gear Connection" there is an option named "Remote Connection". Which says "Use your Samsung Account to your Gear Remotely via mobile data and Wi-Fi". If this is turned on and I walk away and lose connection with my phone, I can send texts to my primary and receive them on the watch but the sender receives a message stating "Receiver unable to receive message. Message blocking active".

     

    Anyone else experiencing this? I noticed others mention they were experiencing issues with VoLTE. So I did try and disable that but it made no difference. I have also contacted the Beta team and created a case. But they didn't know either.

     

    Otherwise the call part is working great and I can leave my phone at the office and still send and receive calls from my primary number which is very cool.

      All replies