Smart settings not turning off Wi-Fi since Android 7.

cmquinn

    Since the installation of Android 7 the use of smart settings to turn off Wi-Fi when you leave home does not work the Wi-Fi stays on. What is the solution?

      All replies

      • tmo_amanda

        Oh, good question, cmquinn!

         

        Do you have your location enabled? Once that's enabled, is "my place" enabled? You can also try these steps:

         

        1. First turn off Wi-Fi and enable Mobile Data (via quick access toggle on the notification bar)
        2. Next, Go to Settings >> General >>Location >> My Place (it will no longer be grayed out)
        3. Turn on “My Place” and select “Allow”
        4. Next, you will have to set you home location
        5. Go to settings >> General>> Location >> Turn on location >> Tap on “My Place”
          • Note: Mobile data should be enabled for this step as well
        6. Now your current location will be automatically detected, and you can set it has “Home” location

         

        Please let me know if this works for you!