dukesilversjazz

    Just joined T-Mo, got the S7 Edge.

     

    I turned on Wifi Calling, and the icon in the status bar is fine, it is the ongoing notifications (yep, two are shown) when pulling down the status bar to show any Notifications.  There are TWO notifications that say the exact same thing, "Calls will be made over Wi-Fi, tap here to access preferences".  I know that the service is "WfcService", but I cannot hide notifications from this as there is no option to do so (you can only hide it from the Lockscreen, which I've done).

     

    I've read up that rooting you can hide this, but that option is out.  Looks like "it is what it is", is there any way that T-Mo would allow a user to hide this ongoing notification?  It doesn't need to be persistent in my opinion.  Any other suggestions/solutions?  I'm thinking no, but thought I would put this out there.

      All replies

      • htghtg

        Hello dukesilversjazz,

         

        If you select them both (one at a time), do they actually take you to the preferences? Or does one of the two notifications close the status bar? If one only closes the status bar I would think it is a kind of glitch that can be corrected.

         

        I'm interested! Would be cool to find a way without Rooting the device (as this voids any warranties).

         

        Please let me know,

         

        HTGHTG

        1 of 1 people found this helpful
          • dukesilversjazz

            Thanks for the reply htghtg!

             

            When I press on either one of them, I'm taken to the same location in Settings called "Wi-fi Calling Settings".  It doesn't matter what settings I select there (Wi-Fi Calling On/Off, Wi-Fi Preferred, Cellular..., or Never...).  The notifications also do not clear after pressing on them.  So both of them do the same thing.  I've restarted the phone as well a few times, all same results thus far.

             

            The only way I can get this to go away would be to turn Off Wi-Fi Calling, but I don't wanna, so I'm living with the dual notifications.

             

            Here's what I'm seeing:  http://i.imgur.com/T1XYpKx.png

              • htghtg

                Thanks dukesilversjazz for the quick response!

                     I have a couple of suggestions that maybe we can run through to see if we can clear them. Please keep in mind that I am using an Android 6.0 Galaxy S6 Emulator, so some things may be different. I do believe you mentioned the process that manages the Wi-Fi Calling settings, however I'm not convinced that is the service prompting these notifications. Needless to say- I could be wrong; this could all be a witch hunt. I apologize in advance for the delay. The visualization I recognize is 50MB's soooo it may take a bit to load depending on your connection.


                --Let's try the following...Visualized

                • Tap "Home"
                • Tap "Settings"
                • Tap "Apps"
                • Tap the "More Options" icon
                • Tap "Show System"
                • Scroll down the list to locate a service that has "IP" in it.
                • Please list them if you found any in a response.
                • Bonus points if you see an option to mute the notifications in them.

                 

                I'm also going to put the next method below which would typically fix the issue if it is just a glitch. The Master Reset is usually what CS representatives will have you do. I would like to try to fix the issue WITHOUT using it, though.

                 

                --------The "ALL ELSE FAILS" method:

                This method will erase and content and settings on your device.

                1. Back up data on the internal memory. If you have signed into a Google account on the device, you have activated Anti-theft and will need your Google credentials to finish the Master reset.
                2. From the Home screen, tap the Apps icon.
                3. Tap Settings.
                4. Tap Backup and reset.
                5. If desired, tap Back up my data to move the slider to ON or OFF.
                6. If desired, tap Restore to move the slider to ON or OFF.
                7. Factory data reset.
                8. Tap Reset device.
                9. If you have screen lock turned on, enter your PIN or password.
                10. Continue.
                11. Tap Delete all.

                 

                Thanks again and let me know!

                 

                HTGHTG

                 

                Resources:

                1 of 1 people found this helpful
                  • dukesilversjazz

                    htghtg, thanks again for the fast reply!

                     

                    The only system app starting with "IP" is IPsec Service.  I was Googling this and people were saying that the service for this was called "WfcService".  In both of these, there's no way to hide these notifications at all unfortunately.  Force stopping the service makes it go away, until a phone reboot then it is back, or if you turn off Wi-Fi Calling, the notifications also go away.  I will try a factory reset, probably next week, as I'm traveling for work so I will do that when I'm back.  I use Samsung Pay quite a bit and just setup my credit/debit cards too.

                     

                    For now I'll live with it, not the end of the world just annoying more than anything.  I appreciate the follow-up on this, and get back to you once I am able to factory reset the device.

              • dukesilversjazz

                htghtg, I confirmed it is the service called "WfcService" that is showing that notification.  Here's what I have found AFTER the Factory Reset.

                 

                Re-setup phone, all apps/settings.  Good Lock was not installed yet.

                Notification was showing only ONCE.

                Installed Good Lock, phone restarts.

                Setup Good Lock, and now the notification shows TWICE.

                 

                It would appear that somehow Good Lock is showing/allowing this notification to show twice.  Disable Good Lock, notification only shows once.  Good Lock is a Samsung app that allows you to customize lock screen/notification bar/status bar to a more of a "stock" Android feel.