is anyone else having trouble paying their bill online?

tialopes89

    Everytime i go to pay my phone bill today im kicked back to the main screen after i hit the pay with debit/credit link. Is this happening to anyone else

      All replies

      • tmo_mike_c

        Hmm. I tested this the other day and it worked fine for me. Can you clear out the browser's cache and history then test it out? Try giving another browser a try if you haven't already. Let us know if that helps. Thanks!

        • traveler12

          I've been having the same problem as you with two computers. Getting nowhere calling T-Mobile support about this.

          • ronka

            This is the fourth month in a row that TMobile's online bill payment system isn't working. I usually have always paid on Saturdays. Every time I try to make an online payment, either: the screen comes right back to the "pay now" button, OR it says "our systems are not currently available.

            I try to pay online again on Sundays, and then again on Mondays, each time getting the same errors. Then I wind up having to call TMobile to speak with someone in order to pay. Then, the TMobile person adds a $5 service fee…then I have to call you back AGAIN to have the fee removed. I have tried the browsers Safari, and also Firefox. I have also updated Java. This problem started in June, and it is now October. Each time I speak on the phone with a TMobile representative, they say, "Yes we're having a problem and it will be fixed soon." BUT this is now FIVE months since this issue started!

             

             

            I pay many bills online, but this problem only happens at Tmobil's website.  TMOBILE, PLEASE ADVISE!

             

              • tmo_mike_c

                Wow ronka !

                 

                This is taking surprisingly longer than normal to get this taken care of for you. Did anyone you spoke with mention filing a Help Desk ticket for you? That would be the next step to get the website working for you.

                 

                Keep in mind, if you have the T-Mobile App on your phone you can make a payments there. It's really easy and worth a shot since the site is giving you fits.

                  • grimdel

                    Ive been having this problem for months with Firefox and Internet Explorer.  I've tried clearing the cache, and using other computers with no succes, and am forced to used the T-Mobile App.

                     

                    No - its not easy to pay via my phone - its horrible - takes a minute or two to bring up the app, and another 5 minutes or so to fill out the payment info because because the phone has a small screen and poor keyboard layout.  Please fix your website or I'll start considering moving to another carrier.

                • magenta3745827

                  It is now JANUARY 5, 2018.........

                   

                  IM HAVING THE EXACT SAME ISSUE

                   

                  Cant pay my bill.....just keep looping back to the main page !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

                  • mscash

                    I paid my bill on line through the T-Mobile app and my payment was lost. It cleared my bank but T-Mobile says that they never received it. They say they gave me credit for the payment but it does not show it on the T-Mobile app. I have talked to several representatives at T-Mobile and this problem has not been solved. I want to know where my money went and they can’t give me an answer. This makes me want to leave them and get a new carrier.

                      • tmo_mike_c

                        We certainly wanna get this figured out for you too. I understand you've called already, but have you tried reaching out to our T-Force folks through FB or Twitter? I think it's worth it to run this by them so they can take another crack at trying to find out what happened. I do suggest mentioning that we tried escalating this before and that you're still having some trouble.

                      • mellowamethyst

                        I've been having the same issue for weeks now.  I've found a workaround, but it's not 100% (it involves racing the page before it kicks you out).  It's very frustrating.  This issue exists whether I try to pay my bill via mobile phone (not the app) or on laptop.

                         

                        On Google Chrome the issue exists even after I clear cookies, cache, everything I could find, since the "beginning of time."    I actually tried Safari today, and it worked!  I'm still disappointed how I am no longer able to utilize my preferred browser to make payments or adjust payment methods (i.e update credit cards).  The app isn't always feasible/ reliable since I pay two accounts and can only access one account on there.  It also may not be available at times (and directs one to the website anyway).        

                          • needbetterservice

                            I have never had this issue before, but am having it now: Trying to reload prepaid phone account with monthly fee, using credit card that has worked for the past 2 years (and is not expired or overcharged). Cannot click fast enough on credit card payment page to stop it from returning immediately to account home page (which continually reminds me to reload the account...). Tried 2 different computers with latest Firefox for iMac and Windows 7: same bad behavior. Finally tried Safari on iPad, where the page seemed to stay up long enough to enter the info. However, between trying the iMac/Win7 and the iPad, I spent about 45 minutes on the phone with a Customer Service rep who spoke with an impenetrable accent (a lot of the time spent was asking her to repeat words that she could not seem to pronounce in a way I could understand), and who admitted that she had no idea when, or if, I would ever be able to make payments online again. She insisted that she could absolutely help me make my payments, and said over and over that "there are no problems, and everything will be completely OK". She took my credit card info, and said that she submitted it. She also assured me that she would send me a text (to my phone that I repeatedly told her was out of the very narrow access range of T-Mobile's very spotty service), confirming that the payment had been verified by the card company, and that T-Mobile had accepted it. Instead, she called me back (to the landline where I am staying) after 20 minutes to say that the payment would be delayed (passive voice, no indication as to the nature or cause of the problem) for "15 to 30 minutes". 15 minutes later, she called back again to say that the payment "did not go through", and I would have to give all the credit card info to a supervisor, to whom she would transfer me now. The target line of the transfer rang about 10 times, then went completely silent for about 2 minutes. Then, over an extremely noisy connection, a recording informed me that the T-Mobile automated answering system was having problems now, and that I should hang up now and call back at some unspecified point in the future. I hung up, and then checked my credit card charges online. Sure enough, just like another poster to this thread, found that despite the rep's assertions, the charge DID GO THROUGH, but T-Mobile failed to credit me for the money they collected. This is fraud, pure and simple. Given the incompetent Customer Service, the persistently malfunctioning website, and the lack of reasonable channels for recourse when T-Mobile screws things up this badly and for this long, T-Mobile clearly does not give a damn about their customers' satisfaction. As for the standard advice from the T-Mobile rep who apparently monitors this thread (tmo_mike_c, "have you tried reaching out to our T-Force folks through FB or Twitter"): I am not on either of those public forums, and should not have to be in order to get good customer service (both for reporting and solving T-Mobile's server problems and for paying with a credit card by phone). Why can't T-Force respond to problems posted on this forum? Why can't T-Mobile publish a Customer Service email address for, you know, CUSTOMERS who are paying (or trying to pay) for adequate service, and respond to secure emails from those customers?

                              • tmo_mike_c

                                I'm really sorry to hear you've been having so much trouble too. It definitely shouldn't have been so difficult to get your payment process properly. If we drop the ball, it's on us to make things right and this is a classic case where we need to own this. I understand you should be able to call Care and get the help you need without having to go through our social media. T-Force is just an alternate method that can get the same results as our Care team. This particular forum is more of a peer-to-peer site for helping with resolving a wide range of issues. We do our best to give you as much help as we can here, but there are some instances that require access to your account that we don't have here. That's when we'll recommend reaching out to folks like our T-Force team to get account related issues resolved. I understand you don't use those channels, I'd just like you to know the reason I made that suggestion. In regards to having a direct email for our Customer Care team, we've been asked this before too. I don't have one I can give you, but what I can tell you is that we have a specific way of verifying accounts through calling and our social media channels used to protect your account and make sure we track and record all changes that take place. After hearing your story, I couldn't agree more that we could have done a better job for you. In the same breathe, I know this can be resolved and I'm sure our Care (as well as T-Force) have the tools need to make things right. I'd like to encourage that you give our Care folks another shot at trying to fix this for you. Not that you should have to, but if you reiterate what you've told us here, I'm sure they'll make the effort to take better care of you. My apologies for what happened, but I appreciate you choosing to come here and tell us this.

                            • magenta4890214

                              Same problem here months later. Strange way for T-Mobile to get right to the problem and fix it so customers can pay their bill. Simply amazing.

                                • dc5fan

                                  The only bill I have is to place money into a Pay As You Go account ($3 a month). I still can't do this on my T-Mobile account. I think I can do it on the T-Mobile app, but can't check that right now as my battery is being charged. The other mode is to go to a corporate store that is about 9 miles south of me. I would lean more to the store as I would be given a receipt using a credit card. It sure would be to T-Mobile's advantage to have the site fixed.

                                • magenta4890214

                                  I found a solution through phone support. Who is poster, tmo_mike_c? He is useless.

                                   

                                  Paying through mytmobile is useless, go to tmobile's home page and at the bottom is a pay option and it worked for me. You have to allow all scripts if using a script blocker.

                                   

                                  T-Mobile is a joke, even replying to this thread which I'm currently subscribed to was difficult. When I clicked on the link in the email which is dangerous and I should know better led me to a page that instructed not found look under the couch. What is their problem? I'm unsubscribing as I have been able to pay my bill and want no further interactions with this company than absolutely necessary.

                                    • dc5fan

                                      I have had the same feeling of what you are writing. I did get some great help from 2 members that suggested a T-Mobile phone. After a couple of days I bought the phone. It is a great phone, but I don't have much to say about the manufacturer. Your suggestion about a script blocker may be a problem I am having as I still can't use a credit card to put more money into my account. Thanks for that!