Play Store can't download / YouTube doesn't work on Galaxy S6 on Wi-Fi with LTE


    On my Samsung Galaxy S6, on Wi-Fi, downloading an app in the Play Store doesn't work (it just shows "Downloading..." but never starts the download), and YouTube videos don't play (I think also there are problems with other Google apps such as Gmail and Drive).

    This happens when "Network mode" is set to "LTE/3G/2G" (the default).


    When my phone had Android 5.1.1 Lollipop, I was able to avoid the problem by turning off VoLTE (Phone -> more -> Settings -> Voice over LTE settings -> Do not use VoLTE).  That had basically no drawbacks for me.  But after the update to Android 6.0.1 Marshmallow, that option no longer exists; there is a new option "Voice over LTE Preferred", but turning that off doesn't help.


    T-Mobile: please fix this problem, or bring back the option to completely disable VoLTE (or provide another good workaround).


    Things that seem to work around the problem, but are not good long term solutions:

    - Remove SIM card (i.e., it works when using just Wi-Fi without any cellular network connection).

    - Turn off Wi-Fi (i.e., it works when using just the cellular network).

    - Disable LTE, by setting "Network mode" to 3G/2G instead of LTE/3G/2G (but this will be slow when not on Wi-Fi).

    - In Lollipop, setting "Do not use VoLTE" made it work; but as mentioned above, that option doesn't exist in Marshmallow.

    - Use DNSet app which sets up a VPN to use Google DNS servers and (but this makes it more difficult to use another VPN, and I'm uncomfortable giving this app permission to potentially spy on all my network traffic).

    - Use a different Wi-Fi network (or maybe different router); it works on my employer's network, but not on my home network (Netgear C6300 router on Cox cable in southern California).  Possibly the problem is related to IPv6 (I only want to use IPv4, and websites tell me I don't have IPv6 connectivity, but my phone and router seem to have both IPv4 and IPv6 addresses); for some other Galaxy Wi-Fi problems, I've seen reports of issues with IPv6, but I don't have an easy way to test that theory; my router doesn't have a way to disable IPv6, and I think disabling it in the phone requires rooting the phone.


    Things I tried that did not help:

    - factory reset, clear cache/data for Google Play Store, Google Play services, Google Services Framework, Download manager, YouTube; wipe cache partition.

    - removed my Google account, added it back.

    - rebooted Wi-Fi router.  restarted phone.

    - changed DNS servers to in my router's DHCP server; also changed the phone to use a static IP and those DNS servers (a little odd that this didn't help but DNSet did; possibly the phone doesn't really use the DNS servers I specify, or something related to IPv6, or DNSet's VPN affects something other than just DNS servers)

    - turned off "Voice over LTE Preferred"

    - turned off "Mobile data" (does this not affect VoLTE?)

      All replies