VoLTE still not working under Marshmallow; when is this ever going to be fixed?


    Issues have been since VoLTE was introduced. Across two or three major OS updates, across three different phones and numerous locations from LA/OC counties, to all over the Twin Cities metro area to most major cities (and rural areas) in every New England state. I start a call (me calling out or receiving a call) and within a minute, the person on the other end can't hear me. Hang up, call again and the same thing happens over and over, until I turn off VoLTE. It has been been months since I even tried it, but I figured that with a major update, maybe something about this might get fixed.

      All replies

      • matesny

        VoLTE does not require any special user configuration but it does require the official T-Mobile ROM I believe.


        When the other party can not hear you, it is usually a sign that the application lost its access to your microphone. This was an issue with some S6 users and turning off OK Google solved it for some.


        Have you tried chaging your SIM card?


        Another thing you probably should do is to open a ticket with T-Force and get the tech team involved in tracking and debugging the problem.

        • mttech

          I never had any issues when using VoLTE on my Galaxy S6. matesny is correct, it does require T-Mobile's official ROM to enable VoLTE. You mention that your phone is currently running on Marshmallow. Go to settings > About Device. What Baseband version is your phone on? If it is G920TUVU3EPD1 then you have the official T-Mobile Marshmallow ROM. If your Baseband is one of the following:









          Then you are running an older software version, and you should be able to update to the new G920TUVU3EPD1 Baseband. If your Baseband does NOT match any of the numbers I listed, then your phone does NOT have an official T-Mobile ROM.

          If your phone's Baseband does match the official T-Mobile Marshmallow Baseband number and VoLTE still won't work. I would try getting your SIM card replaced at a T-Mobile store. Replacing a defective SIM card should be FREE or charge. Mention to the employee that VoLTE doesn't work on your device, so even if they changed your SIM card, they can help you troubleshoot the problem.

          • mttech

            opwog Have you tried turning off only Wi-Fi Calling and leaving VoLTE Preferred on? I live in the Twin Cities area and although I don't have issues with VoLTE with Wi-Fi Calling on, I just turn off W-Fi calling as I find it a hassle when I'm using a free public Wi-Fi network and Wi-Fi calling would work half the time. I only turn on Wi-Fi calling if I'm in a building with no service at all and I'm connected to Wi-Fi. Haven't had any issues with VoLTE with Wi-Fi calling OFF. The only time I had an issue was when T-Mobile had the VoLTE outage that affected everyone nationwide.

            • matesny

              Let's think more about the situation here:


              Your VoLTE Calls go through. You can send and receive calls using VoLTE.

              You can have the first minute or so of the call going fine but then the other party can no longer hear you. But you can hear them.


              They do not hear you because you are not transmitting anything to them.


              What does this point to? It points to your device. And what could it be? Many things.


              Could be an optimized system service that thinks microphone isn't being used and turns off the power to it. Or maybe another system service thinking you are not on a call or running any app to process voice data, thus, throwing away the microphone input into the /dev/null oblivion!

              Maybe the power mode you are using turns off the microphone when the screen goes off....

              So there is something happening at around one minute after a VoLTE Call starts that triggers the system to stop processing microphone input, or stop broadcasting volte packages. It is triggered by something else on your device. Some other setting.


              Think in this direction and look through all your settings, including developer options if you have it enabled.


              (It is ALSO possible that network may be deciding to stop processing your volte packages after a minute, maybe due to errors in package headers that goes over a certain threshold but this is quite unlikely.)

                • opwog

                  matesny wrote:


                  Let's think more about the situation here:


                  Your VoLTE Calls go through. You can send and receive calls using VoLTE.


                  Let me clarify the calls can sometimes go through. The issue that I described here is what happens when they do go through. But the other issue is that they do not go through at all. I can't speak to what happens on an inbound call when it fails (presume they go straight to VM), but when I have tested VoLTE when I have been out and about, I will try to call somebody and then it looks like it is calling, but I do not get any ringing and within about 30 seconds to a minute, the call fails (hangs up). And I know that is the VoLTE, because I have tested that numerous times that when that happens a couple of times, I will turn off VoLTE and the call will go through with no problems.

                    • tmo_mike_c

                      I feel like you've made it very clear what's going on. The resolution would still be the same based on what you've described. Since this is happening over multiple devices, in various locations, and only while connected to VoLTE, we'd need to file a ticket. Here on the forum we don't have the ability to view your account or any past ticket numbers that were noted there.


                      As I mentioned before, if it's been over a year since your most recent ticket was filed, you'd need to have a new one created. In the new ticket, we'd need to include any recent examples of calls (times, dates, and numbers) in which you've noticed this happening. With this information included on a new ticket, it'll give us the best chance at providing a solution for this.