Galaxy S5 is stupid slow since update. Usual fixes don't work.

andrew.r.long@live.com

    I've always found the Samsung Galaxy S5 slow. Then in December something magical happened. Some update was being pushed to my phone and it started working like I imagine a phone should work. When I pressed an app icon... the app opened! Then 3 days later my world came crashing down. Another update was pushed to my phone. Now I go through this barbaric process of restarting my phone in order to do anything. It starts. It works for a bit. Not too fast, but functional. Then it slowly bogs down until my choice is between throwing it against the wall or restarting if I want anything to happen. Typing becomes impossible since it takes about 30 seconds for my keyboard to open up, then about 5 seconds per letter for the phone to notice I am pressing buttons. Since I'm still paying it off, I usually decide to pull the battery (it would take forever for the menu to appear if I tried restarting using the power button) instead of destroying the phone.

     

    Unfortunately, I am not sure exactly what update made it work great and what update made it crappy again. I am pretty sure the 5.1.1 update is what made it slow down; however, for all I know the first update was 5.1.1. and the second update was something else. I wish (and maybe there is) a way to look up when I updated my phone and what exactly was updated when that happened.

     

    I have tried clearing the cache. I have tried doing a factory reset. I have tried clearing the cache then doing a factory reset. Then I tried clearing the cache again. No combination of cache clearing and factory resetting has changed anything. I don't even get a short reprieve like I have seen other people mention. I have noticed that it seems to be worse when I have recently used an app, but since "using apps" is the phone's only function, I assume the phone is supposed to be able to handle it. Frequent culprits include Boom Beach, Facebook, the SwiftKey keyboard, Chrome, and virtually any other app. When I force stop apps, the phone speeds up a bit, until I open one of those apps for more than 5 minutes again. Unfortunately, sometimes the phone is so slow that I can't get to the force stop menu and I again have to decide between destruction or disassembling my Otterbox case and pulling the battery.

     

    Thanks for reading. I kind of assume no one will be able to help since this problem seems to have existed for ages and no one has done anything about it. Are iPhone's like this? Is there any phone that you use and are like, "Man, isn't it great that something you bought brand new f---ing works?!"

      All replies

      • tmo_mike_c

        Looks like you've done quite a bit on your own to get a handle on this. Sorry it's been such a pain. I do have a question. After you did the master reset, did you make sure there were no 3rd party apps on the phone when you tested it? I just want to see if if this is happening with just the stock apps on the device.

          • andrew.r.long@live.com

            I did not do any testing before installing 3rd party apps.

              • tmo_mike_c

                At this point, it's definitely worth a shot. It'll help pinpoint if this is something coming from a 3rd party app or not.

                  • andrew.r.long@live.com

                    Let's say I did it. And let's say it doesn't happen with stock apps. But does happen with any of several 3rd party apps, including some of the most widely used 3rd party apps on Android (the ones I mentioned before). Again, I haven't done this, but I imagine what I just said is what I would report back if I did.

                     

                    From there, I imagine you'd say the problem is with the apps. Something changed with Android 5.1.1, specifically it relates to the S5 or some specific build of the S5, and the apps didn't do anything to handle that change. Since the S5 is now 2 generations old, likely Facebook, Supercell, etc. are not spending a ton of time trying to fix problems that only appear on some specific build of an old phone. While that seems to put the culpability in the hands of these other app developers, at the end of the day I still have a phone that is barely usable.

                     

                    If this were the case, and assuming my assumption about your diagnosis would be true, is there anything that can be done? For instance, I've never tried downgrading a phone to a previous Android version before. Is that advisable?

                      • tmo_mike_c

                        You have a good point. I'm not here to just pass the blame on the applications, but I do understand that there are some instances where they can be the culprit. Applications can do some strange things to phones after a software update, so we'd like to test this using steps like uninstalling them and seeing the results.

                         

                        With that being said, there is something that can be done. Since there are multiple applications, you could remove them and download them back gradually, then see how the phone does.

                         

                        If the phone works like normal without a certain app installed, it's safe to say that this app is the root cause of any trouble. Bringing this to the attention of the app developer would be the next logical step.

                        The specified item was not found.

                         

                        As for downgrading the software, I can't advise that. This could void the warranty so it's not recommended.

                • hallda

                  You've probably already seen this, but the general description of the issues you've reported are in line with this thread that started in Jun 2015.

                   

                  The specified item was not found.

                   

                  Re-imaging your phone to a previous official version is not hard to do.  I'm pretty sure this wouldn't be a warranty issue as you are not hacking the phone.  However, if you are rooting your phone, that will trip the warranty counter and likely void your warranty.

                   

                  My spouse's phone is out of warranty anyway and we rolled it back to 5.0 and it was a noted improvement.  Once you do that, you need to disable the update service or it will try to update back to 5.1.1.

                  • getmet

                    seems to be only on the tmobile 5.1.1 version update. ATT Verizon seem good and better on 5.1.1 on same apps.