latmanvx

    Hello community peeps! I was recently (Dec 28, 2015) added as a 4th line to my family's T-mobile plan. We have 6GB of fast speed internet as part of our unlimited data plan. Everyone in that plan besides me has a fast connection using their data network. My T-mobile version of LG G3 is upgraded to Lollipop 5.0.1, and although I have a 4G symbol with arrows in the upper right corner, my internet works either very slow or sometimes does not connect at all.

     

    My mobile network is connected to HSPA, sometimes switching to HSPAP. I cannot connect to the T-mobile (LTE) when I search for networks. I can only "automatically select preferred network." My access point names is valid with fast.t-mobile.com APN configuration.

     

    Sometimes I can connect through my data usage (very very slow), but more often my connection is hung up, and I get a message with the following:

     

    "the server closed the connection without sending any data"

     

    A suggestion is made to "make sure you have data connection" while my 4G symbol with arrows is displayed.in its corner. I don't seem to have any issues making calls or receiving texts, but the internet is the only problem I'm dealing with. My wifi works perfectly and never drops. I've done a full factory reset and a hard reset, but the problem persists. Sometimes even, if you will believe me, my network drops me down to the 2G Edge network. I was incredulous, too!

     

    I have contacted T-mobile technical support, and two times the representatives have recommended me to turn off my phone while they reset my network settings or something to that effect. The issue does not lie with the sim because I swapped the sims between my mom's iphone 6 and my LG G3, and on her phone my sim works flawlessly with amazing internet speed while the internet of her sim in my phone is as fast as *imagine* a baby tortoise wading through thick honey.

     

    This leaves me with the very confident hypothesis that the issue has something to do with my phone and possibly the lollipop upgrade, which has stirred lots of trouble for other users.

     

    Any advice for your fellow LG G3 lollipop upgraded peep? Thank you for any help

      All replies

      • tmo_mike_c

        Re: LG G3 data network isn't working properly

        You've done some great steps on your own latmanvx and that's rough you're data is not as fast as the other lines. I'd like to help you out here.

         

        First off, when you ran the speed test, what was your download speeds? Are they faster than 2Mbps? If so, and since you've already called, have you given our T-Force team a shot? They are an awesome group of T-Mobile experts that help over social media channels and can look into this much further. They can be reached via the Facebook, Twitter, and Google+ links below and they're available 24/7. You can link them to this thread and have them reference DOC-41167 as it has the next steps they can follow to help you more.