1 2 Previous Next 18 Replies Latest reply: Mar 24, 2016 1:16 PM by pixelchutes RSS

    TM-AC1900 QoS/Performance Issues

    sgs

      I'm currently using a TM-AC1900 as the router on a TimeWarner cable connection which is supposed to be 20Mbps/2Mbps

       

      Downstream has been close to rated, but upstream has been struggling -- measured around 560kbps making even sending email slow.

       

      After upgrading the cable modem and doing some testing with TimeWarner, we determined to sourly of the problem to be the TM-AC1900.

       

      Taking it out of the loop give me 25M/2.5M putting it back in gives 23M/880k, so it appears the the TM-AC1900 is consuming more than half my upstream bandwidth, even with no call in progress. Firmware is current, Smart QoS is on. Suggestions?

       

      On a related note, I've noticed dropouts on my VoIP phones (connected over ethernet) since installing the TM-AC1900 -- is there a way to configure it to give the same priority to VoIP calls over Ethernet as it does to WiFi calling?

        • 1. Re: TM-AC1900 QoS/Performance Issues
          sgs

          Replying to my own message: I called in to TMO support on Dec 23 to makes sure this question was answered and was told I'd receive a reply within 48 hours. That never happened.

           

          Called back again today (Jan 5) to follow up and (after 27 minutes) was told that engineering had determined that the problem was with the cable provider and closed the ticket. When I pointed out that the cable company and I had debugged the issue and determined that the problem was the router, the call mysteriously disconnected and there has been no callback.

           

          To help anyone else experiencing this issue, I was able to recover my upstream bandwidth by replacing the TM-AC1900 with a Ubiquiti EdgeRouter Lite 3 ($100 on Amazon) running EdgeOS 1.7 which has reasonably configurable QoS and put the TM-AC1900 into access point mode (disabling the built-in router and making it a bridge) and moving it downstream of the ER-3.

           

          This restores my upstream bandwidth to an expected number -- 22.52/2.08 Mbps from my ethernet network as reported by speedtest.net, where TimeWarner advertises 20/2 Mbps -- with QoS enabled in the ER-3.

          • 2. Re: TM-AC1900 QoS/Performance Issues
            sgs

            To add a bit more data, I did receive a callback a couple hours after posting the message above. They said they would be contacting the router vendor and I should give them until Friday (today) to get an answer.

             

            A couple more related questions: would it be possible to get some documentation on what DSCP and/or IEEE 802.1Q tags are applied to WiFi Calling packets by the TM-AC1900 so that I can configure the ER-3 to give them the same priority as SIP packets from my IP phones? (Short of resorting to Wireshark of tcpdump to reverse-engineer the information)

             

            Is "WiFi calling" identically equal to SIP to an upstream router?

             

            What prioritization is being done on the WiFi side if I wanted to configure my own WiFi router to do the same thing?

             

            Also, it would be useful if the TM-AC1900 did the same for IP phones connected via Ethernet.

             

            The IP phones I have (Yealink T-22P and Grandstream GXP2160) are already recognized by the voice VLAN feature of my (Linksys GS308P) switch, so this ought to be automatic -- similarly, the default QoS settings (smartqueue) in the ER-3 handle them automatically.

             

            I can resolve the performance issues by using a different router as my gateway, but this is something that should "just work" without someone with an electrical engineering degree and a significant amount of networking experience spending several days diagnosing the problem and tweaking router settings.

             

            Regardless of the QoS issues, the TM-AC1900 shouldn't be reducing upstream bandwidth from Ethernet to unacceptable levels.

            • 3. Re: TM-AC1900 QoS/Performance Issues
              tmo_mike_c

              Hello there sgs!

               

              Just checking in to see if you heard back from the representative that called the router vendor. Did someone get back in touch with you?

              • 4. Re: TM-AC1900 QoS/Performance Issues
                sgs

                Hi Mike, I got a call back from support with a rep from ASUS bridged in -- unfortunately there were language issued -- he kept explaining to me that putting the router into access point mode (which I did to disable the router and substitute my own to prove that the problem was the ASUS router and not Time Warner) would disable the router.


                (I do commercial software development and have Taiwanese clients, so I'm pretty good at English by Mandarin speakers, but couldn't get much to survive a round-trip. Sometimes email is easier than phone with this particular language pair -- similarly, I can read French, but have a hard time understanding it spoken in real time)


                They resolved to send me a new AC1900 to determine if my unit is defective. I was just about to leave town for a business trip, so we delayed delivery until I returned -- I'm on the way back and should have it Thursday. Will post an update when I've had a chance to test it. I'll be (pleasantly) surprised if it behaves any differently (unless is has newer firmware not available for download), but we'll see.

                • 5. Re: TM-AC1900 QoS/Performance Issues
                  sgs

                  OK, finally got a chance to test the new router -- solved one problem and opened another:

                   

                  Referring to the instructions to set up Smart QoS on the router here:

                   

                  [Adaptive QoS] How to set up QoS?

                   

                  Setting up QoS on the new router with the bandwidth of the new (higher speed) connection got me full bandwidth, so went back to the original router to check the settings and discovered I'd forgotten to update the bandwidth settings in the QoS panel, specifically from 1mb/s to 2 mb/s up, which explains the bandwidth issue.

                  18226a54-35d2-4b28-a3bc-d17669e32a6b.jpg

                   

                  My bad on that (D'oh!), but also should have been one of the first questions in the support script for that problem. I'd totally forgotten about that configuration page.

                   

                  Now, the puzzler: note that there are two types of QoS: Adaptive and traditional.

                   

                  There are instructions for setting them up here [Adaptive QoS] How to set up QoS? so I tried each -- adaptive first, then traditional. No difference in measured performance, but adaptive seems more appropriate for my use case with IP phones as I assume it uses DSCP rather than requiting you to enter IP addresses and port numbers.

                   

                  Here's the problem: once I selected Traditional, the QoS Type item disappeared from the settings page:

                  Screen Shot 2016-02-18 at 12.27.13 PM.png

                  (this is a screen shot from the configuration page of my local router)

                   

                  and there appears to be no way to switch back to adaptive QoS.

                   

                  I was able to repeat this on both routers (and it's now no longer possible to access adaptive mode on either of them).

                   

                  So far I've tried turning QoS off and back on, resetting the router, and restoring to factory state with no luck -- the QoS Type setting is gone from both routers with no (obvious) way to get it back.

                   

                  How the heck do I get it back?

                   

                  Also, it would be useful to have some documentation on what Adaptive QoS actually does -- there's some documentation here: [Adaptive QoS] How to set up QoS- Adative type and I'm guessing that each box is a DSCP class (or group of classes), however it would be useful to have some idea what's going on.

                   

                  Thanks for any advice,

                   

                  -Steve

                  • 6. Re: TM-AC1900 QoS/Performance Issues
                    smplyunprdctble

                    I should have almost thought about this QoS business.

                    There was a time I had bought a router (probably my current one) and I was complaining about the same thing -- my downloads and uploads were awful slow.  But, it didn't happen as soon as I put on the router, it happened after I changed something, and I was an idiot and didn't track what I changed when and completely forgot what I did.

                    I eventually found the limits on the router and once I changed them, everything was beautiful!

                     

                    (In my case, in order to provide certain devices priority of bandwidth, it needed to know how much bandwidth I had.  It defaulted to some setting that was lower than my provider's speed.  Manufacturers REALLY need to put big bells and whistles around these QoS things that say "If you're turning something on, PLEASE make sure your bandwidth settings are right!")

                    • 7. Re: TM-AC1900 QoS/Performance Issues
                      tmo_mike_c

                      Wow, you're right, this is a puzzler. I don't have any other suggestions on getting it back other than a reset and going through the setup process through the admin page. ASUS would be the best bet for finding a way to get that option back.

                       

                      Just outta curiosity, there aren't any traces of this program installed in your program list is there? I'm just thinking if there is, you could try uninstalling it and going through the setup again to see if that works.

                      • 8. Re: TM-AC1900 QoS/Performance Issues
                        sgs

                        tmo_mike_c wrote:

                        Just outta curiosity, there aren't any traces of this program installed in your program list is there? I'm just thinking if there is, you could try uninstalling it and going through the setup again to see if that works.

                         

                        I'm not quite sure what you're saying here.

                         

                        Restoring factory defaults from the Administration panel and running through setup again doesn't bring it back.

                         

                        (Unless this behavior is triggered by double-NAT, which I'd find unlikely -- I'm happy to plug the spare device into my network and blow it away w/o tearing my working network apart, less so if I have to rearrange everything for the test)

                         

                        The issue with calling ASUS directly is that the TM-AC1900 uses T-Mobile-specific firmware, resulting in finger pointing between ASUS and TMO. I'd be willing to bet that flashing it with the current AC-68U (?) firmware might fix the problem (see many complaints about TMO firmware not being updated), but that's a lot of work for little gain.

                         

                        At this point, I'm kind of into the territory of solving the problem for others -- while more complex, using the Ubiquiti EdgeRouter for the gateway and putting the AC1900 into AP mode gets the job done and has other advantages.


                        Happy to run tests on the spare AC1900 if it will help anyone, though.

                        • 9. Re: TM-AC1900 QoS/Performance Issues
                          tmo_mike_c

                          Sorry, let me rephrase what I'm asking. When you were going through the setup, I'm assuming you accessed the Administration Panel through a desktop computer?

                          • 10. Re: TM-AC1900 QoS/Performance Issues
                            sgs

                            Correct. (From the LAN side of the router)

                            • 11. Re: TM-AC1900 QoS/Performance Issues
                              tmo_mike_c

                              Ya know what, I was thinking the computer may have saved the QoS settings somehow and was keeping them as the default which wasn't allowing you to go back and change them. (It's a stretch I know, but I'm just trying to think of other possible causes to this mystery )

                               

                              Any-who, I don't want you getting caught in a "finger-pointing" battle either. I only suggested ASUS because we can only give you so much support for this. Plus, this is kind of a unique issue and I figured they may have more suggestions on bringing that option back.

                              • 12. Re: TM-AC1900 QoS/Performance Issues
                                sgs

                                I can see where you're thinking it might be stored in a cookie or something, but have repeated with multiple computers.

                                 

                                The first time I called ASUS and they told me to call TMO support (and I mean call -- online/chat not an option) -- that resulted in about 6 hours of phone/hold/calling back time over several days and weeks eventually resulting in shipping a new router to verify mine wasn't defective. We're completing that experiment.

                                 

                                Alternatively, is there anyone out there who can verify that they were able to switch to Traditional QoS, them back to Adaptive?

                                 

                                It would be great if someone at TMO (with a supply of routers) could try to duplicate the problem.

                                 

                                As far as I know, the steps are:

                                1. Unpack the router and set it up in default configuration
                                2. Click on "Traffic Manager" and enable Smart QoS
                                3. Set to Adaptive, Apply and run a speed test from your favorite site
                                4. Switch to Traditional, Apply and run another speed test
                                5. Try to switch back to adaptive

                                 

                                At this point (on both routers I've tested), the QoS Type setting is gone and, based on the settings available, it's in Traditional mode, with no obvious way to switch it back to adaptive.

                                 

                                I'd be surprised if the speed tests are necessary, but including them for completeness.

                                 

                                As I've mentioned, so far, I've tried:

                                1. Turning QoS off and back on
                                2. Using Administration -> Restore/Save/Upload setting-> Factory default
                                3. Resetting with hardware button

                                 

                                This should be a standard use case for anyone who is using streaming video or does VoIP.

                                 

                                Thanks,

                                 

                                -Steve

                                • 13. Re: TM-AC1900 QoS/Performance Issues
                                  tmo_mike_c

                                  Yes, that's exactly what I was thinking, but it looks like you beat me to the punch. There isn't anyone at T-Mobile that can verify if the settings can be switched back. We only provide so much support and the QoS goes a little beyond what folks normally do with the router. If the router doesn't work when you're using Wi-Fi calling or data and you've gone through the setup process that we have steps for, we can help with that. If you're configuring the router to have a different setup, that's when we rely on ASUS to give us hand.

                                  • 14. Re: TM-AC1900 QoS/Performance Issues
                                    sgs

                                    Mike, (chuckle), somehow I was expecting that [no one at T-Mobile has access to routers] -- although it's with mentioning that the WiFi calling feature (which is the reason you're supplying these things for in the first place) is absolutely QoS and is probably identically equal to running Smart QoS on the WiFi interface.

                                     

                                    I'm just trying to give VoIP phones connected via ethernet the same treatment.

                                     

                                    The problem is I can't get a technical description of what the user-visible features are doing.

                                     

                                    OK, just spent an hour on the phone with Customer Service, then Resolution who eventually said I need to talk to Solutions. Resolution can't access this website, so they sent me their email address and offered to forward an email to Solutions so I don't have to wait on hold again.

                                     

                                    I'm tempted to keep documenting this as an exercise on tech support futility.

                                     

                                    FWIW, everyone I've interacted with has been fantastic -- no complaints about the people and their efforts -- but the process is dysfunctional -- i.e. Resolution can't access this thread, I have to call Cust Svc, to get to Resolution to get to Solutions when I need to follow up on an open issue)so I have to keep repeating the same thing over and over to the same people).

                                     

                                    It may be worth forwarding this to someone in management who has control over the process as it (the process) seems to be frustrating everyone.

                                    1 2 Previous Next