Can't setup my voicemail system. Says I have an invalid number.

    donAs the title says, I can not setup my voicemail. It prompts me to hit pound and enter in my number or to enter in a ten digit number to send a message. When I enter in my own number to get started, it says that my number is invalid. I just signed on with T Mobile last month and this phone is new. I just want to get my voicemail setup and done with.

      All replies

      • e2k

        You mailbox has not been setup correctly on the T-Mobile side. Call 611 & they will fix it for you.

        1 of 1 people found this helpful
        • tmo_mike_c

          Hello krispy038!

           

          I sure hope this has not been going on for a whole month! Yikes! You definitely want to Contact Us so we can have our tech team correct it so your number is valid in our voicemail system.

          • leceli

            I have the same problem. I can not setup my voicemail. It prompts me to hit pound and enter in my number or to enter in a ten digit number to send a message. When I enter in my own number to get started, it says that my number is invalid.

            • virguinia

              I had the same issue!!! I literally called 5x and spoke to 7 different people and 3 differen department!!!! SO FRUSTRATING AND WASTE OF TIME!

              Long story short I had changed my phone# the day before and after that i was not able to set up my voicemail even after numerous attempts it  was unsuccessful and mind you each time

              I called I was on hold between 30-80 minutes. After my fifth time calling I finally got a repre who was able to help me. She deleted the voicemail feature and then added it back again and that worked. I wish all representatives were on the same page! It could have saved me half my day!!

              • cplava123

                I can't setup my voicemail either.  I get the same message that my number is invalid.  I have only tried once by phone and once by text and it still is not resolved. I hope that the store has better customer service.

                  • terrorbyte

                    I'm having the exact same problem. Switched service on Saturday, still not fixed by today (They said it could take 48 hours), I was on the phone with Customer Support, now on the phone with Tech Support, and he wanted to transfer me to Apple because he thought it was just a problem with my Visual Voicemail. NO! I said I can't even set it up! The guy had me restart my phone and he's calling back any second now. I'm not super happy. I've gotten many calls from unknown numbers who I don't know if they were important or not because "I'm sorry, this mailbox is invalid." I'm staying with T-Mobile because they are cheap, but this is utter ridiculous right now. Hopefully they get it fixed.

                      • terrorbyte

                        Alright, so the tech support guy literally told me to call AT&T because I transferred from them. Ummm...WHAT KIND OF RESPONSE IS THAT. So I contacted them over chat and the new tech support guy I contacted said that he checked their technical reports and said there is an issue retrieving and setting up Voicemail, and it started on November 2, 2018. There is no estimated time to fix, however he said issues like this usually take only a week to solve. Just letting the community know since this is an ongoing issue that many users have seemed to have.

                          • magentatechie

                            I realize that this is an older post, but I wanted to check in to see if anyone was able to get this issue resolved.  I've seen the same issue if the ENHANCED VOICEMAIL feature is missing from an account.  You will need to reach out to T-Mobile to have them check and if it's not there it will have to be manually added.  It might be a good idea to contact T-Force directly. I've had great experiences with them fixing issues with my account.

                            1 of 1 people found this helpful
                              • terrorbyte

                                Yes, the issue was resolved for me. When I switched to T-Mobile, I was given a temporary number when my account was setup, and that number went away about 10 minutes later when I ported my old number from AT&T. During the porting process the Voicemail wasn‘t ported to the new number. To prove this, I went to the voicemail system and when it asked for a mailbox number, I typed in the temporaft number I had originally, and what do you know, it tried to set the voicemail account up. Dialing the number however would result in a “no longer in service” message, so obviously something was up. I contacted T-Mobile Help over twitter and they were able to open up a ticket, and my issue was resolved within 48 hours. From what I gather, the porting process didn’t 100% change EVERYTHING over, and so when the other techs that tried to work on my voicemail did stuff, it was actually messing with the other box attached to the number no longer in service.