tricon23

    What is the current firmware for the Personal Cell Spot? Mine is 3.0.0.4.376.3108.

     

    Thanks!

      All replies

      • jwhlrussell

        Re: Current TM-AC1900 Firmware?

        Yes, I would like to know what the current firmware is also. In looking over the various threads on the subject it's a bit confusing. I have what tricon23 states above but a confirmation would be appreciated.

         

        Thanks!

        • i called asus support they told me to download latest firmware here

          https://www.asus.com/us/Networking/RTAC68U/HelpDesk_Download/

          they said it is the same router just rebranded...

          • mindragon

            Re: Current TM-AC1900 Firmware?

            I wish T-Mobile would do an amazing announcement around this...

             

            * The Forum Software used here isn't even updated with fixes for Facebook login / Yahoo login. Both are broken.

            * Just like their inattention to the Forum Software, they are not paying attention to ASUS updates. Several revisions later, the TM-AC1900 is far behind the RT-68U updates. Here is a change log of what is different now - in bold are critical security updates. Now I don't want to 'downgrade' my router to just an ASUS router, instead of a T-Mobile / ASUS router...but I have to and I URGE EVERYONE ELSE TO DO THE SAME. These are CRITICAL security updates that leave your network UNPROTECTED!!

             

            - Fixed Multicast issue when WAN is PPPoE/ PPTP/ L2TP

            - Fixed IPTV GUI issue

            - Fixed two guest networks had same mac address problem.

            - Fixed view list in network map cannot be closed.

            - Fixed network map device icon issue

            - Fixed client cannot get new IP when changed router IP and subnet mask.

            - Fixed wrong notification when using quick internet setup wizard in static IP environment.

            - Fixed wrong notification when client was blocked by Time scheduling.

            - Fixed ASUS Router App related issues.

            - Fixed DNS response error issue.

            - Fixed abnormal LED blinking issue when enabled IPTV.

            - Fixed client list name cannot be changed issue.

            - Fixed too many repeat information in system log.

            - Fixed Traffic analyzer issue UI issue when changing the data.

            - Fixed Adaptive QoS bandwidth setting issue.

            - Fixed low samba transfer throughput issue when enable bandwidth limiter.

            - Fixed web history related issue.

            - Fixed abnormal bandwidth increasing in bandwidth monitor.

            - Fixed VPN client UI issue when using Firefox.

            - Fixed wireless channel issue when set 2.4G channel in 12 or 13 (only for EU region)

            - Fixed dual wan ping time watch dog issue which might cause .false fail over to secondary wan.

            - Fixed Bandwidth monitor and Web history UI issue which was caused by "<" or ">" in SSID.

            - Fixed vulnerability of the cross site scripting

            - Fixed User-Agent buffer overflow. Special thanks for Hubert's contribution.

            - Fixed null ptr dereference in https issue. Special thanks for Anthony's contribution

            - Fixed buffer overflow issues.

            - Modified brute-force protection mechanism in router login page.

            - Fixed malicious site block related issues.

             

            New Feature

            Support ASUS router app which make it very easy to monitor and manage route status and client devices and more.

            Search ASUS Router in google play or go the following URL

            https://play.google.com/store/apps/details?id=com.asus.aihome

            iOS app coming soon.


            - Fixed httpd crash issue. Special thanks for Merlin's contribution.

            - Fixed blank web page when clients number over 100.

            - Fixed Network map client list related issues.

            - Fixed firmware login issue when connect to router by OpenVPN.

            - Add reboot scheduler in Administration --> System

            - Fixed warning page showing issue when only enable the HTTPS authentication.

            - Fixed the slow UI issue when enabled Bandwidth limiter.

            - Fixed repeated mDNSNetMonitor message in system log when there is a Apple TV in LAN.

            - Fixed IPv6 firewall UI issue.

            - Fixed UI issue when enable monopoly mode in printer setting.

             

            3rd party app supported

            Added Cloudcheck router software agent. Cloudcheck agent enables intelligent wifi diagnostics that provides complete visibility into home network performance and offers actionable recommendations for improvements.

            - Updated TrendMicro security engine.

            - Fixed CVE-2015-6949 buffer overflow issue, special thanks for Elvis Collado at DVLabs.

            - Fixed Host and User-Agent parameter buffer overflows, special thanks for Elvis Collado at Praetorian

            - Fixed Web server URL handler buffer overflow, special thanks for Tim Yeh and Kenney Lu at TrendMicro.

            - Enhanced router login password and wireless password(WPA2) strength check method to against brute-force attack.

            - Reject administrator to set too easy to guess login and wireless password to avoid brute-force attack.

            - Added Meo and Movistar ISP profile.

            - Adjusted Guest network mac filter maximum client number to 16

            - Allow paste password on login page to fulfil some password management softwares requirement.

            - Show current control channel while value is auto.

            - Bandwidth limiter can accept decimal point.

            - Unnecessary to reboot router after set allow only spcified IP address to enter GUI.

            - Adaptive QoS can now be enabled without assigned upload/ download bandwidth.

            - Updated OpenSSL library to 1.0.2d

            - Fixed CSRF and XSS vulnerability.

             

            New features

            - [AiCloud] Show image EXIF info on image player

            - [AiCloud] Auto rotate image on image player.

            - [AiCloud] Files can be moved and copied.

            - [AiCloud] Images can be uploaded to Picasa or Twitter.

            - [AiCloud] Share link can be posted on Twitter, Plurk, weibo and QQ in AiCloud.

            - [AiCloud] AiCloud can be used in AP/ media bridge mode.

            - Added 3G/4G USB modem APN auto detection feature. In most cases, firmware can automatically find the ISP profile and establish link when 3G/4G dongle inserted to router.

            - Added Android phone in USB modem/ USB Tethering --> Select USB device.

            - Bandwidth Limiter in Adaptive QoS --> QoS. Let administrator easily limit specific client's upload/ download bandwidth

            - Independent mac filter for main wireless network and guest network. Administrator can set white list for main wireless network to only allow trust client connect to main wireless network and share network to guest with guest network

            - Modified the network map client status. When click the client icon, administrator can bind IP, change host name, change icon, block internet access or set time scheduling.

            - Added client list view button on network map and help administrator easily monitor all client connection status.

            - Added the question feedback in Administration -> Feedback

            - Added new DDNS provider www.oray.com

             

            Modifications

            - Changed warning page style.

            - Changed Cloud sync Dropbox URL encoding from UTF8 to BASE64.

            - Added stateful server in IPv6

            - Improved media server response time when new file added.

            - Adjusted Adaptive QoS UI and easier to set top priority for gaming, media streaming or web surfing.

             

            Bug fixes

            - Fixed MAC clone abnormal issue

            - Fixed cloud sync issues between router and ASUS webstorage.

            - Fixed share link related issue to Android devices.

            - Fixed web redirection issue when WAN IP conflicted.

            - Fixed compatibility issues for IE8

            - Fixed GUI related issues

            - Fixed login issue when router’s IP is 10.x.x.x

            - Fixed parental control-> time scheduling related issue.

            - Fixed adaptive QoS device priority label dragging issue.

            - Fixed network tool related issues.

            - Fixed USB HDD issue when using time machine.

            - Fixed network map UI issue when selected French.

            - Fixed the saving issue in OpenVPN server -> content modification of keys & certification.

            - Fixed dropdown UI offset issue at Parental control.

            • ty2015

              Re: Current TM-AC1900 Firmware?

              since 2016-06-04,....

              Product ID: TM-AC1900

              Firmware Version: 3.0.0.4.376_3169

              The router's current firmware is the latest version.

                • tricon23

                  Re: Current TM-AC1900 Firmware?

                  Finally!

                  • cmg0

                    Re: Current TM-AC1900 Firmware?

                    This latest update seems to have broken the ability to use a connected HDD for Time Machine. I have two disks connected. One is a media server, the other is for backup. Using the Time Machine setup pane I had identified that disk and it showed up on all the Macs in the house as AC1900-7330. But since this update AC1900-7330 no longer appears. The media server disk is still there. Help!

                      • kulea

                        Re: Current TM-AC1900 Firmware?

                        I am also having trouble with Time Machine. Every time the disk image is mounted the CPU and RAM on the router starts pegging. The backup then gets stuck on Preparing for Backup for hours. Eventually, the backup just fails. For a while it did get to start backing up, but it did only a few MB, then pause, then some more, then long pause. After maybe a few hundred MB total, the backup failed. That happened for a few days. Now it never gets past preparing. And the whole time the CPU and RAM are pegging. As soon as I dismount the drive from my computer, the router settles down. Needless to say, I haven't had a successful backup since the upgrade.

                          • cmg0

                            Re: Current TM-AC1900 Firmware?

                            I'm unable to mount the disk image, since it doesn't even appear on my network (I checked this from two different Macs). So you're ahead of me here. I wonder what the difference is?

                              • kulea

                                Re: Current TM-AC1900 Firmware?

                                How big is your TM partition (disk) and is it connected to the USB2 or USB3 port? Mine is 4TB on the USB3 port. It also might be the number of files, or type of files. What do your system status meters look like when the drive is plugged in and mounted to the router?

                                  • cmg0

                                    Re: Current TM-AC1900 Firmware?

                                    The reason for my delay in responding was that I just completely factory reset and reconfigured my router. But there's no change.

                                     

                                    I'm using an entire Seagate 5TB drive, plugged into the USB3 port. It's formatted with a single OS X Extended (journaled HFS Plus) partition. I have a second drive that is usually plugged in to the USB2 port to use as a media server, but I have turned off the media and Samba servers and unplugged it for this test. This configuration - with both disks - has been in use and working with no problems until the day the firmware (automatically) updated to 3.0.0.4.376_3169.

                                     

                                    Right now the status meters are showing 5% and 0% for the two cores and 103MB of RAM (41%) in use. But the Time Machine disk is not visible on the network (checked from two different Macs that had been routinely backing up to it). According to the instructions on the configuration page, it should appear as an SMB server.

                                     

                                    I gather you can see and mount yours but you can't use it, which is completely different behavior from mine.

                                     

                                    I called T-mobile support, and the person I spoke to was completely clueless, alternately telling me to call ASUS and call Apple. This is clearly an issue with the router that appeared with the new firmware, and I'm certain Apple won't have anything to contribute. I expect ASUS to tell me T-Mobile controls the firmware and so I should call them. But I will call ASUS tomorrow anyway. Then I will probably go to Costco and buy a Netgear Nighthawk, because as much as I don't want to spend the money, I don't have the time to spend on this.

                                     

                                    Just a thought for a support person… I wonder if there's a way to back up to the previous firmware version? I don't have a backup of it.

                                     

                                    UPDATE: For some mysterious reason it has suddenly started working. I guess it took a few minutes to start the server after I reconfigured the router. I will let the backup complete and then try enabling the other disk and servers to see what happens. The router has gotten a lot busier now… The CPUs and RAM are hovering close to maximum, and Time Machine still says "preparing backup." I'll update this in a few minutes after it actually starts (trying?) to send data.

                                      • kulea

                                        Re: Current TM-AC1900 Firmware?

                                        When you did the factory reset, did it revert to the old firmware, or did it keep the updated one? Let me know if it actually starts and completes the backup.

                                          • cmg0

                                            Re: Current TM-AC1900 Firmware?

                                            No it didn't revert the firmware, and now it does seem to be doing the same as yours. Stuck on "preparing backup" for about 25 minute. The router system status has settled back down to very low cpu and RAM usage.

                                             

                                            Just about time to go to bed and leave it running overnight.

                                              • cmg0

                                                Re: Current TM-AC1900 Firmware?

                                                Okay, I'm done for tonight, and probably done with this router.

                                                 

                                                • If I have my backup drive plugged into the USB3 port and nothing plugged into the USB2 port, I have pretty much the same symptoms as kulea. When I start the backup, CPU and RAM usage go way up and the Mac gets stuck on "Preparing backup…" Eventually (after 15-20 minutes) the CPU and RAM usage come back down again, but I've let it run up to half an hour so far and it never gets past "preparing." I'm going to leave it going overnight and see what happens.
                                                • If I plug a second drive into the USB2 port, even if no other servers are turned on in the router configuration (I usually share the other disk via iTunes, DLNA, and Samba), the first disk (TM-AC1900-7330) vanishes from my local network. If I unplug the second drive TM-AC1900-7330 immediately reappears.
                                                • If I turn on the other servers, sharing only the USB2 drive, that disk shows up on the network. But TM-AC1900-7330 is still nowhere to be found.

                                                Everything here previously worked just fine until the latest firmware update.

                                                 

                                                T-Mobile, is there any way you can send me the old firmware in a file (or point me to where I can download it)?

                                                  • kulea

                                                    Re: Current TM-AC1900 Firmware?

                                                    Did you ever get a successful backup?

                                                      • cmg0

                                                        Re: Current TM-AC1900 Firmware?

                                                        I contacted T-Mobile tech support and was told they don't support functionality other than wifi calling. They said I should contact ASUS.

                                                         

                                                        I contacted ASUS and they told me "I am really sorry to inform you that we do not support the T mobile router. As we are only the manufacturer of the chipset for the T mobile router, we do not have any support." They did not respond when I pointed out that the router goes to an ASUS server for its firmware, and all I had asked for was the old firmware.

                                                         

                                                        Meanwhile, I got nowhere with the backup, and nowhere with anybody being willing to take responsibility for support.

                                                         

                                                        I am now the proud owner of a Netgear Nighthawk router. I do not know for sure if the first backup with that worked since it was just getting started when I left for work this morning. I will return the POS TM-AC1900 to T-Mobile as soon as I have a chance. Really very disappointed with TMO, and I will never again purchase an ASUS product (I have bought their routers and monitors in the past).

                                                          • tricon23

                                                            Re: Current TM-AC1900 Firmware?

                                                            Looks like my router recently updated to 3.0.0.4.376_3181. Not sure what fixes improvements were made?

                                                            • mnagali

                                                              Re: Current TM-AC1900 Firmware?

                                                              so it seems I'm not the only one getting the run-around with getting support for the ASUS TM-AC1900 with T-mobile telling customers to get support from ASUS and vice versa. I'm just about ready to quit as well.

                                                                • snn_555

                                                                  Re: Current TM-AC1900 Firmware?

                                                                  I get that the TM-AC1900 has WiFi-Calling prioritized, but that could be done with the correct parameters set on the stock RT-AC68U.  I also understand that the update paths are separate given the Asus vs T-Mobile firmware, but in the end, the hardware is the same and the software is just tweaked.  It is my opinion that T-Mobile should be taking the Asus stock firmware and making sure it works with T-Mobile's WiFi Calling QoS specifications and should have the router's update path link to T-Mobile's servers rather than Asus'.

                                                                   

                                                                  This would be no different than Google releasing an Android update and T-Mobile "tweaking" it before rolling out to Android users.

                                                                   

                                                                  I'm fine with the features as-is, and don't need the extras in aftermarket firmwares, but the security aspect of newer firmware is a nice thought.  Or hey, this beast is almost 4 years old anyway, maybe even a newer version with newer hardware to match updated software.  I can see it happening, though I'd rather not, where this router turns into the Motorola SB5101 that TWC and Comcast still use as their "latest" available model in my area.  (13 years later)

                                          • jhill8

                                            Re: Current TM-AC1900 Firmware?

                                            I have

                                            3.0.0.4.376_3181-g247286a

                                            and it has not bee updated in years as far as I know.  unless is has done so automatically. some revision history would be nice.  I guess you get what you pay for.

                                            I wouldn't care but the 2.4 wifi just stopped authenticating.

                                              • snn_555

                                                Re: Current TM-AC1900 Firmware?

                                                Your update was the last and was just 3 months ago or so.

                                                  • sandog

                                                    Re: Current TM-AC1900 Firmware?

                                                    do you have to go in and update or will it auto update

                                                      • snn_555

                                                        Re: Current TM-AC1900 Firmware?

                                                        I was notified upon logging into the router's page one day.  It was not automatic.

                                                          • philbake1

                                                            Re: Current TM-AC1900 Firmware?

                                                            Mine seems to have updated automatically in mid-February.  Just logged into the GUI one day, and it's updated to 3181.

                                                              • snn_555

                                                                Re: Current TM-AC1900 Firmware?

                                                                I'd love to see some future support for this router, or if not, a new router with new support.  Though I can't really say I need a new router since this one works fine, but there are some changes and updates, at least in security, that would be nice in on-going support.

                                                                 

                                                                Wih as much as T-Mobile pushed this device, you'd think there would be some continued update support.  But, I am reminded of how Verizon released that Samsung Network Extender (3G-Only and $200) and it was a bit of a hassle with it's lack of security and method of connection, added to the fact that Verizon believed their network reached far enough that no one needed the device any longer.

                                                                  • philbake1

                                                                    Re: Current TM-AC1900 Firmware?

                                                                    While it would be cool to have the latest features, hey I didn't pay a dime for this router.  It works great, handles phone calls both on T-Mobile and my Ooma service, terrific coverage compared to most other routers....considering that, no complaints.  I'm sure they're very conservative with updates to minimize problems.  Their customer base needed a way to fill in the gap in poor coverage areas and this does the trick.

                                                                      • cmg0

                                                                        Re: Current TM-AC1900 Firmware?

                                                                        You're right, that (for the most part) the router works well and does (most of, see below) what it's supposed to. New features would be nice, but the real problem is lack of security updates.

                                                                         

                                                                        The other issue I've had is that a feature that originally worked, and that I was using, in this router - Time Machine compatibility - was broken by an update some time ago. I was very frustrated when T-Mobile told me to get support from Asus and Asus told me to get support from T-Mobile. Eventually, I ended up with a separate NAS for backups.