MMS Not Working with Wi-Fi enabled.

funkyguns

    Android 7.0 LG V10, unlocked.

     


    Wi-Fi enabled allows texting, browsing, media, everything, EXCEPT MMS or Group Texting/Chat.
    APN settings are the suggested "fast.t-mobile.com".
    I have tried three different settings of that APN, one with APN Protocol set to IPv4, then to IPv6, then to IPv4/IPv6, and the Roaming APN Protocol set to IPv4, IPv6, and IPv4/IPv6. I have six APNs to choose from and none of them work.
    I have tried every combination.

    I have tried the stock messenger app, I have tried the Textra app, I have tried other apps.
    I have completely disabled Wi-Fi calling, I have turned Wi-Fi advanced settings to "Cellular Preferred".

     

    The only way it works is if I go into airplane mode and then take airplane mode immediately off again, resetting something and forcing a connection again, OR I turn Wi-Fi off entirely allowing MMS to function over 4G. This is so undeniably aggravating.
    T-Mobile needs to send out an OTA update changing Android 7.0 to 7.1 or SOMETHING.

     

    This issue is so far reaching, and you can see thousands and thousands of the same question being asked on this website, MMS is the most popular FAQ/Troubleshooting issue on this website.

     

    What is necessary for allowing this basic functionality to work?

     

     

     

    *edited to remove tags - Marissa

      All replies

      • tmo_chris

        Re: MMS Not Working with Wi-Fi enabled.

        My goodness funkyguns,

         

        It sounds like you have pretty much done every troubleshooting step possible for this specific issue. I am honestly at a loss as to what to try next. We know it is not the network as it works when you do not have Wi-Fi on. We know it is not the APN settings as it would not work over 4G if it were. The process of elimination that you have gone through leads me to believe that the issue is more than likely software and the only thing left to try is a full factory reset. I know a factory reset is not ideal but you have literally done everything possible to troubleshoot this already.

          • funkyguns

            Re: MMS Not Working with Wi-Fi enabled.

            I guess that may be the case. A factory reset isn't very demanding as long

            as I move all my photos/music/credentials/details to a MicroSD and SIM card

            but it truly does seem to be the last hope. I'll factory reset and reply

            back with results.

             

            The issue being so vastly expansive across all devices leads me to believe

            it may be an Android 7.0 issue with T-Mobile due to their Wi-Fi calling

            capability. I imagine updating to 7.1 or 8.0 would fix the issue. As far as

            texting goes, Textra have questioned this issue and arose to the same idea

            I have, whereby it is a t-mobile issue unfortunately. I love the Wi-Fi

            calling though. Guess time will tell.

            • mike41674

              Re: MMS Not Working with Wi-Fi enabled.

              Hi Chris, I know this post is old and it's now Nov. 2019. I think I found a solution to this problem as I was having the same issue. I don't know if it's "the" solution but it works. I went into the developer options and turned on the keep mobile data on even when  WIFI is on for fast network switching. In addition aggressive WIFI to cellular option would probably also work although I haven't tried it. So I wasn't aware that you couldn't send SMS or MMS messages over WIFI with T-Mobile. It seems to be a problem with the WIFI handing over to the mobile data when sending messages. In any case it worked for me. If you've never been into the developer options you will have to tap on it 7 times I think to activate it. Thanks, Michael C.

            • tmo_chris

              Re: MMS Not Working with Wi-Fi enabled.

              Hey there! You still with me?

              • tmo_chris

                Re: MMS Not Working with Wi-Fi enabled.

                Fingers crossed. How are things going?

                • magenta6499265

                  Re: MMS Not Working with Wi-Fi enabled.

                  Mine is random. Sometimes I will recieve them and sometimes not. Hangouts always goes through though. When I told my friend to try it, he said it takes like 10 minutes to send, so I was wondering if the person sending it has a slow connection and it's timing out but you still receive something showing that they tried to send something but it's because of slow connection on their end. IDK