T-Mobile app

The T-Mobile app simplifies your mobile life. With it, you can manage your account without lifting a finger—just a thumb!





What you can do with the T-Mobile app



What you need to use it

  • A T-Mobile account.
  • A T-Mobile branded phone with the latest software:
    • Android devices need Ice Cream Sandwich 4 or higher, or Gingerbread 2.3 or higher.
    • Apple iPhones need Apple OS 8 or higher. iPads aren't supported at this time. To log in to the app on iOS, you must disable Wi-Fi on your device.


If you're running into problems with this app, check out our troubleshooting tips.