1 2 Previous Next 18 Replies Latest reply: Jul 25, 2013 4:10 PM by dmcmillo RSS

Galaxy S2 USB not being recognized, phone charging.

As the title states, my Galaxy S2 will not be recognized on my computer. When I plug it in, the phone charges, but there is no icon in the task bar. When I pull down the task bar, there is no option to go into Mass Storage mode. If I manually go into settings and USB Utilities, and click connect to mass storage device, nothing happens. It worked when I first had the phone, it just suddenly stopped working.

 

I've tried:

Different USB cords

Different USB ports

Different computers

Hard-resetting my phone

Restarting my computer

Dialing "*#7284#" and changing from PDA to modem and vice versa

I went through the chat session with a T-Mobile representative and she could not help me

KIES connects through Wi-Fi, but not through USB

 

At the moment I am downloading a Samsung USB driver from their website. I'll see how this goes.

EDIT: No luck.

 

I wanted to know if anyone found a solution to this problem before I contacted Samsung. I know this is a common problem because I've googled around and seen it come up a lot. Not just with the S2 but also with the S3. Any help would be appreciated. I'm going to the nearest T-Mobile store to see if they can help me out when I have time after exams. Meanwhile, I hope you folks can post some suggestions. Thanks.

1 2 Previous Next