3 Replies Latest reply: Nov 26, 2012 2:48 PM by jaylanphnx RSS

    Galaxy S2 control buttons stopped working (menu,home,back,search)

      They started to be unresponsive just every once in a while a couple weeks ago I would have to restart the phone and it would work again. After a week of that I had to reboot it repeatedly until I was lucky enough to have full control over my phone. I used Kies to backup my phone and then I updated to the most recent firmware on 11/10/2012. Kies and My S2 alerted me the firmware updated successfully.

       

      For almost a full day my S2 worked better than ever then the buttons stopped working completely. It's been two days with the buttons being completely unresponsive. I tried dialing #9900# to do a system dump but that was "unable to process".  It also won't connect to Kies now. I never tried to update it with firmware that wasn't recommended by Samsung Kies.

       

      If I try doing the #9900# to wipe system memory I get a "USSD Code Running..." then an alert pops up saying "Unable to Process Request" same thing happesn with the #1234# check firmware version.
      I also have a "Wi- Error: ER05 "invalid SIM card" error.

       

      Any help would be great. I really don't want to pay $180 insurance claim for a new S2 when they have so malfunctions so frequently. My fiance and I both have the Galaxy S2 and they have both been glitchy since we bought them and continue to get worse. We've put a lot of money into these phones I think T•Mobile and Samsung should at least trade us the glitchy S2 model for the S3.

       

      Thanks for reading hope to find a solution soon (not a $500x2 solution),
      Aaron