5 Replies Latest reply: Nov 20, 2012 12:57 AM by resde RSS

Can't connect SG3 to computer (MTP driver error)

I can't connect my SG3 phone to my Windows 7 64-bit computer with the included USB cable, which means I can't transfer photos, videos, etc. to my computer.  I've done it easily with the Samsung Vibrant in the past - just plug in the USB cable and voila - copy and paste from the phone to computer. 

 

With the SG3, I keep getting a MTP driver error, which prevents my computer from "seeing" my phone as an attached device. 

 

LOTS of people are having the same issue (a quick Google search for MTP driver error shows many online discussions, but no working solutions).  I've tried many different things to fix - including uninstalling drivers, reinstalling drivers, enabling USB debugging mode, factory reset of phone, reinstalling Samsung Kies, etc.   None seem to work.

 

I also tried connecting using Samsung's recommended method (a software that you download on your computer called Samsung Kies (http://www.samsung.com/us/kies/).   Kies is the software for a computer to connect to the SG3 phone, as well as the method to update the software on your phone.  Proper functioning of Samsung Kies is critical to getting the most out of your phone. 

 

So... I can't connect my phone to the computer with the USB...and I also can't connect using the Samsung Kies software!! 

 

Any suggestions would be appreciated!

  • 1. Re: Can't connect SG3 to computer (MTP driver error)
    hidden_dragon

    You can try the PDAnet drivers from June Fabrics.  Honestly, I think you just need to find the right drivers for your connection.

  • 2. Re: Can't connect SG3 to computer (MTP driver error)

    I had the same problem and it was driving me nuts! I downloaded "Android FIle Transfer" from the internet and it works like a charm! 

  • 3. Re: Can't connect SG3 to computer (MTP driver error)

    There currently is no solution (well, none that I found anyways). I've tried everything there is out there.

    http://support.t-mobile.com/thread/28807?tstart=60

  • 4. Re: Can't connect SG3 to computer (MTP driver error)

    I found a solution that worked.  Below was method I used, followed by further explanation.  You may not need to follow these steps exactly, but they're the steps I used. 

     

    1) Plug Samsung Galaxy S3 phone into computer's USB port.  You will get the MTP driver failed to installed message.  

     

    2) Backup SMS / MMS using a backup app (like MyBackup Pro). 

     

    3) Factory reset phone (while still plugged into computer). 

     

    4) Do NOT sign in to your Google Account when phone resets - This is CRITICAL.  You can do it later. 

     

    5) Basically, just get the phone started up again without signing into any accounts (like Dropbox, Samsung account, etc.)

     

    6) MTP driver should have automatically installed on computer - if not, then unplug phone from computer and reconnect. 

     

    7) Sign into your Google Account, and feel free to re-customize your phone at this point.  

     

     

    Explanation and Notes:

     

    1) I factory reset my phone 2x in a row.  The first time, without doing ANYTHING on the phone after factory resetting it except for signing into my Google Account, the MTP driver failed to install.  I believe this happens because signing into my Google Account uses the "backup and restore" functionality of the Google Android account and Google starts automatically downloading saved settings like home screen, Wallpaper, Play Store apps, and other settings.  This interferes with the initial MTP driver installation.  The 2nd time I factory reset (within minutes of the first factory reset), I did NOT sign into Google Account, and voila, the MTP drivers installed.  Only AFTER I was able to connect to the computer did I sign in to Google Account. 

     

    2) Previous to this solution, I had tried every solution I had found online including:

     

    a)  checking / unchecking USB debugging mode

    b)  toggling between MTP mode and Camera mode

    c)  changing some hidden Android settings

    d)  using different USB cables (the one that came with the phone along with others I had)

    e)  uninstalling and reinstalling the Samsung drivers

    f)  uninstalling and reinstalling Samsung Kies

    g)  Device Manager in Microsoft Windows - deleting everything under Universal Serial Bus Controllers so it would reinstall upon Windows restart

    h)  cleaning registry

    i)  trying to connect to different computers (it didn't work) 

     

     

    I had initially thought it was a computer problem, but then realized I was using MTP to connect other devices (like a Sony videocamera).  The problem was with the Google Account automatically downloading various settings to the phone (because of the Backup and Restore functionality) PRIOR to connecting to the computer.   

     

     

    For those of you who have tried everything suggested online to connect to the computer, I hope this solution helps! 

  • 5. Re: Can't connect SG3 to computer (MTP driver error)

    I found this thread on the CNet Forums about MTP device problems:

     

    http://forums.cnet.com/7723-21579_102-252569/a-service-installation-section-in-the-inf-is-invalid/

     

    One of the proposed solutions there was to install this Microsoft driver framework: http://go.microsoft.com/fwlink/?LinkId=71641&/umdf.exe

     

    This solution worked for me (I use Windows XP) and I believe it should work with most devices using MTP.

     

    I should also say that I did have to go to Control Panel > Add Hardware and follow the steps of the Add Hardware wizard to fix the problem completely.