1 2 Previous Next 25 Replies Latest reply: Sep 6, 2013 7:10 PM by fortinw4 Go to original post RSS
  • 15. Re: "Samsung Mobile MTP Device" USB Issue
    theartiszan

    Sounds all to me like there is just something either blocking the connection or there is a bad install somewhere.

     

    I would try the following:

    unplug the phone (do not reconnect till stated)

    uninstall kies on computer

    uninstall drivers on computer ( is a different option in add remove apps)

    reboot computer

    on the phone go to settings > developer options and ensure "USB debugging" is unchecked.

    on the phone also remove any exchange email account to rule out a security policy from that account as they can also cause this problem

    on computer again reinstall kies

    while waiting for kies to install reboot the phone but do no connect it yet

    once kies is reinstalled reboot the PC again.

    once computer is up again start the kies app on PC

    the plug phone in directly to the computer (ie no hub directly into the back of a desktop no front panel or directly to laptop)

     

    That process is what seemed to have worked for me in the past.

  • 16. Re: "Samsung Mobile MTP Device" USB Issue

    I WAS experiencing this same issue

     

    What DIDN'T work for me: toggling USB debugging, no sim or sd card when connecting, factory reset and connect before signing in, safe mode, 32 bit system, virtual xp mode, downloading drivers from samsung, downloading drivers from windows update catalog.

     

    I fixed this by removing the Upperfilters setting in the following registry key (ALWAYS MAKE A BACKUP OF THE REGISTRY BEFORE MAKING CHANGES):

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro  l\Class\{EEC5AD98-8080-425F-922A-DABF3DE3F69A}

     

    “Upperfilters” = klfltdrv

     

    This key is related to Kaspersky AV USB filters (I think )

     

    After I removed this key and plugged in my phone, it no longer showed MTP usb device failed, but rather SGH-T999 successful!

  • 17. Re: "Samsung Mobile MTP Device" USB Issue

    Reading all these messages about MTP Device issue and figuring nothing is going to be done.

     

    Surely T-mobile should of contacted Samsung about the issue and at least provide a fix on the T-mobile website for its customers; instead they expect its customer to solve the impossible through support forum boards - go round the houses trying to figure out what to do. Customers agree to buy service contract, and expect the nooks and crannies to sorted, isn't that what we pay phone insurance for, and monthly phone contracts, allowing the customer to be covered under the agreement

     

    Feeling bit short change ... Samsung Kies was a nightmare to activate on the Galaxy S and huge effort all 90mb app download onto Windows 7.

     

    Honestly say, I never ever had a USB compatibility issue when I was an Orange customer, they really had a professional serivce when it came to synching data, installation of third-party peripherals, upgrading firmware. It seems everything worked fine for both companies right up until the acquisition and now service levels set to bare minimum, and everything went down hill.

  • 18. Re: "Samsung Mobile MTP Device" USB Issue

    this is from nacos on xda-developers.com

     

    1. Uninstall any previous instance of Kies/USB driver

    2. Download the latest Kies, specific to your S3.

    3. Download Samsung USB drivers 1.4.6.0 (I've tried newer versions but they all failed)

    4. REBOOT

    5. Disconnect from internet (VERY IMPORTANT!!! - forcing Windows to install local drivers ONLY)

    6. With the phone disconnected, install Kies + USB drivers downloaded in steps 2,3

    7. Connect the phone and let Windows install the drivers.

    8. Reestablish the internet connection.

  • 19. Re: "Samsung Mobile MTP Device" USB Issue

    Support suggested a much simpler solution, which apparently worked for me:

     

    0. Disconnect phone

    1. Uninstall Samsung Kies

    2. Uninstall Samsung USB Driver for Mobile Phones

    3. Download old version of Samsun Kies 2.3.3.12085_7_5 from http://www.samsungapps.com

    4. Find downloaded file in Downloads and start it with right click -> Run as Administrator

    5. After installation - connect phone and wait until Windows installs drivers

    6. You should be good to go

     

    Perhaps this link will work for you:

    http://www.samsungapps.com/earth/supportMain/getSupportMainList.as

     

    There should should find a tiny button "Kies herunterladen" (Download Kies) under "Uber Kies" (About Kies). Probably this page is localized and will be shown in your own language. Old version of Kies also includes old version of the driver, which does work.

  • 20. Re: "Samsung Mobile MTP Device" USB Issue

    retrodivot - since it worked once based on the solution I had suggested, but stopped working after you signed into your Google Account on your phone, it appears the issue is caused upon signing into your Google Account.  Here's what I had mentioned in my previous post: 

     

    1) I factory reset my phone 2x in a row.  The first time, without doing ANYTHING on the phone after factory resetting it except for signing into my Google Account, the MTP driver failed to install.  I believe this happens because signing into my Google Account uses the "backup and restore" functionality of the Google Android account and Google starts automatically downloading saved settings like home screen, Wallpaper, Play Store apps, and other settings.  This interferes with the initial MTP driver installation.  The 2nd time I factory reset (within minutes of the first factory reset), I did NOT sign into Google Account, and voila, the MTP drivers installed.  Only AFTER I was able to connect to the computer did I sign in to Google Account.

     

    2) I had initially thought it was a computer problem, but then realized I was using MTP to connect other devices (like a Sony videocamera).  The problem was with the Google Account automatically downloading various settings to the phone (because of the Backup and Restore functionality) PRIOR to connecting to the computer.  

     

     

    If none of the other solutions suggested by other people in the support community have helped, I can think of 1 more possible solution. 

     

     

    1) Under Phone -->Settings --> Backup and Reset, UNcheck the "Back up my data" and "Automatic Restore" options (this should delete all backed up info on Google's servers like phone's home screen, wallpaper settings, etc.).  Don't worry, it doesn't delete any previously purchased apps.  Restart your phone just to make sure all the backed up stuff is deleted from Google's servers.

     

     

    2) After waiting for a while to make sure the backed up info is deleted from Google's servers, re-do all the steps I had listed in my previous post (the steps that you said worked only one time to let your computer recognize the phone before you had signed into your Google Account again).  Here's the link for those steps  http://support.t-mobile.com/message/171421#171421 

     

     

    3) since previously backed up info has now been deleted from Google's servers, when you sign back into your Google account, it shouldn't download any previously saved info (like home screen, wallpapers, etc.) - you'll have to customize this again. 

     

     

    I know it's a huge time sink and should be fixed - but I don't think the problem is with Samsung OR Google alone - my guess is that when you change from one Android phone to another AND you have previously backed up information to Google's servers (i.e. via the phone's Backup and Reset setting), there's some "OLD" information that's downloaded to your new phone that causes incompatibility and prevents connecting to the computer. 

     

     

    Hope this works!

  • 21. Re: "Samsung Mobile MTP Device" USB Issue

    Great information, thank you! I downloaded the USB driver from the Samsung suppport website and reinstalled it. This solution acutally worked for me without having to reset the phone.

  • 22. Re: "Samsung Mobile MTP Device" USB Issue
    animaleyezz

    I'm glad you got your phone working but consider also purchasing new or newer micro USB cables.  I have 4 that over time have worn out.  I use to take it between my car, work and home.  This can wear them down not for charging but for transferring data.  So now I use the older cables just in the car for charging and I have 3 new ones in my office, bedroom and connected to my laptop.

  • 23. Re: "Samsung Mobile MTP Device" USB Issue

    I found this thread on the CNet Forums about MTP device problems:

     

    http://forums.cnet.com/7723-21579_102-252569/a-service-installation-section-in-the-inf-is-invalid/

     

    One of the proposed solutions there was to install this Microsoft driver framework: http://go.microsoft.com/fwlink/?LinkId=71641&/umdf.exe

     

    This solution worked for me (I use Windows XP) and I believe it should work with most devices using MTP.

     

    I should also say that I did have to go to Control Panel > Add Hardware and follow the steps of the Add Hardware wizard to fix the problem completely.

  • 24. Re: "Samsung Mobile MTP Device" USB Issue

    Just writing to note that the 4.1.1 Anroid update fixed the issue. Up until then, nothing of note really worked for m, but thanks guys for all the suggestions. I'm glad it is finally fixed and also if any of the input helped others, I'm glad.

     

    Thanks again.

  • 25. Re: "Samsung Mobile MTP Device" USB Issue
    fortinw4

    MTP Device Failure on Galaxy S3 - Solved!



    Symptoms:

    () The Galaxy S3 is most likely listed in device manager under Portable Devices as
    "MTP Device".

    () This hardware failure is a common issue with the Galaxy S3 in Windows 7 x64.

    () It probably has a yellow ! (bang) next to it.


    Steps to fix:

    I. Right click on My Computer.

    II. Left click on Properties

    III. On the left side of the System Properties window, click on Device Manager.

    IV. Under "Portable Devices", Double click on the "MTP Device" with the yellow bang.

    V. Click the Driver tab at the top of the window.

    VI. Click the "Update Driver" button.

    VII. Click "Browse my computer for driver software".

    VIII. Click "Let me pick from a list of device drivers on my computer".

    IX. Make sure you double-click the SECOND "MTP Device" in the list (the first one is the one that is failing).

    X. It should say "Installing device driver software" and "Windows has successfully updated your driver software".


    <> Now "MTP Device" should no longer have a yellow bang or error and your Samsung Galaxy S3 should pop up in a window asking you what you want to do with the device.

    <> It will also be listed under "My Computer" as a portable device.

    <> Enjoy using your Galaxy S3 as a portable device!

1 2 Previous Next