1 2 Previous Next 25 Replies Latest reply: Sep 6, 2013 7:10 PM by fortinw4 RSS

    "Samsung Mobile MTP Device" USB Issue

      I have a major issue with my SGH-T999. I cannot get the phone to connect with my Windows 7 desktop computer via the micro usb to usb cable. I have the latest version of Windows 7.

      1. I downloaded and re-downloaded Kies which doesn't work. It will recognize the phone after a very long time, but once I move to do something in the program, it begins again to try and re-recognize the phone again.
      2. I tried Kies Air which doesn't work.
      3. I removed the driver several times and let the computer try to reinstall the driver on it's own.
      4. I wiped my SDcard because when I googled the issue there was something about files containing titles longer than 16 digits/letters.
      5. I've even downloaded the USB driver directly from Samsung and tried that: http://www.samsung.com/us/support/owners/product/SGH-T999RWATMB


      What occurs when I hook up the phone to my computer is that it installs three things:


      • SAMSUNG Mobile USB Composite Device (Install Successful)
      • SAMSUNG Mobile MTP Device (Install Failed)
      • SAMSUNG Mobile USB Modem (Install Successful)


      The phone then throws up a "Attention" pop-up:


      "Unable to find software on your PC that can recognize your device. Service pac 3, Windows Media Player, version 10 or higher, must be installed for Windows XP.


      You can downlaod and install PC Kies from http://www.samsing.com/kies in order to sync data with your device, backup data, and upgrade your decice (Windows and Mac OS are supported)."


      I'm currently at my wit's end. I just emailed Samsung, but can anyone help?

        • 1. Re: "Samsung Mobile MTP Device" USB Issue

          good luck with getting it to work.  i tried this on my 32bit and 64bit windows 7 machine.  no dice.

          • 2. Re: "Samsung Mobile MTP Device" USB Issue

            I even tried to connect it on my XP S3 at work and it does not connect. Just keeps cylcling that it found a new "MTP Device." It only "works" when I go select PTP (under the "USB PC connection", but that does no help since it won't transfer any of the files for the camera anyway).


            This has got to be a huge oversight! I can't believe I'm only one of a few.

            • 3. Re: "Samsung Mobile MTP Device" USB Issue

              I did everything you posted and I couldn't get it to work.  I read somewhere that you can use Kies Air to transfer files wirelessly, but I didn't feel like mucking around with my Windows firewall settings and enabling a bunch of stuff.


              I ended up copying files from my Vibrant phone to my computer's hard drive then to DropBox to my SGS3.  It was a long and tedious process, but it was a workaround that didn't require me to make any changes to my computer.

              • 4. Re: "Samsung Mobile MTP Device" USB Issue

                Man, that's junk. You and I are in the same boat (Vibrant to T999). Well, I guess that'll have to do for now.


                I'm still waiting on what Samsung has to say and I did see something on Microsoft's website that I wanted to try. I'll report how it goes later on. From the more I read though, it seems like a updated driver issue that will have to come from Samsung.

                • 5. Re: "Samsung Mobile MTP Device" USB Issue

                  This is what you need:




                  Go to the Manuals & Download and then the Software tab.  Download it and install.  It will take a ridiculously long time to run and install but it works on my Vista 64 bit Laptop.


                  Also, as an aside, ICS is why it doesn't act exactly like Gingerbread does with regards to file transfers/SD Card access, not TMOs or Samsung's fault.  It is frustrating, but you can get this to work.

                  • 6. Re: "Samsung Mobile MTP Device" USB Issue

                    Yeah, I tried that (Well, the link I posted above is from the "white" version of the T999). No go.

                    • 7. Re: "Samsung Mobile MTP Device" USB Issue

                      I have the Samsung Galaxy Nexus running direct from Google ICS 4.0.4  and Windows searched for drivers and installed them and then placed a Portable Media Player on my system.  I'm Windows 7 64 bit as a VM. 


                      I tried to post a pic of Device Manager but it won't let me.  It shows up under Portable Devices, Galaxy Nexus and the driver provider is SAMSUNG Electronics Co. Ltd, Driver Date 11 May 2012, Driver version 2.9.319.511


                      Driver files loaded








                      It seems the SGS3 should work in a similar fashion. 



                      • 8. Re: "Samsung Mobile MTP Device" USB Issue

                        Just as a follow up. Nothing works. Still waiting for Samsung to issue a driver that actually works.

                        • 9. Re: "Samsung Mobile MTP Device" USB Issue

                          OMG this is driving me nuts has anyone talked with Samsung yet

                          • 10. Re: "Samsung Mobile MTP Device" USB Issue

                            A proposed solution IF YOU ROOT YOUR PHONE: http://www.techsliver.com/enable-usb-mass-storage-mode-on-your-samsung-galaxy-s-iii-how-to/


                            " A major issue with MTP is also that it is not natively compatible with all operating systems. "




                            I'm going to try the wifi work around with air droid


                            I'm also slightly unclear what exactly MTP does? Does it allow us to use the memory card without having to "mount" the sd cards like previous versions of andriod made us do? I noticed this the first time I tried. There is no mouting usb button.


                            Then my major question is, "What happens when they issue an Android OS update? How am I supposed to get that?!"

                            • 11. Re: "Samsung Mobile MTP Device" USB Issue

                              cross-posted in http://support.t-mobile.com/message/163626



                              I found a solution that worked.  Below was the method I used, followed by further explanation.  You may not need to follow these steps exactly, but they're the steps I used. 


                              1) Plug Samsung Galaxy S3 phone into computer's USB port.  You will get the MTP driver failed to installed message.  


                              2) Backup SMS / MMS using a backup app (like MyBackup Pro). 


                              3) Factory reset phone (while still plugged into computer). 


                              4) Do NOT sign in to your Google Account when phone resets - This is CRITICAL.  You can do it later. 


                              5) Basically, just get the phone started up again without signing into any accounts (like Dropbox, Samsung account, etc.)


                              6) MTP driver should have automatically installed on computer - if not, then unplug phone from computer and reconnect. 


                              7) Sign into your Google Account, and feel free to re-customize your phone at this point.  



                              Explanation and Notes:


                              1) I factory reset my phone 2x in a row.  The first time, without doing ANYTHING on the phone after factory resetting it except for signing into my Google Account, the MTP driver failed to install.  I believe this happens because signing into my Google Account uses the "backup and restore" functionality of the Google Android account and Google starts automatically downloading saved settings like home screen, Wallpaper, Play Store apps, and other settings.  This interferes with the initial MTP driver installation.  The 2nd time I factory reset (within minutes of the first factory reset), I did NOT sign into Google Account, and voila, the MTP drivers installed.  Only AFTER I was able to connect to the computer did I sign in to Google Account. 


                              2) Previous to this solution, I had tried every solution I had found online including:


                              a)  checking / unchecking USB debugging mode

                              b)  toggling between MTP mode and Camera mode

                              c)  changing some hidden Android settings

                              d)  using different USB cables (the one that came with the phone along with others I had)

                              e)  uninstalling and reinstalling the Samsung drivers

                              f)  uninstalling and reinstalling Samsung Kies

                              g)  Device Manager in Microsoft Windows - deleting everything under Universal Serial Bus Controllers so it would reinstall upon Windows restart

                              h)  cleaning registry

                              i)  trying to connect to different computers (it didn't work) 



                              I had initially thought it was a computer problem, but then realized I was using MTP to connect other devices (like a Sony videocamera).  The problem was with the Google Account automatically downloading various settings to the phone (because of the Backup and Restore functionality) PRIOR to connecting to the computer.   



                              For those of you who have tried everything suggested online to connect to the computer, I hope this solution helps! 

                              • 12. Re: "Samsung Mobile MTP Device" USB Issue

                                i dont know if this will work for anyone else, but it worked for me. i just went to settings and scrolled down to developers options. at the very top the USB debugging should be checked. uncheck it, unplug the replug your phone back in. it worked on my computer

                                • 13. Re: "Samsung Mobile MTP Device" USB Issue

                                  I tried this and it worked only one time. Essentially, It worked when I completed what you said to do above and the drives even appeared, but then I signed into Google and now it seems nothing happens. When I say nothing, it doesn't even prompt for the downloading of the MTP drivers and the drives don't appear. I tried plugging it into Kies and that does not work.


                                  The ONLY thing that works, is the mobile version of Kies where I access it via the browser.


                                  This is a major nuisance and I have to say that I would not recommend to someone to purchase getting a Galaxy S III. If all one did was use it as a phone, then I say you can get it. Then again if that is all you did another phone would be more economical.

                                  • 14. Re: "Samsung Mobile MTP Device" USB Issue

                                    Sory, that was one of the many things I tried, but I forgot to add it to the list. That doesn not work either. Thanks.

                                    1 2 Previous Next