3 Replies Latest reply: May 24, 2012 11:01 AM by jrosen1987 RSS

    WIFI Calling drops when not on charger...

      So I'm having some issues with WIFI calling on my Galaxy S 4G.

       

      I have two phones from Tmobile:

       

      Phone #1: Galaxy S 4G - Android Gingerbread 2.3.6

      Phone #2: LG G2X - Android Gingerbread 2.3.3

       

      Now on the G2X, wifi calling works flawlessly, never drops calls or anything.

       

      On the Galaxy S, It will connect to the wifi calling fine, but will lose wifi calling once the screen has timed out for a couple of minutes.

       

      I have found that if it is plugged into the power adapter, it will not drop the wifi calling. Hmmm...

       

      It worked fine for a couple of months and recently stopped working.

       

      Already set the wifi sleep policy to "Never", this did nothing.

       

      Should I try and reflash to an older rom (Froyo) or something?

       

       

      HELP TFORCE!!!

        • 1. Re: WIFI Calling drops when not on charger...

          I am having the same problem. Interesting observation around the power supply causing the problem. I'll check that out on mine.

          • 2. Re: WIFI Calling drops when not on charger...
            tmo_keith_m

            Thanks for the post, T-Force would be more than happy to assist (apologize we missed you the first time), I'm glad you checked the wifi sleep policy because that is the first thing that came to mind.  We can safely say that if the G2X doesn't have the issue then your ISP and your router are in good shape, so the next steps I would try are wiping the cache partition.

            http://support.t-mobile.com/docs/DOC-3295

            Past that you would want to try a master reset on the device

            http://support.t-mobile.com/docs/DOC-2405

            Going back to froyo would require rooting the device so I cannot recommend that however please try these two things and let us know.

             

            Thanks,

            • 3. Re: WIFI Calling drops when not on charger...

              Ok, I think I found out what is causing this problem.

               

              WIFI calling works perfectly (over two months without an issue), when only ONE device is using the service on the network.

               

              Within 15 seconds of activating WIFI calling on another device, the first device drops the connection to the secure servers.

               

              Activate it again on the first device, and the second one drops the connection to the WIFI calling servers.

               

              I have tried this multiple times... Always the same result.

               

              So, only one device can utilize WIFI calling at one time.

               

              I have used port forwarding, DMZ, and port triggering methods, to attempt a fix... Still the same issue.

               

              This leads me to this conclusion:

               

              This might be an issue between the NAT traversal mechanism and the TMobile servers. I bet that if both phones had public IP's instead of NATing from one single public IP, it would work perfectly.

               

              It would seem that only ONE device can be authorized on the network at any given time.

               

              I notice that WIFI calling uses ports 4500/500. So it's using IPSEc.

              Port 4500 is being used for NAT traversal, and port 500 for IKE.

               

              NAT might be causing an issue with any authentication IPSec is using, or the WIFI calling app is not utilizing any ephemeral port for communication...

               

              How to fix this issue?

               

              WIFI calling works on both devices if they are both on seperate networks.

               

              The only thing I can think of is to get a couple of static IP's from your ISP ($15 per month for 8 IP's from AT&T, not sure with other ISP's).

               

              I hope this helps everybody out...

               

               

              RFC:IPSEC NAT TRAVERSAL

              http://tools.ietf.org/html/rfc3947#section-8