9 Replies Latest reply: Jun 17, 2013 5:33 AM by smplyunprdctble RSS

    How Do I_Set SMS only -not-MMS?

        Both my wife and I have the Samsung Galaxy S2 phone w/ T-Mobile running stock v2.3.6.

       

      Typically when I respond to her SMS, my outgoing message is translated to MMS -and- it fails as rejected.

       

      If I manually initiate a SMS text event, the text will generally go through as SMS and succeed.  If she responds and I reply to her response, we're back to the reject cycle and I must re-init a text converstation.

       

      I'd like to set SMS_ONLY some how if that's possible.  Though successful MMS would help as well.

       

      --thanks for your time and efforts in advance.

       

      --Micke

        • 1. Re: How Do I_Set SMS only -not-MMS?

          Try a third-party SMS app like Handcent SMS and see if it works better.

          • 2. Re: How Do I_Set SMS only -not-MMS?
            tmo_alicia_b

            Hi grepzen,

                 Generally SMS that only include text don't automatically turn into an MMS unless it is over 160 characters. Are these long messages you are sending?

            • 3. Re: How Do I_Set SMS only -not-MMS?
              smplyunprdctble

              Make sure the phone number you're sending to [inside the contact] is in the following format:

                 +14045551212

               

              Make sure there's a +1 -- and all ten digits -- and no spaces or hyphens [you may need to edit via the web to do this]

               

              MMS has problems sending on the SII if there's any spaces in the phone number.  Much to my shagrin because I've prided myself for the past many years of having all my contacts stored as 404 555 1212 -- which means I've needed to go through contact cleanup.

              • 4. Re: How Do I_Set SMS only -not-MMS?

                All:

                 

                I've tried:

                <> Setting stored phonenumber to format(+18005551212)  ;; Did not solve

                <> Installing using 3rd party SMS client (Handsent) :: Did not solve

                    Hansent doesn't indicate which method was used to send the text-replies.  My wife saw none of them.

                <> Ensuring my responses were < 140 characters (they most often are):: Did not solve.

                 

                I do appreciate all of your time/effort/tips

                • 5. Re: How Do I_Set SMS only -not-MMS?

                       Since you have already tried all the above methods to fix this, we would need to take troubleshooting a step further.  The SMS/MMS error isn't present when the device is using it's original factory settings, so like a computer, we would need to uninstall (and make sure not to just re-install the offending program/application/setting)  Please view the enclosed links to backup and then reset your device.  Please also make sure that you UNcheck the "Backup my data" and "Automatic Restore" options (one is dependent upon the other) to ensure the problem gets erased without losing anything from your SIM card, SD card or Gmail account.  After, when re-installing applications/settings, make sure to use caution and add apps one-by-one to better locate a bad application in the future.

                   

                  I hope this helps.

                   

                   

                  mike_s

                  T-Force

                  • 6. Re: How Do I_Set SMS only -not-MMS?

                      'lo Mike,

                     

                      The error is, in fact,present when using the factory default SMS client.  --which cannot be un- and re-installed.

                     

                    -- I'm hoping that the ICS udpate/upgrade will shed some positive light on this matter.  So I'm trying to patienly wait for it to come to my T-Mo-S2

                    • 7. Re: How Do I_Set SMS only -not-MMS?
                      smplyunprdctble

                      Factory reset then?

                       

                      Don't install any apps and see if it works without apps installed.  If it does, then it's an app causing the problem.

                      • 8. Re: How Do I_Set SMS only -not-MMS?

                        Hi grepzen,

                         

                        I don't know if this has been fixed as it is a couple of weeks now. I had the same issue and this is how I resolved it.

                         

                        1. Got to message settings.

                        2. Tap/click on input mode

                        3. Change to Unicode

                        4. You should be good to go.

                        • 9. Re: How Do I_Set SMS only -not-MMS?
                          smplyunprdctble

                          louisfelix wrote:

                           

                          I don't know if this has been fixed as it is a couple of weeks now. I had the same issue and this is how I resolved it.

                          ...or a year

                           

                          But, great info to pass along!  Thanks!