7 Replies Latest reply: Jun 29, 2012 4:11 PM by rgonzalez85 RSS

    Inbound MMS Not Working, Changes to Hidden Sender Address Anonymous

      I have an issue on my Samsung Galaxy S II with inbound MMS Messages from various networks, not limited to only form one specific network.  What happens if you are actually watching the message as it comes in is John Doe will show the MMS (picture in my case) and for a brief second you can see it, then all of a sudden it dissapears from the message and a new "conversation" from Anonymous that says "Hidden Sender address" shows up and plays this blank video message that is all black and only a couple of seconds.   This is happenign on 100% of my inbound MMS messeges.  I think its happening to a few people. Not sure what T-Mobile support recommends we do about it.

       

       

      I found something about it on the android google page here (Towards the last few posts it gets clearer) : http://code.google.com/p/android/issues/detail?id=14512

       

      On an unrelated issue, when sending an MMS, I have to manually disable wifi so it will send out, otherwise it will not use the data network to send out the MMS, but more importantly is being able to receive messages that I am worried about, its quite annoying.

        • 1. Re: Inbound MMS Not Working, Changes to Hidden Sender Address Anonymous

          MMS=Picture messages require that you have your data enabled through your settings and be on the network.  SMS messages only require that you be on the network.  SMS messages with a MMS attached to it require that your data be enabled and that you be on the network.

           

          As far as incomming messages changing to "Hidden Sender Address", call T-Mobile and make sure you have your data plan setup properly.

           

          Also, go into settings>about phone>status and make sure your phone number is appearing.  If not, that is the problem. T-Mobile can resolve that for you.

          • 2. Re: Inbound MMS Not Working, Changes to Hidden Sender Address Anonymous

            I have been having this same issue. After it briefly pops up in the correct message thread, it disappears and shows up under Anonymous. The message continues to push itself to the phone about 10 different times with nothing on it.  Talk about annoying!

            Baracuda- I have the correct plan and my phone number is on my phone.

             

            Someone, anyone, please help!

            • 3. Re: Inbound MMS Not Working, Changes to Hidden Sender Address Anonymous

              Ok, This is obviously a recurring theme that needs to be looked at officially by T-Mobile/Samsung/Android but here goes somethign that somehow fixed it, not sure exactly what it may be but now its working fine for me:

               

              I will list everything I did, though not sure exactly where it got fixed. I have Chompsms for my messages, so what I did was I turned auto retrieve MMS off on both messaging app as well as chomp, before that I did clear data on Settings-Applications-All-Messaging, then  I went into messaging app and deleted all conversations(Threads) so it was basically empty, i kept test sending myself an MMS until it stopped doing it throughout the process.   Yes it was super annoying receiving them 10+ times, something definitely wrong.

               

              Barracuda - BTW yes, of course I have the right plan, and of course my number is set.  Basically to make it easy if I were to put sim in my MyTouch4G then I can send/receive MMS just fine.   I seem to have fixed the issue, not sure what part of it fixed it, but it seems to be a common problem with new GS2 owners.  Hopefully the things I did can be replicated and fix it for others.  The downside is I lost all of my conversation threads, but I got to the point I did not care since it was so dang annoying.

               

              Message was edited by: manolodf

              • 4. Re: Inbound MMS Not Working, Changes to Hidden Sender Address Anonymous

                Hmmm... I use ChompSMS too but never had this issue on any of my other android phones. Not sure how that would impact it, but I wonder if it is?

                I am going to try what you did and see if that works on my phone. Did you turn 'auto-retrieve' back after you got it sorted out?

                • 5. Re: Inbound MMS Not Working, Changes to Hidden Sender Address Anonymous

                  Honestly at the end of my rampage I think maybe turning the auto-retrieve off within Chomp only may have been the solution.  Before you wipe threads or clear data do this:

                   

                  Turn off the auto-retrieve within the chomp mms settings, send yourself an MMS and see if it fixed it.  If not then go into stock messaging and also turn it off in there, if still not fixed then go ahead and do the full one like I did.

                   

                  I have a feeling its something with auto-retrieve.

                  • 6. Re: Inbound MMS Not Working, Changes to Hidden Sender Address Anonymous

                    I tried turning off auto-retrieve in the stock messaging and leaving Chomp on, that didnt work.

                    I turned it off within Chomp and left the stock one on, and it worked. The MMS auto-retrieved within Chomp and I didnt get any silly anonomous messages. Thank god. That ish was about to drive me bananas! Thanks for your help. Hopefully it solved your issue too.

                    • 7. Re: Inbound MMS Not Working, Changes to Hidden Sender Address Anonymous

                      Hello there,

                      I was having the same issue on my Galaxy Blaze 4G, I found the problem on my case I use chompSMS app for messaging and after I turn off the Auto-retrieve on the actual app the problem was solved. Just leave the build in message app to take care of the Auto-retrieve.