1 2 3 Previous Next 33 Replies Latest reply: Aug 15, 2013 5:33 PM by prometheanburden Branched to a new discussion. RSS

Bill Pay Website Hasn't Worked in Months

There is another discussion going on in here on this same topic but, it's marked answered and everyone agrees it is NOT the correct answer.

http://support.t-mobile.com/thread/12780?tstart=0

 

So we'll try this again.

They page found at https://my.t-mobile.com/Billing/OneTimePaySignUp.aspx does not work for many of us.

Once on the page you are meet with a spinning circle of dots and the waiting never goes away. So basically we can NOT pay our bill simply and convenently through the standard method provided to us by T-Mobile.

 

It's worked for me and others in the past, that it goes back to the aforementioned spinning dots.

 

T-Mobile, we all need this fixed ASAP. Please get someone to look over this page. there are errors throughout it. Anyone with basic knowledge in web design can pick this page apart. Cut out the bells and whistles and please just let us pay our bills, that's what you want isn't it?

  • 1. Re: Bill Pay Website Hasn't Worked in Months

    For those looking for a quick way to pay your bill this URL has been found to work for the time being.

    https://my.t-mobile.com/Pda/

  • 2. Re: Bill Pay Website Hasn't Worked in Months
    kk13

    I finally got a Tech at T-Mo that had an answer and it is really simple. I hope it works for you also. Before you go to view your bill, you need to go to your phone's browser settings (web, phone's menu soft key, settings,) go to block pop-ups, select "not block pop-ups" automatically. That's it. Turn it back on when your done with T-Mo page. Whoever is or was there web designer made the different sections of a displayed page are actually individual pop-ups. Lame huh?  Kinda an inconvenience but, simple enough to rectify. Hopefully they can do something to change it permanently.

  • 3. Re: Bill Pay Website Hasn't Worked in Months

    I tried this in Windows 7.  Disabling pop-ups makes no difference in IE9.  There is still a "spinning wheel."   And yes it is most inconvenient and stupid and lame however one slices it!

  • 4. Re: Bill Pay Website Hasn't Worked in Months

    Hello all,

     

    Sorry to hear you guys are having trouble with our website.

     

    Here's a couple tips and suggestions. For anyone having this issue, please run through this checklist (or confirm the steps if you've already completed them) and post back here with the results and we'll help you guys out.

     

    1) This is occuring on Windows 7 machines only, is this accurate according to your experience?

     

    2) Do other browsers work? If so, which ones. If not, which ones and what error do you get?

     

    3) Does clearing your cache make any difference?

     

    4) Has your account been suspended or otherwise interrupted in the last 72 hours?

     

    ^CG

  • 5. Re: Bill Pay Website Hasn't Worked in Months
    philyew

    I've paid this way using Google Chrome on a Windows 7 machine for at least the last 5 months without problems.

  • 6. Re: Bill Pay Website Hasn't Worked in Months

    @tmo_chris

     

    Yes, Windows 7 here

    No same issue on IE9 and Chrome 18 or 19 beta

    No, cache never fixes it

    No, Acct has not had any issues in any time frame.

     

    tmo_jessicab has also already contacted me and i've provided screen shots and shes reported that she has opened a ticket on the issue

  • 7. Re: Bill Pay Website Hasn't Worked in Months

    @kk13

     

    I tried what you suggested but, it did not work. Theres still "something" covering the whole section along with the spinning dots

  • 8. Re: Bill Pay Website Hasn't Worked in Months

    mbush78 ok in that case, thank you very much for taking the time to let us know. I'm sure Jessica will take good care of you.

     

    For anyone else, feel free to respond here if you have this issue and need assistance.

     

    ^CG

  • 9. Re: Bill Pay Website Hasn't Worked in Months

    1) This is occuring on Windows 7 machines only, is this accurate according to your experience?  

     

      I don't have any other OS available to me to verify.  I have tried both Win 7 32 bit and 64 bit machines.

     

    2) Do other browsers work? If so, which ones. If not, which ones and what error do you get?

     

         FireFox and IE9 do not work for me as of today.  Spinning ball on IE9 and something like:  "sorry website not available try later"  on Firefox.  Chrome now works.  It did not work the last time that I tried it -- I think that was in January.  There are no error messages anywhere -- ever.

     

    3) Does clearing your cache make any difference?

     

      I tried it on FireFox and it made no difference.

     

    4) Has your account been suspended or otherwise interrupted in the last 72 hours?

     

       No

     

    I also have provided screen shots of IE9 and did so in January.

  • 10. Re: Bill Pay Website Hasn't Worked in Months

    I've been using Windows 7 since the WIndows 7 RC version came out in the spring of 2009.

    Everything was fine until I upgraded to IE9 from IE8 last summer 2011.

     

    I can only log on and pay the bill.

     

    If I try to do anything else like view my Bill or look at the Payment History or see my Account Usage it kicks me out and puts me back to the log on screen.

     

    I had called T-mobile support and they said to either downgrade back to IE8 or get another web browser.

     

    It's been almost a year now and T-mobile still hasn't made their website compatible with IE9.

    I can go to any other website and pay bills/view history w/o a problem.

     

    When I log on I see this message: 

    We see you're using an older browser. For a better experience, we suggest upgrading to

    a newer version

     

    If I click on compatible mode the message goes away but the site still logs me off if I try to do any of the above mentioned things.

     

    They need to hire someone else to manage their website

  • 11. Re: Bill Pay Website Hasn't Worked in Months
    tmo_jessicab

    Hello spl323,

     

    It is definitely frustrating when websites don't work properly. I'll need to file a ticket to get this fixed for you. I'm sending you a private message to get more information. Take a look when you've got a moment.

  • 12. Re: Bill Pay Website Hasn't Worked in Months

    Here's a couple tips and suggestions. For anyone having this issue, please run through this checklist (or confirm the steps if you've already completed them) and post back here with the results and we'll help you guys out.

     

    1) This is occuring on Windows 7 machines only, is this accurate according to your experience?

     

    I just tried it on a tablet running Android ICE using the Dolphin HD browser -- the same spinning wheel. 

     

    2) Do other browsers work? If so, which ones. If not, which ones and what error do you get?

     

    No error message -- just the annoying perpetually spinning wheel.

     

    3) Does clearing your cache make any difference?

     

    No.

     

    4) Has your account been suspended or otherwise interrupted in the last 72 hours?

    No

  • 13. Re: Bill Pay Website Hasn't Worked in Months
    kk13

    Sorry to take so long to get back at you, mbush78, when I posted originally, with my version of the blocked page, I was not thinking about every body on this site, meaning PC users, and other phone OSs, I'm stuck in Android mode mostly these days. But, the un-block pop-ups worked on both my phones to clear up that blocked out, still loading, spinning dots b***sh*t, page. I now see that it isn't just a phone issue, but T-Mo has a big problem that they don't want to, or don't know how to address it and we all have to deal with one more bug, in the list of T-Mobile's bad quality control and business accountability.   .  I wish I had an answer for everybody, not just the Android users, but I'm just an electrician, not a magician, LOL.

     

    Sent this message using my Samsung Galaxy SII 4G T-989 Hercules or my Samsung Galaxy S Captivate

  • 14. Re: Bill Pay Website Hasn't Worked in Months

    Just what I expected to see today when I went to pay my bill...... spinning dots 

     

     

1 2 3 Previous Next