'Error' when attempting to turn on Wi-Fi or Wi-Fi hotspot: Android

Understanding the Issue

Symptoms

 

  • Error: ‘Error’ in Wi-Fi Settings when turning on
  • Wi-Fi or Wi-Fi hotspot fails to connect

 

Devices affected

 

  • HTC Sensation
  • LG Optimus T
  • Samsung Dart T499
  • T-mobile Comet
  • T-Mobile G2
  • T-Mobile G2x
  • T-Mobile myTouch 3G
  • T-Mobile myTouch 3G Slide
  • T-Mobile myTouch 4G
  • T-Mobile myTouch 4G Slide

 

Possible causes


  • Too far from Wi-Fi router
  • Too close to Wi-Fi router
  • 2.4 GHz wireless interference
  • Wi-Fi router issues (unsupported)

 

When attempting to turn on WiFi or a WiFi hotspot, the word ‘Error’ appears in the Wi-Fi Settings.

 

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Resolution Steps

  1. Check the software version of the device. If it is not up to date, then update it.
  2. Turn the phone off, and turn it back on.
    Note: Doing this multiple times sometimes help to resolve the problem.
  3. Attempt to turn on Wi-Fi.
  4. If Wi-Fi still cannot turn on after turning the phone off and on a few times, then remove the battery.
  5. Re-insert the battery. (Do not turn the phone on yet. The next step will do that.)
  6. Wipe the cache partition.
    Note: See how to The specified item was not found., or see documents for your device for specific steps.
  7. Turn on the device.
  8. Turn on airplane mode for one minute.
  9. Turn off airplane mode.
  10. Attempt to turn on Wi-Fi.
  11. If W-Fi still cannot turn on, then forget all Wi-Fi networks:
    1. From the Home screen, press the Menu key.
    2. Touch Settings.
    3. Touch Wireless & networks.
    4. Touch Wi-Fi settings.
    5. Under the Wi-Fi networks header, touch and hold each network listed.
      Note: If no networks appear, touch Wi-Fi at the top of the screen to see if any networks appear.
    6. Touch Forget network to forget it.
    7. Repeat until all networks are forgotten.
  12. Turn off Wi-Fi if it is on.
  13. Turn on Wi-Fi.
  14. If W-Fi still cannot turn on, perform a master reset.
    Note: See documents for your device for specific steps.
  15. Turn on Wi-Fi with no third-party apps installed.
  16. If the issue continues after all steps above and with no third-party apps installed, then you may have a problem that:

    • We are tracking the reported problem currently.

    • Until we determine what causes the problem, there is not any more resolution. But your feedback will help us determine the problem.

    • The issue is being reported on all recent Android models from all carriers (including Verizon and Sprint), and is not specific to your device nor T-Mobile.

    • If you are comfortable using a development fix that is not supported by T-Mobile, see: http://forum.xda-developers.com/showthread.php?t=1295319

  17. If you still have 'Error' appearing when turning on Wi-Fi after following all steps above, then contact us.

 

DOC-36228